My app has about 100,000 downloads and the following error is being
reported in my market console a few times a week (i.e. it's a rare but
consistent problem):

java.lang.RuntimeException: Unable to instantiate activity
ComponentInfo{com.spacer.test/com.spacer.test.MainActivity}:
java.lang.ClassNotFoundException: com.spacer.test.MainActivity in
loader dalvik.system.PathClassLoader[/mnt/asec/com.spacer.test-2/
pkg.apk]
at
android.app.ActivityThread.performLaunchActivity(ActivityThread.java:
2585)
at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:
2679)
at android.app.ActivityThread.access$2300(ActivityThread.java:125)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:
2033)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:123)
at android.app.ActivityThread.main(ActivityThread.java:4627)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:521)
at com.android.internal.os.ZygoteInit
$MethodAndArgsCaller.run(ZygoteInit.java:868)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.ClassNotFoundException:
com.spacer.test.MainActivity in loader dalvik.system.PathClassLoader[/
mnt/asec/com.spacer.test-2/pkg.apk]
at dalvik.system.PathClassLoader.findClass(PathClassLoader.java:243)
at java.lang.ClassLoader.loadClass(ClassLoader.java:573)
at java.lang.ClassLoader.loadClass(ClassLoader.java:532)
at android.app.Instrumentation.newActivity(Instrumentation.java:1021)
at
android.app.ActivityThread.performLaunchActivity(ActivityThread.java:
2577)
... 11 more

As no users have contacted me about when and where this problem arises
I have very little go on. I've tested my app on about 10 hardware
devices though and I cannot replicate this problem. My app only has
two activities and I can launch them both just fine. I've only ever
seen errors like the above when I've put the wrong class names in my
manifest files.

Does anyone have any hints about what could cause the above?

-- 
You received this message because you are subscribed to the Google
Groups "Android Developers" group.
To post to this group, send email to android-developers@googlegroups.com
To unsubscribe from this group, send email to
android-developers+unsubscr...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/android-developers?hl=en

Reply via email to