php nizi suhosin patzh ile derlemişsiniz.
aslında yararlı bir patch olmasına karşın zaman zaman bu gibi php
scriptlerinin kullandığı kodlardan dolayı false alarm vererek uuygulamaların
çalışmamasına neden olmakta.
aynı sorunla bende sunucularımın üzerindeki phpmyadmin amaçlı kullanıcılar
tarafından adılan pma dizinlerinin çalışmasınında da yaşamıştım.
php yi suhosin patch olmadan yeniden derleyip kurarak (çalışan sistem
olduğundan biraz zahmetli olmuştu) sorunu aşmıştım.

kolay gelsin...

23 Nisan 2009 Perşembe 23:03 tarihinde Murat Sürücü <
msur...@karaelmas.edu.tr> yazdı:

> Merhabalar,
> Freebsd üzerinde zamanlı çalışan bir php script var, mssql sunucuya
> bağlanıp
> basit bir SQL sorgusu çalıştırıp sonucu bir dosyaya yazıyor. PHP script her
> çalıştığında aşağıdaki gibi uyarı alıyorum.
>
> Apr 23 22:58:00 testsunucu suhosin[4992]: ALERT - canary mismatch on
> efree()
> - heap overflow detected (attacker 'REMOTE_ADDR not set', file 'unknown')
>
> Bu tarz bir sorunla karşılaşan oldu mu hiç?
>
> Teşekkürler.
>
> Murat SÜRÜCÜ
>
>
>
> __________ ESET NOD32 Antivirus Akylly Güvenlik tarafyndan sa?lanan
> bilgiler, virüs imza veritabany sürümü: 4031 (20090423) __________
>
> Yleti ESET NOD32 Antivirus Akylly Güvenlik tarafyndan denetlendi.
>
> http://www.nod32.com.tr
>
>
>
> FreeBSD 6 kitabi: http://www.acikakademi.com/catalog/freebsd6
> ---------------------------------------------------------------------
> Listeye soru sormadan once lutfen http://ipucu.enderunix.org sitesine
> bakiniz.
>
> Cikmak icin, e-mail: freebsd-unsubscr...@lists.enderunix.org
> Liste arsivi: http://news.gmane.org/gmane.org.user-groups.bsd.turkey
>
>
>


-- 
İyi çalışmalar...
Mesut GÜLNAZ

Cevap