On February 24, 2017 11:36:19 AM PST, Ricardo Neri
>On Fri, 2017-02-24 at 11:11 -0800, Andy Lutomirski wrote:
>> > In a previous version Andy Lutomirsky suggested that
>> > if (user_mode(regs) && (fixup_umip_exception(regs) == 0))
>> > was easier to read :). Although at the time fixup_umip_exception
>> > returned a numeric value. Now it only returns true/false for
>> > successful/failed emulation. If with true/false not comparing to
>> > makes it easier to read, I will make the change.
>> I think == true is silly :)
>Then I'll make the change.
>Thanks and BR,
It's worse than silly, it is potentially toxic.
true is a macro which it's defined as 1. Thus
foo == true
... doesn't actually mean what people *think* it does, which is roughly the
same thing as
However, if foo is not a boolean, this is *very* different; consider if foo is
Sent from my Android device with K-9 Mail. Please excuse my brevity.
To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html