On 04/04/2017 11:39 AM, Martin Schreiber wrote:
> On Tuesday 04 April 2017 17:12:37 Jon Foster wrote:
>> Martin,
>> Per your request in the discussion we were having in the fpGUI news groups
>> about the "need" for form files and streaming form layouts I will detail
>> what I remember of my trial runs of recent MSEgui versions. I used 4.4
>> (4.4.1 I think) and 3.8.8. 4.4.x worked better in the visuals department.
>> The problems I ran into fall roughly in three categories:
> [...]
> Which operating system/window manager?
> Can you try again with current git master version:
> https://gitlab.com/mseide-msegui/mseide-msegui/tree/master
> so we can sort out the problems?
> Please compile MSEide in clone-directory with
> fpc -Fulib/common/* -Fulib/common/kernel/linux apps/ide/mseide.pas
OK, I cloned the git repo and compiled MSEide. Almost all of the problems 
persist. Still too numerous for me to do much with it.

My current desktop setup and the one I've been using for years:
Debian 7 i386. Enlightenment 0.16.x (aka E16-1.0.0). Intel Core 2 x 4 
@3GHz. Using Xorg 1.12.4 with ATI video card & 2 monitors. Looks like it is 
using the Xorg supplied ATI Radeon driver, with RandR and such. Also have 
an Intel based notebook in basically the same configuration... except its 
using the "fbdev" video driver instead of Intel's since it was too buggy. 
The hardware is too new for the driver.

>> 1. Z-Ordering problems: Forms falling / rising unexpectedly. The worst
>> [...]
> Maybe a window manager with buggy NET_RESTACK_WINDOW protocol handling.
> Starting MSEgui applications with --NORESTACKWINDOW activates a workaround,
>> 2. Form content disappearing. Particularly with the 3.x version using the
>> [...]
> That looks similar like an effect of a buggy RADEON driver
> https://bugs.freedesktop.org/show_bug.cgi?id=69543
> https://bugs.freedesktop.org/show_bug.cgi?id=84253
> Switching off EXAPIXMAPS helps, see README.TXT.
Fascinating this appears to be the case. The fbdev driver on the notebook 
does not have this issue. Things sure seem to have gone downhill since Xorg 
took over for Xfree86.

Assuming your also correct about WM issues with #1 above I still have to 
say that all of the other software on my system is running without these 
issues. I'm not going to invest any more time into this ... unless I can 
find the time to get the current Enlightenment going. Everything is too 
fine tuned to disrupt.
>> 3. Won't connect to MySQL: In 3.x I'd get an "Access Violation" after
>> setting the properties and then setting the "connected" property to true.
>> [...]
> That should already been fixed.
> http://www.mail-archive.com/mseide-msegui-talk@lists.sourceforge.net/msg10791.html
> A heavy regression, sorry.
This is fixed in "master".
> [...] 

Jon Foster
JF Possibilities, Inc.

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
mseide-msegui-talk mailing list

Reply via email to