On 11/09/2016 09:21 PM, Vincent Bernat wrote:
  ❦  9 novembre 2016 11:56 -0500, Stephen Clark <sclar...@earthlink.net> :

LIBS ......... : -L/usr/pgsql-9.4/lib -ldl -L/usr/local/lib -lpfring
-lpcap -lrt -lnuma -lz -lpthread
If libpfring is linked to one version of libpcap and your local libpcap
is another one, there will a version conflict unless libpcap symbols are
versioned (they are not). Could you check with ldd what is in libpfring,
dependency-wise?
Yes, that is probably what is happening. The pf_ring from ntopng
replace libpcap with its own
version that uses pf_ring.




Yes, that is probably what is happening. The pf_ring from ntopng
replace libpcap with its own
version that uses pf_ring.
So, if libpfring is exporting directly the bpf_validate symbols (could
you check with objdump -T?), you can try to not link with -lpcap at all.
I just took the easy way out and compiled on a system that didn't have pf_ring installed.
Thanks for the info though.

Steve




_______________________________________________
pmacct-discussion mailing list
http://www.pmacct.net/#mailinglists

Reply via email to