[gentoo-user] Where is the file which masks glibc-2.18?

2013-09-05 Thread 东方巽雷
I cannot find glibc-2.18 in /usr/portage/profile/package.mask,but glibc-2.18 is being masked.I would like to know which file masks glibc-2.18.

[gentoo-user] glibc security issue

2016-02-17 Thread Meino . Cramer
Hi, I found this http://www.heise.de/newsticker/meldung/glibc-Dramatische-Sicherheitsluecke-in-Linux-Netzwerkfunktionen-3107621.html and the daily update contains an update to glibc. Is this the patch, which fixes that problem? Best regards, Meino

[gentoo-user] How to update glibc

2017-08-19 Thread Raphael MD
Hi, Emerge is asking to update glibc because old is masked and it'll be removed. But, how to update glibc? Gentoo only talk about to update gcc, but my gcc it's up to date. Thanks

Re: [gentoo-user] package.mask

2006-04-12 Thread Nagatoro
Niki Balov wrote: Hi there, i want to ask how to mask versions of glibc above 2.4? I compile my entire system with gcc3.4.5 and glibc 2.4 and i don't want to upgrade them. I added the following lines in package.mask sys-devel/gcc-3.4.5 sys-libs/glibc-2.4 sys-devel/gcc-3.4.5 sys-libs/glibc-2.4

[gentoo-user] glibc build problem

2014-03-05 Thread microcai
he guys. I'm having trouble compiling glibc. No matter I tried with binutils 2.23 2.24. or - live version, I got ld internal error in x86_64_relocation . And the same error repeated with glibc-2.18 and glibc-2.19 . Don't know why . The google bring me a old bug report about

[gentoo-user] glibc-2.18 build problem

2014-03-07 Thread microcai
I'm having trouble compiling glibc. No matter I tried with binutils 2.23 2.24. or - live version, I got ld internal error in x86_64_relocation . And the same error repeated with glibc-2.18 and glibc-2.19 . Don't know why . The google bring me a old bug report about

[gentoo-user] emerge error with glibc and nptl

2005-07-14 Thread kristina clair
Hi, I'm trying to update glibc with nptl and nptlonly USE flags, but I'm getting an error. The emerge command I'm running is: emerge --newuse -buD glibc The error is: Install glibc-2.3.4.20041102-r1 into /var/tmp/portage/glibc-2.3.4.20041102-r1/image/ category sys-libs /usr/portage/sys-libs

Re: [gentoo-user] emerge error with glibc and nptl

2005-07-14 Thread Zac Medico
kristina clair wrote: Hi, I'm trying to update glibc with nptl and nptlonly USE flags, but I'm getting an error. The emerge command I'm running is: emerge --newuse -buD glibc The error is: Install glibc-2.3.4.20041102-r1 into /var/tmp/portage/glibc-2.3.4.20041102-r1/image

[gentoo-user] two glibcs with different version

2010-04-30 Thread Kraus Philipp
Hello, I must test a software with a older version of the glibc. I run the 2.11.1 now but for one tool I need a previous version (2.6.1). How can I compile the glibc without changing my system glibc. I would like to set the previous glibc with the LD_PATH. Can I run two different versions

Re: [gentoo-user] Where is the file which masks glibc-2.18?

2013-09-05 Thread Wang Xuerui
2013/9/5 东方巽雷 dongfangxun...@gmail.com: I cannot find glibc-2.18 in /usr/portage/profile/package.mask,but glibc-2.18 is being masked.I would like to know which file masks glibc-2.18. Isn't it KEYWORD=? I noticed its ebuild's KEYWORDS line is commented out.

[gentoo-user] glibc-2.20 and intel microcode

2014-11-10 Thread microcai
I've finnally detected the root cause of glibc-2.20 broken my system: glibc-2.20 start using TLX instruction which is disabled by microcode update. disabling microcode update brings my system back to live! so, there is either a bug in CPU , nor glibc has borken CPU feature detection.

Re: [gentoo-user] How to update glibc

2017-08-19 Thread Branko Grubic
On Sat, 19 Aug 2017 11:39:40 -0300 Raphael MD <raph...@gmail.com> wrote: > Hi, > > Emerge is asking to update glibc because old is masked and it'll be > removed. > > But, how to update glibc? > Gentoo only talk about to update gcc, but my gcc it's up to date. > &g

Re: [gentoo-user] Changing glibc

2014-08-18 Thread Kerin Millar
On 18/08/2014 19:06, Timur Aydin wrote: Hi, I am using a closed source software package on my 64 bit gentoo linux system. The software package is beyond compare by scooter soft. Because of the way this package is built, it needs a specially patched version of glibc. I have patched my existing

[gentoo-user] glibc problem on amd64

2006-03-22 Thread Keats
hi, i have a gento on a ~x86 that udpate sucessfully but on a ~amd64 it failed on emerge... (the processor is in reality a xeon w emt64 ) here are the last lines of the emerge... thanx for suggestion... it's boring cause i m still using the glibc from the stage3 installation... so it's

[gentoo-user] asserts in glibc

2005-05-09 Thread Ian Monroe
There's currently an open bug in amaroK ( http://bugs.kde.org/show_bug.cgi?id=100049 ) where it appears xine crashs when an assert fails in glibc. I figured that this would only happen when someone was foolish enough to install a glibc with debug enabled. However today I talked to a user who had

Re: [gentoo-user] BUG in glibc????

2005-11-01 Thread John Myers
On Sunday 30 October 2005 13:54, capsel wrote: is it a bug in glibc or in my code? Probably not a bug in glibc. I'm 99% sure that there are no bugs that obvious in printf or strcmp. glibc is absolutely the most tested code in a GNU/Linux system, aside from the kernel itself, seeing

Re: [gentoo-user] glibc 2.4 - emere -e world necessary?

2006-05-04 Thread Hemmann, Volker Armin
On Thursday 04 May 2006 19:25, Alexander Skwar wrote: Hello! I'd now like to upgrade to glibc 2.4 as well. After having installed glibc 2.4, is it required to have a full emerge -e world run; ie. rebuild the entire system? no. glibc updates NEVER need a rebuild. Only if you change from gcc

Re: what about glibc upgrade (was: Re: [gentoo-user] gcc 4.1 with gentoo 2006.1)

2006-08-31 Thread Hemmann, Volker Armin
On Thursday 31 August 2006 20:31, tdrueke wrote: Sorry for capturing the thread. :) What about the glibc upgrade from 2.3 to 2.4. Does the same concerning emerge -e world apply here (e.g. it is recommended to do it) ? Or is it a more relaxed situation and simply emerging glibc 2.4

[gentoo-user] How do I turn off glibc's runtime error checks?

2011-07-01 Thread Nikos Chantziaras
This is driving me nuts. Since a few days ago, glibc will abort programs with a: *** glibc detected *** program: free(): invalid pointer: ... *** or similar error message. I have no idea which package was updated that triggered this. I did *not* emerge glibc (qlop confirms that I emerged

Re: [gentoo-user] Problems compiling glibc: Something wrong with the creation of docs...?

2017-01-15 Thread Zhu Sha Zang
Please, report appropriately at bugs.gentoo.com. Remember: * If you need support, post the output of `emerge --info '=sys-libs/glibc-2.23-r3::gentoo'`, * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-2.23-r3::gentoo'`. * The complete build log is located at '/var

[gentoo-user] nonfatal() not supported error in glibc binary install

2014-10-04 Thread Bruce Schultz
Hi, I'm trying to update a system using binary packages build on another system. I get this error for glibc: Emerging binary (1 of 1) sys-libs/glibc-2.19-r1::gentoo * glibc-2.19-r1.tbz2 MD5 SHA1 size ;-) ... [ ok ] Extracting info Failed to emerge sys

Re: [gentoo-user] Gentoo glibc-2.3.2 install help

2005-08-09 Thread Zac Medico
CJ Keist wrote: Hello all, First time user of Gentoo. We're wanting to run Matlab R14 SP2 64bit mode. According to Matlab site they support the Linux kernel 2.6.x and glibc-2.3.2. Non of the current linux distro (i.e. Fedora) has that old of glibc. So looking at Gentoo thinking I can

Re: [gentoo-user] How to fix circular dependency?

2010-09-06 Thread Alex Schuster
Ajai Khattri writes: On Sun, 5 Sep 2010, Dale wrote: Try this: emerge -1av =*glibc*-2.10.1-r1 # emerge -1av =*glibc*-2.10.1-r1 * IMPORTANT: 1 news items need reading for repository 'gentoo'. * Use eselect news to read news items. These are the packages that would be merged

[gentoo-user] Problems compiling glibc: Something wrong with the creation of docs...?

2017-01-14 Thread Meino . Cramer
Hi, while compiling glibc I got this: /var/tmp/portage/sys-libs/glibc-2.23-r3/work/build-x86-x86_64-pc-linux-gnu-nptl/manual/argp-ex1.c.texi /var/tmp/portage/sys-libs/glibc-2.23-r3/work/build-x86-x86_64-pc-linux-gnu-nptl/manual/argp-ex2.c.texi /var/tmp/portage/sys-libs/glibc-2.23-r3/work

Re: [gentoo-user] Upgrade + gcc dilemma

2006-01-08 Thread Bob Sanders
system - emerge -e system, has to be done once and that gets everything in the system profile built with gcc 3.4. However, both gcc and glibc need to be rebuilt again after the first pass, and anything using glibc needs to be rebuilt after glibc has been recompiled, thus the - emerge -e world

Re: [gentoo-user] Cleaning up installation / two glibc versions

2008-06-08 Thread Dirk Heinrichs
Am Sonntag, 8. Juni 2008 schrieb Nicolai Beuermann: Basic question: Why do I need two versions of glibc? You don't. equery depends =sys-libs/glibc-2.6.1 lists about 30 entries equery depends =sys-libs/glibc-2.3.4.20040808-r1 lists 27 entries of which some are the same some are different

[gentoo-user] Re: glibc-2.5

2007-02-11 Thread »Q«
In news:[EMAIL PROTECTED], Marc Blumentritt [EMAIL PROTECTED] wrote: after syncing portage yesterday, an update for glibc from 2.4-r4 to 2.5 is shown. Is there anything special to do after this update? Last time glibc was updated you had to rebuild world, if I remember correct. IIRC, last

Re: [gentoo-user] glibc 2.4 - emere -e world necessary?

2006-05-05 Thread Graham Murray
Hemmann, Volker Armin [EMAIL PROTECTED] writes: glibc updates NEVER need a rebuild. Only if you change from gcc 3.X to 4.Y you have to rebuild. But not because of a glibc update. That is not always true. A glibc upgrade *can* require that *some* packages are re-built. I am not an expert

[gentoo-user] Re: Dovecot... is the bugzilla material?

2006-06-27 Thread reader
Neil Bothwick [EMAIL PROTECTED] writes: Reading that thread, it would appear that for this to happen you have to have installed =linux-headers-2.6.16 but not recompiled glibc. Check the dates from genlop glibc genlop linux-headers If the former is earlier, re-emerge it. Doesn't appear

[gentoo-user] amarok 1.4.1 and new libvisual problem

2006-07-03 Thread Kenton Groombridge
Amarok 1.4.1 adds support for the new libvisual, however only a few of the visualizations are functioning. When I select most of them, I get the following at the command prompt: *** glibc detected *** /usr/bin/amarok_libvisual: munmap_chunk(): invalid pointer: 0x08067f78 *** *** glibc detected

[gentoo-user] emerge - system error

2006-07-22 Thread James Lockie
checking size of long double... configure: error: cannot compute sizeof (long double), 77 See `config.log' for more details. !!! ERROR: sys-libs/glibc-2.3.6-r4 failed. Call stack: ebuild.sh, line 1539: Called dyn_compile ebuild.sh, line 939: Called src_compile glibc-2.3.6-r4.ebuild, line

[gentoo-user] Changing glibc

2014-08-18 Thread Timur Aydin
Hi, I am using a closed source software package on my 64 bit gentoo linux system. The software package is beyond compare by scooter soft. Because of the way this package is built, it needs a specially patched version of glibc. I have patched my existing glibc version (2.18) and have been

[gentoo-user] Re: Changing glibc

2014-08-18 Thread James
Timur Aydin ta at taydin.org writes: I am using a closed source software package on my 64 bit gentoo linux system. The software package is beyond compare by scooter soft. Because of the way this package is built, it needs a specially patched version of glibc. I have patched my existing

[gentoo-user] downgrading glibc

2017-08-18 Thread Raffaele Belardi
I hava a build problem upgrading Mythtv to 0.28.1-r1 [1] on an ~amd64 system. The problem is related to a glibc API change [2] introduced in glibc-2.24 and still present in glibc-2.25. So I'm thinking to try the build with an older glibc version. Downgrading the system to glibc to 2.23-r3 means

[gentoo-user] glibc fail on rebuild

2006-05-28 Thread Stuart Howard
Hi I have just changed some USE flag settings, and the resulting emerge -N asks to rebuild glibc however when I run it, it simply stops and drops back to the command line with no actual complaint. The output is as below much is snipped for clarity, if anyone has a suggestion or something I can

Re: [gentoo-user] emerge error with glibc and nptl

2005-07-14 Thread kristina clair
I'm trying to update glibc with nptl and nptlonly USE flags, but I'm getting an error. The emerge command I'm running is: emerge --newuse -buD glibc The error is: Install glibc-2.3.4.20041102-r1 into /var/tmp/portage/glibc-2.3.4.20041102-r1/image/ category sys-libs /usr

Re: [gentoo-user] etc/host.conf: line 24: bad command `mdns off'

2006-02-21 Thread Rumen Yotov
On Tuesday 21 February 2006 17:59, Francesco Riosa wrote: Iain Buchanan wrote: Since my recent upgrade of glibc from glibc-2.3.6-r2 (Jan 18) to glibc-2.3.6-r3 (Feb 21) I'm getting this error when starting emacs and doing various other things: etc/host.conf: line 24: bad command `mdns

Re: [gentoo-user] glibc

2005-04-29 Thread Andres Järv
No.On 4/29/05, Jose Moreira [EMAIL PROTECTED] wrote: hello, i'm recompiling glibc to suport userlocales. do i nedd torecompile my software?

Re: [gentoo-user] UT2004 crashed!

2005-06-11 Thread Raphael Melo de Oliveira Bastos Sales
Did you recently recompiled glibc? 2 of the files on the log are part of glibc. Maybe it is that reason. If not, downgrading it may help. -- gentoo-user@gentoo.org mailing list

Re: [gentoo-user] Re: After update to glibc-2.4: /usr/bin/python: relocation error: /lib/libresolv.so.2: symbol __res_iclose, version GLIBC_PRIVATE not defined in file libc.so.6 with link time re

2006-03-11 Thread Rumen Yotov
On Sunday 12 March 2006 05:48, Sven Köhler wrote: Oh, I just noticed the following: [EMAIL PROTECTED] ~ $ ls -lad /var/db/pkg/*/*glibc* drwxr-xr-x 2 root root 864 19. Feb 19:13 /var/db/pkg/sys-libs/glibc-2.3.6-r3 drwxr-xr-x 2 root root 856 11. Mär 21:49 /var/db/pkg/sys-libs/glibc-2.4

[gentoo-user] Glibc-2.4 and Gcc-4.0.3??

2006-05-08 Thread Jerry McBride
Anyone here running a ~x86 box and have the latest glibc and a 4.0.3 gcc running on it? Any hurdles to leap? Thanks in advance, Jerry -- gentoo-user@gentoo.org mailing list

Re: [gentoo-user] glibc builds but won't install

2005-08-17 Thread Benno Schulenberg
darren kirby wrote: Also, I have rebuilt the glibc several times through this ordeal, and at 5-6 hours per pop it is getting tedious to try new things. Glibc _was_ built correctly, so is there anyway I can manually copy the rest of the files from the portage sandbox to the live filesystem

[gentoo-user] glibc and gcc updated to 2.3.5

2005-08-17 Thread Grant
I noticed my glibc and gcc were updated to 2.3.5 in my last big emerge world. Should I run an emptytree emerge now? - Grant -- gentoo-user@gentoo.org mailing list

[gentoo-user] glibc update and CHOST problem

2006-08-31 Thread Neil Isaac
I'm trying to upgrade to glibc-2.4-rc3 (in x86 stable) and get the following error: Emerging (1 of 2) sys-libs/glibc-2.4-r3 to / checking glibc-linuxthreads-20060605.tar.bz2 ;-) checking glibc-powerpc-cpu-addon-v0.01.tgz ;-) * glibc-2.4 is nptl-only! * NPTL requires a CHOST of i486

[gentoo-user] Re: valgrind showing glibc warnings

2010-03-25 Thread Nikos Chantziaras
On 03/25/2010 04:09 PM, Crístian Viana wrote: hi, when I use valgrind, it shows hundreds of warnings related to glibc. Rebuild valgrind. This usually fixes this.

Re: [gentoo-user] glibc-2.18 build problem

2014-03-21 Thread Tom Wijsman
On Fri, 7 Mar 2014 18:43:27 +0800 microcai micro...@fedoraproject.org wrote: I'm having trouble compiling glibc. No matter I tried with binutils 2.23 2.24. or - live version, I got ld internal error in x86_64_relocation . And the same error repeated with glibc-2.18 and glibc

[gentoo-user] glibc unmerged by accident

2007-11-12 Thread de Almeida, Valmor F.
Hello, After a successful upgrade from profile 2006.1 to 2007.0, I decided to unmerge some unused packages from world and accidentally had glibc on the emerge command line from a cut and paste operation. glibc was unmerged and now I can't use common shell commands such as ls or cp to list

[gentoo-user] Re: glibc unmerged by accident

2007-11-13 Thread Alexander Skwar
Florian Philipp [EMAIL PROTECTED] wrote: On Mon, 2007-11-12 at 18:49 -0500, de Almeida, Valmor F. wrote: glibc was unmerged and now I can't use common shell commands such as ls or cp to list and copy files from a backup. I am thinking that to fix this I will have to boot from a cd

Re: [gentoo-user] Re: glibc-2.4-r2: Problems with UTF-8 locale

2006-05-05 Thread Alexander Skwar
Jeremy Olexa wrote: Alexander Skwar wrote: Sven Köhler wrote: My glibc 2.3.6 (with userlocales turned off) never creates such locales. There's no such flag as userlocales. Sorry, I cannot help with the issue but I do know there is a userlocales flag, No, there *IS* not. There *used

Re: what about glibc upgrade (was: Re: [gentoo-user] gcc 4.1 with gentoo 2006.1)

2006-08-31 Thread Richard Fish
On 8/31/06, tdrueke [EMAIL PROTECTED] wrote: What about the glibc upgrade from 2.3 to 2.4. Does the same concerning emerge -e world apply here (e.g. it is recommended to do it) ? Or is it a more relaxed situation and simply emerging glibc 2.4 is enough ? When you emerge -e world for the gcc

Re: [gentoo-user] two glibcs with different version

2010-05-01 Thread pk
On 2010-04-30 15:24, Kraus Philipp wrote: I must test a software with a older version of the glibc. I run the 2.11.1 now but for one tool I need a previous version (2.6.1). How can I compile the glibc without changing my system glibc. I would like to set the previous glibc with the LD_PATH

Re: [gentoo-user] glibc 2.13 warning

2011-02-08 Thread Alan McKinnon
Apparently, though unproven, at 15:34 on Monday 07 February 2011, Neil Bothwick did opine thusly: Don't install glibc-2.13 if you either use prelinking or run postfix. After testing it on my netbook, which uses neither, I installed it on my desktop and home server and broke both. hehe, I'm

Re: [gentoo-user] glibc-2.20 and intel microcode

2014-11-10 Thread Samuli Suominen
On 11/11/14 05:49, micro...@fedoraproject.org wrote: I've finnally detected the root cause of glibc-2.20 broken my system: glibc-2.20 start using TLX instruction which is disabled by microcode update. disabling microcode update brings my system back to live! so, there is either a bug

[gentoo-user] glibc-2.24-r2 failed (install phase)

2017-06-15 Thread tuxic
Hi, While updateing glibc-2.24-r2 failed to install. These are the last few lines of that process: al/execinfo.c.texi /var/tmp/portage/sys-libs/glibc-2.24-r2/work/build-amd64-x86_64-pc-linux-gnu-nptl/manual/add.c.texi /var/tmp/portage/sys-libs/glibc-2.24-r2/work/build-amd64-x86_64-pc

RE: [gentoo-user] NPTL and glibc

2005-04-29 Thread Dave Nebinger
You can also set the nptlonly flag for glibc, which will avoid using linuxthreads at all (forces everything to use nptl). If you look at the OP's message, it appeared that he did have the nptlonly flag set... There is the message about glibc/gcc masking off some use flags for stability

[gentoo-user] glibc-2.5

2007-02-11 Thread Marc Blumentritt
Hi, after syncing portage yesterday, an update for glibc from 2.4-r4 to 2.5 is shown. Is there anything special to do after this update? Last time glibc was updated you had to rebuild world, if I remember correct. Thanks in advance Marc -- gentoo-user@gentoo.org mailing list

Re: [gentoo-user] Fwd: FontForge needs conversion from ISO-8859-1 to UCS2 - iconv (glibc-2.3.5-r2) does not support it on amd64

2006-05-04 Thread Michael [Plouj] Ploujnikov
This is fixed in glibc-2.3.6-r4 and glibc-2.4-r2 now: https://bugs.gentoo.org/show_bug.cgi?id=131386 -- gentoo-user@gentoo.org mailing list

Re: [gentoo-user] glibc builds but won't install

2005-08-15 Thread Neil Bothwick
On Mon, 15 Aug 2005 16:45:31 -0700, darren kirby wrote: Isn't locales.build supposed to get glibc to _not_ build any other locales? Only if you emerge glibc with the userlocales USE flag. -- Neil Bothwick Psychiatrists say that 1 of 4 people are mentally ill. pgpeACGv2Sutw.pgp

[gentoo-user] glibc 2.4 nptlonly?

2006-08-31 Thread Sven Köhler
Hi, is there any of the big distributions like SuSE, Fedora or Debian who use glibc 2.4 too? And if they do, do they also only include a nptlonly-glibc? Just wondering. Sven signature.asc Description: OpenPGP digital signature

Re: [gentoo-user] glibc 2.13 warning

2011-02-08 Thread Neil Bothwick
On Tue, 8 Feb 2011 23:49:33 +0200, Alan McKinnon wrote: hehe, I'm safe :-) I've hardmasked =glibc-2.12 ever since the blatantly untested cock up that was the first testing version of glibc-2.12 hit the tree Now if only you could mask your smugness plugin :P

[gentoo-user] sys-libs/glibc-2.15-r1

2012-04-22 Thread Stefan G. Weichinger
Just browsed the changelog of glibc-2.15: http://sourceware.org/ml/libc-alpha/2012-03/msg00836.html When I read the NEWS section there with all that optimized stuff I wonder if it makes any sense to rebuild packages here after upgrading glibc? Stefan

Re: [gentoo-user] glibc security issue

2016-02-17 Thread Max R.D. Parmer
Yes, looks like it is: https://security.gentoo.org/glsa/201602-02 -- 0x7D964D3361142ACF On Wed, Feb 17, 2016, at 08:48, meino.cra...@gmx.de wrote: > Hi, > > I found this > http://www.heise.de/newsticker/meldung/glibc-Dramatische-Sicherheitsluecke-in-Linux-Netzwerkfunktionen-

[gentoo-user] glibc 2.4-r3 upgrade dies

2006-09-20 Thread James
Hello, Routinely upgrading an older Pentium Pro system, I get this glibc error: snip a - elf/framestate.os a - elf/unwind-pe.os : /var/tmp/portage/glibc-2.4-r3/work/build-default-i686-pc-linux-gnu-nptl/ libc_pic.a i686-pc-linux-gnu-gcc -nostdlib -nostartfiles -r -o /var/tmp/portage/glibc-2.4

Re: [gentoo-user] glibc upgrade and firefox/seamonkey issues

2015-10-22 Thread Alan Mackenzie
Hello, Dale. On Wed, Oct 21, 2015 at 07:57:32PM -0500, Dale wrote: > Howdy, > I recently did a upgrade which included glibc. Now both Firefox and > Seamonkey has problems starting. I have several profiles and some work > and some don't. Using safe-mode works which ma

[gentoo-user] Cannot emerge glibc

2005-07-16 Thread Alexander Veit
Hi, When I try to emerge -u world, the only package that's going to be updated is glibc. However the build fails with the following error: --- snip --- /var/tmp/portage/glibc-2.3.5/work/build-default-i586-pc-linux-gnu-linuxthrea ds/linuxthreads/libpthread_pic.a(pthread.os)(.text+0x1cd

[gentoo-user] Emerge of glibc-2.3.5-r1 fails

2005-09-01 Thread Lincoln Baxter
Hi, I consistently get an ACCESS DENIGHED error will trying to emerge glibc. Does anyone else get this: make[2]: Entering directory `/scratch/i686/portage.tmp/portage/glibc-2.3.5-r1/work/glibc-2.3.5/timezone' /bin/install -c /build/portage.tmp/portage/glibc-2.3.5-r1/work/build-default-i686-pc

Re: [gentoo-user] glibc-2.17 fails and warning: setlocale: LC_ALL error

2014-07-14 Thread Dale
system which will also update everything as well. My problem is glibc and the locale settings. May be a separate issue or related. Here is the boo boo. localhost linux # emerge -v glibc sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF8) * IMPORTANT: 5 news items need

Re: [gentoo-user] glibc unmerged by accident

2007-11-13 Thread Graham Murray
de Almeida, Valmor F. [EMAIL PROTECTED] writes: I am thinking that to fix this I will have to boot from a cd and emerge glibc. I do not think it will be that simple. The problem is that once you chroot to /mnt/gentoo all subsequent commands (including emerge and gcc) will be looking for /lib

Re: [gentoo-user] glibc unmerged by accident (solved)

2007-11-18 Thread Neil Bothwick
On Sun, 18 Nov 2007 15:05:24 -0500, de Almeida, Valmor F. wrote: What's wrong with tar xf glibc-2.6.1.tbz2 -C /mnt/gentoo? It's worked for me in the past when I upgraded to a broken glibc. I was not sure what would happen with other files in some of the existing directories. Just

[gentoo-user] emerging -u sendmail glibc fails -- LD_LIBRARY_PATH issue

2006-01-24 Thread Jason Ausmus
Hello, Emerging -u sendmail fails with this message: checking LD_LIBRARY_PATH variable... contains current directory configure: error: *** LD_LIBRARY_PATH shouldn't contain the current directory when *** building glibc. Please change the environment variable *** and run configure again

Re: [gentoo-user] glibc-2.5

2007-02-11 Thread Bo Ørsted Andresen
On Sunday 11 February 2007 11:42:29 Marc Blumentritt wrote: after syncing portage yesterday, an update for glibc from 2.4-r4 to 2.5 is shown. Is there anything special to do after this update? Last time glibc was updated you had to rebuild world, if I remember correct. glibc-2.4.x was special

Re: [gentoo-user] Re: glibc-2.4-r2: Problems with UTF-8 locale

2006-05-05 Thread Alexander Skwar
Sven Köhler wrote: Yesterday I updated from glibc-2.4-r1 to glibc-2.4-r2. Since then, I've got problems with my UTF-8 locale. I suppose, that is because the UTF-8 denomination seems to have changed from .UTF-8 to .utf8: .UTF-8 changed from .utf8? Yep. That's not true. Wrong, it is. My

Re: [gentoo-user] glibc 2.4 nptlonly?

2006-08-31 Thread Jan-Hendrik Zab
On Thu, 31 Aug 2006 12:35:20 +0200 Sven Köhler [EMAIL PROTECTED] wrote: Hi, is there any of the big distributions like SuSE, Fedora or Debian who use glibc 2.4 too? And if they do, do they also only include a nptlonly-glibc? Just wondering. AFAIK there is a glibc 2.4 RPM available

[gentoo-user] Re: valgrind showing glibc warnings

2010-03-25 Thread Nikos Chantziaras
On 03/25/2010 08:31 PM, Crístian Viana wrote: I think --gen-suppressions may be a too complicated solution. valgrind shouldn't find *any* warnings from the libraries of my system at all. either valgrind is doing something wrong or there's really some errors on glibc. in every other system I try

Re: [gentoo-user] two glibcs with different version

2010-05-01 Thread Graham Murray
Kraus Philipp philipp.kr...@flashpixx.de writes: Hello, I must test a software with a older version of the glibc. I run the 2.11.1 now but for one tool I need a previous version (2.6.1). How can I compile the glibc without changing my system glibc. I would like to set the previous glibc

Re: [gentoo-user] two glibcs with different version

2010-05-01 Thread Kraus Philipp
Am 01.05.2010 um 12:53 schrieb pk: On 2010-04-30 15:24, Kraus Philipp wrote: I must test a software with a older version of the glibc. I run the 2.11.1 now but for one tool I need a previous version (2.6.1). How can I compile the glibc without changing my system glibc. I would like to set

Re: [gentoo-user] glibc 2.13 warning

2011-02-11 Thread Neil Bothwick
On Fri, 11 Feb 2011 17:32:20 +0100, Volker Armin Hemmann wrote: no, the 2.12.1 binpackage does not know which versions are installed. It just includes a version check. If no glibc is installed (and removing the /var/db/pkg/sys-libs/glibc-2.13 directory = no glibc installed) then you are free

[gentoo-user] Re: How do I turn off glibc's runtime error checks?

2011-07-02 Thread Nikos Chantziaras
On 07/02/2011 12:32 PM, Ivan T. Ivanov wrote: Hi, On Sat, 2011-07-02 at 04:18 +0300, Nikos Chantziaras wrote: On 07/02/2011 03:05 AM, Nikos Chantziaras wrote: This is driving me nuts. Since a few days ago, glibc will abort programs with a: *** glibc detected *** program: free(): invalid

Re: [gentoo-user] Re: linux-headers-2.6.38

2011-08-11 Thread Pandu Poluan
On Thu, Aug 11, 2011 at 07:50, Nikos Chantziaras rea...@arcor.de wrote: On 08/10/2011 04:02 PM, c...@chrekh.se wrote: There is at least a theoretical benifit if you set NPTL_KERN_VER=2.6.38 in make.conf and recompile glibc. That way glibc could use things not present in older kernels. glibc

[gentoo-user] glibc memory corruption

2011-09-08 Thread Bill Kenworthy
What would cause this? bunyip rpm # /opt/vmware/lib/vmware/bin/vmware *** glibc detected *** /opt/vmware/lib/vmware/bin/vmware: malloc(): memory corruption: 0x09f35e80 *** ^C bunyip rpm # Ive tried doing a emerge -ep world glibc is * sys-libs/glibc Latest version available: 2.12.2

[gentoo-user] Re: Pentim Pro and glibc-2.4.3

2006-09-07 Thread James
James wireless at tampabay.rr.com writes: Hello, OOPS, I forgot to include error 1... ship /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/../../../../i686-pc-linux-gnu/bin/ld: Warning: size of symbol `_itoa' changed from 193 in /var/tmp/portage/glibc-2.4-r3/work/ build-default-i686-pc-linux-gnu-nptl

[gentoo-user] emerged glibc does not work

2005-04-17 Thread Erik
Hello, now I tried again to emerge the new version of glibc, but it failed again. After the emerge (and even after rebooting), some important programs, such as login and python no longer work. They cause segmentation fault. To boot the system I had to add init=/bin/bash to the GRUB command line

[gentoo-user] Re: After update to glibc-2.4: /usr/bin/python: relocation error: /lib/libresolv.so.2: symbol __res_iclose, version GLIBC_PRIVATE not defined in file libc.so.6 with link time refere

2006-03-11 Thread Sven Köhler
Oh, I just noticed the following: [EMAIL PROTECTED] ~ $ ls -lad /var/db/pkg/*/*glibc* drwxr-xr-x 2 root root 864 19. Feb 19:13 /var/db/pkg/sys-libs/glibc-2.3.6-r3 drwxr-xr-x 2 root root 856 11. Mär 21:49 /var/db/pkg/sys-libs/glibc-2.4 Why do I have two glibc's installed? glibc

[gentoo-user] package.mask

2006-04-12 Thread Niki Balov
Hi there, i want to ask how to mask versions of glibc above 2.4? I compile my entire system with gcc3.4.5 and glibc 2.4 and i don't want to upgrade them. I added the following lines in package.mask sys-devel/gcc-3.4.5 sys-libs/glibc-2.4 but there is glibc-2.4-r1 and the system wants to upgrade. I

Re: [gentoo-user] glibc 2.4 - emere -e world necessary?

2006-05-05 Thread Hemmann, Volker Armin
On Friday 05 May 2006 08:12, Graham Murray wrote: Hemmann, Volker Armin [EMAIL PROTECTED] writes: glibc updates NEVER need a rebuild. Only if you change from gcc 3.X to 4.Y you have to rebuild. But not because of a glibc update. That is not always true. A glibc upgrade *can* require

[gentoo-user] Gentoo glibc-2.3.2 install help

2005-08-09 Thread CJ Keist
Hello all, First time user of Gentoo. We're wanting to run Matlab R14 SP2 64bit mode. According to Matlab site they support the Linux kernel 2.6.x and glibc-2.3.2. Non of the current linux distro (i.e. Fedora) has that old of glibc. So looking at Gentoo thinking I can build the Gentoo

[gentoo-user] emerge glibc

2005-08-21 Thread Thomas Naujokas
Last night I did an: emerge --update --deep world Reviewing logs this morning I find in 3125-glibc-2.3.5-r1.log the following: QA Notice: /usr/lib/misc/glibc/pt_chown is setXid, dynamically linked and using lazy bindings. This combination is generally discouraged. Try: CFLAGS

Re: [gentoo-user] Why is glibc ntpl+nptl-only?

2006-09-16 Thread Jure Varlec
On Friday 15 September 2006 07:07, Wolfgang Liebich wrote: Hi, For my new gentoo system I switched to the latest greatest profile - 2006.1. During the initial installation emerge told me glibc 2.4 is nptlonly - so I turned on the nptl and nptlonly USE flags in make.conf. Now my old linux

Re: [gentoo-user] Why is glibc ntpl+nptl-only?

2006-09-16 Thread Mick
On Saturday 16 September 2006 09:14, Jure Varlec wrote: Well, the new glibc-2.4 only supports nptl, unlike glibc-2.3 which supported both threading models. So if you want legacy linuxthreads, you have to stay with glibc-2.3. As for being better, glibc-2.4 is better than 2.3 IMHO. Also, nptl

[gentoo-user] Booting a Kernel-2.4 with glibc-2.9?

2009-07-08 Thread daid kahl
Hello, I'm working on upgrading a very old Gentoo system for my work. Some software is only running well in 2.4.x kernels, and when doing other updates I inadvertently updated past glibc-2.3.5, and so now the 2.4 kernel does not boot (Fatal error, kernel too old). Fortunately there is a 2.6

Re: [gentoo-user] Where is the file which masks glibc-2.18?

2013-09-05 Thread Alan McKinnon
On 05/09/2013 16:35, 东方巽雷 wrote: I cannot find glibc-2.18 in /usr/portage/profile/package.mask,but glibc-2.18 is being masked.I would like to know which file masks glibc-2.18. Sometimes masks like this are in the profile, but in this case Wang is correct. Here's how you find out: $ emerge -pv

[gentoo-user] How safe is it to change vanilla-USE-Flag in glibc?

2016-07-06 Thread Franz Fellner
Hey all, I have issues with some prgrams eating too much memory. This seems to be related to glibc not trimming as necessary which results in way too much memory still occupied by the program after free()ing memory. I can't use gcc (specifically g++) with quite some apps now because it starts

Re: [gentoo-user] glibc update

2009-03-18 Thread Alan McKinnon
On Wednesday 18 March 2009 13:23:47 Michael P. Soulier wrote: Hello, Looking at what I'm about to pick up via emerge, I notice this [ebuild U ] sys-libs/glibc-2.8_p20080602-r1 [2.6.1] This immediately sets off alarm bells for me, since glibc is the basis of the whole system. If I pick

[gentoo-user] sys-libs/glibc-2.3.6-r2 build error and locales

2006-01-28 Thread Martins Steinbergs
-8859-1 en_GB.UTF-8/UTF-8 lv_LV lv_LV/ISO-8859-13 lv_LV.UTF-8/UTF-8 is there all correct? now when i try rebuild glibc: mar martins # emerge -pv glibc These are the packages that I would merge, in order: Calculating dependencies ...done! [ebuild R ] sys-libs/glibc-2.3.6-r2 USE=nls userlocales

[gentoo-user] ipsec-tools-0.7.3 fails to build

2009-11-07 Thread Mick
Like so: i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I./../libipsec - D_GNU_SOURCE -include ./src/include-glibc/glibc-bugs.h -I./src/include-glibc - I./src/include-glibc -I./../../src/racoon/missing -D_GNU_SOURCE -include ../../src/include-glibc/glibc-bugs.h -I../../src/include-glibc

Re: [gentoo-user] ipsec-tools-0.7.3 fails to build

2009-11-07 Thread alex ponomarev
On Sat, Nov 7, 2009 at 8:10 PM, Mick michaelkintz...@gmail.com wrote: Like so: i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I./../libipsec - D_GNU_SOURCE -include ./src/include-glibc/glibc-bugs.h -I./src/include-glibc - I./src/include-glibc -I./../../src/racoon/missing

Re: [gentoo-user] ipsec-tools-0.7.3 fails to build

2009-11-07 Thread Mick
On Saturday 07 November 2009 17:16:48 alex ponomarev wrote: On Sat, Nov 7, 2009 at 8:10 PM, Mick michaelkintz...@gmail.com wrote: Like so: i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I./../libipsec - D_GNU_SOURCE -include ./src/include-glibc/glibc-bugs.h -I./src/include-glibc

Re: [gentoo-user] ipsec-tools-0.7.3 fails to build

2009-11-07 Thread Daniel Pielmeier
Mick schrieb am 07.11.2009 18:10: Like so: i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I./../libipsec - D_GNU_SOURCE -include ./src/include-glibc/glibc-bugs.h -I./src/include-glibc - I./src/include-glibc -I./../../src/racoon/missing -D_GNU_SOURCE -include ../../src/include-glibc

Re: [gentoo-user] ipsec-tools-0.7.3 fails to build

2009-11-07 Thread Mick
On Saturday 07 November 2009 18:30:16 Daniel Pielmeier wrote: Mick schrieb am 07.11.2009 18:10: Like so: i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I./../libipsec - D_GNU_SOURCE -include ./src/include-glibc/glibc-bugs.h -I./src/include-glibc - I./src/include-glibc -I

Re: [gentoo-user] gcc and glibc. Which unstable to pick?

2011-07-07 Thread Alan McKinnon
On Thursday 07 July 2011 16:01:27 Dale did opine thusly: As the list knows, I been having random lock ups on my system. I'm in the process of one last emerge -e world but I'm not holding my breath it will change anything. So, I'm wanting to try a unstable version of both gcc and glibc

  1   2   3   4   5   6   7   8   9   10   >