[gentoo-user] Re: curses of ncurses :(

2015-08-27 Thread James
J. Roeleveld joost at antarean.org writes: What is llvm actually used for? Enable llvm code generator for ghc (-fllvm). Build with llvm. Currently the package only builds against old versions of llvm. Enable LLVM backend for Gallium3D. Build the sparse-llvm utility hth, James

[gentoo-user] ebuild ChangeLog and emerge -l

2011-05-23 Thread Nikos Chantziaras
installed. Some other times it's less dramatic, but still contains stuff that should not show up. The above seems to be the norm rather than the exception. For example, right now I'm doing an update from llvm-2.9-r1 to llvm-2.9-r2, and emerge prints: *llvm-2.9-r2 23 May 2011; Bernard

Re: [gentoo-user] Emerge of sys-devel/llvm-3.3-r3 fails....

2014-08-11 Thread Volker Armin Hemmann
Am 10.08.2014 um 08:33 schrieb Christopher Kurtis Koeber: Hello, I am attempting to emerge xorg-server and sys-devel/llvm-3.3-r3 is pulled in as a dependency. So, when I emerge llvm it fails. Here is some relevant output: *emerge --info =sys-devel/llvm-3.3-r3::gentoo*: Pastebin: http

[gentoo-user] Re: Emerge of sys-devel/llvm-3.3-r3 fails....

2014-08-12 Thread Jouni Kosonen
Volker Armin Hemmann wrote: Am 10.08.2014 um 08:33 schrieb Christopher Kurtis Koeber: *emerge --info =sys-devel/llvm-3.3-r3::gentoo*: Pastebin: http://pastebin.com/qF92DXSY I am not a fan of that. gcc-4.7.3, Intel-R-_Atom-TM *End Section of Build Log*: Pastebin: http

Re: [gentoo-user] llvm not updating with @world

2017-03-04 Thread Michael Orlitzky
On 03/04/2017 10:18 AM, Dutch Ingraham wrote: > > So, that will bring in the update, just like emerge -1a sys-devel/llvm > will. > > But, why isn't --deep @world doing so? Is it bug-reporting time? > > (There is one other slight possible anomoly I could find: > 'equer

Re: [gentoo-user] llvm not updating with @world

2017-03-04 Thread Michael Orlitzky
On 03/04/2017 06:38 AM, Dutch Ingraham wrote: > Hi all - I'm running a systemd/hardened desktop with > ACCEPT_KEYWORDS="~amd64". > The result of an 'emerge -auDN --with-bdeps=y --complete-graph @world' is > 'Nothing to merge; quitting.' > > However, if I 'emerg

Re: [gentoo-user] Is there a reason why LLVM/Clang ebuilds don't support "mutislot"?

2016-08-29 Thread Jeremi Piotrowski
On Sun, Aug 28, 2016 at 11:58:03PM -0400, P Levine wrote: > Other distros like Ubuntu support the installation of multiple versions of > LLVM/Clang side by side. One of the things Clang is really good at is > support for the most recently approved upcoming features of the C++17 &

Re: [gentoo-user] How do I use LLVM?

2011-12-12 Thread Walter Dnes
On Mon, Dec 12, 2011 at 12:32:04AM -0500, Michael Mol wrote llvm is pulled in on most of my systems as a dependency of something else. It doesn't conflict with having gcc installed. emerge sys-devel/llvm And try again. If that fixes it, you should file a bug against the specific package

[gentoo-user] Re: llvm compile error

2014-03-15 Thread keeper
Silvio Siefke siefke_listen at web.de writes: Hello, i try to install llvm but it broke with: If you are still having an issue, a cause for this bug has been found. https://bugs.gentoo.org/show_bug.cgi?id=500856

Re: [gentoo-user] Is there a reason why LLVM/Clang ebuilds don't support "mutislot"?

2016-08-28 Thread Deven Lahoti
This also makes it difficult to use GHC's LLVM backend, since its compatible versions usually lag behind the current one.

[gentoo-user] How do I use LLVM?

2011-12-11 Thread Walter Dnes
And no, it's not because I'm adventurous. Background... I'm trying to revive an older Dell Dimension 530 (32 bit install) with a Radeon card that uses a binary blob from the radeon-ucode ebuild/download. When trying to emerge xorg-server, it fails with the message... configure: error: LLVM

[gentoo-user] ebuild for gcc-independent llvm and clang for linux

2013-12-25 Thread やまぐちたかゆき
Hello everybody, I'm going to build and install llvm and clang packages in my Linux PC as 1. Binaries of llvm and claag installed finally were compiled by clang. 2. The binaries of 1. depend on libc++.so instead of libstdc++.so. 3. libc++.so was installed by portage. 4. The binaries of llvm

[gentoo-user] Emerge of sys-devel/llvm-3.3-r3 fails....

2014-08-11 Thread Christopher Kurtis Koeber
Hello, I am attempting to emerge xorg-server and sys-devel/llvm-3.3-r3 is pulled in as a dependency. So, when I emerge llvm it fails. Here is some relevant output: emerge --info =sys-devel/llvm-3.3-r3::gentoo: Pastebin: http://pastebin.com/qF92DXSY End Section of Build Log: Pastebin

[gentoo-user] Is there a reason why LLVM/Clang ebuilds don't support "mutislot"?

2016-08-28 Thread P Levine
Other distros like Ubuntu support the installation of multiple versions of LLVM/Clang side by side. One of the things Clang is really good at is support for the most recently approved upcoming features of the C++17 standard. The best support for testing such features is with the latest sys-devel

[gentoo-user] llvm not updating with @world

2017-03-04 Thread Dutch Ingraham
Hi all - I'm running a systemd/hardened desktop with ACCEPT_KEYWORDS="~amd64". The result of an 'emerge -auDN --with-bdeps=y --complete-graph @world' is 'Nothing to merge; quitting.' However, if I 'emerge -1a sys-devel/llvm', I get: '[ebuild r U ] sys-devel/llvm-3.9.1-r1

[gentoo-user] Re: llvm compile error

2014-01-23 Thread walt
On 01/23/2014 01:05 PM, Silvio Siefke wrote: Hello, i try to install llvm but it broke llvm-3.4 ACCEPT_KEYWORDS=x86 Hi Silvio. You're installing an ~x86 package on an x86 machine, I think. Are you doing that on purpose? I don't know if that is causing the error, but it sometimes

[gentoo-user] rubinius fails to emerge with error about llvm-config

2012-08-19 Thread covici
Hi. In my update world of today, the system wanted to emerge rubinius -- for reasons known only to itself -- however it fails to emerge during its config phase with the following output: Configuring LLVM... Checking for existing LLVM tree: not found. Checking for 'llvm-config': Unrecognized

[gentoo-user] Re: llvm compile error

2014-01-24 Thread Holger Hoffstätte
Before this gets out of hand.. On Fri, 24 Jan 2014 19:44:38 +0100, Silvio Siefke wrote: llvm-3.4 is not hardmasked. It is marked ~x86 which is something very different. Correct, i mean Clang in version 3.4 is hardmasked. I want install clang alone llvm i not need. I think mesa use llvm

[gentoo-user] Latest LLVM wants to pollute my machine with VIM stuff.....

2017-03-15 Thread Andrew Lowe
Hi all, I'm still trying to come to grips with understanding ebuilds so please bear with me if this is a simple question. I've just sync'd and then done an emerge --ask -NuD world I have LLVM/clang installed and upon browsing the updates saw app-vim/llvm-vim. This is some sort

Re: [gentoo-user] llvm not updating with @world

2017-03-04 Thread Dutch Ingraham
-graph @world' is > > 'Nothing to merge; quitting.' > > > > However, if I 'emerge -1a sys-devel/llvm', I get: > > '[ebuild r U ] sys-devel/llvm-3.9.1-r1 [3.7.1-r3]' and > > '[ebuild rR] media-libs/mesa-17.0.0' > > > > So, why is a reinstall of ll

Re: [gentoo-user] How do I use LLVM?

2011-12-11 Thread Michael Mol
to emerge xorg-server, it fails with the message... configure: error: LLVM is required to build Gallium R300 on x86 and x86_64  I understand that LLVM is a gcc-like compiler.  What is the minimum amount of stuff that I need to do?  Are there any LLVM-compatability libraries for gcc that would

Re: [gentoo-user] How do I use LLVM?

2011-12-11 Thread Mick
from the radeon-ucode ebuild/download. When trying to emerge xorg-server, it fails with the message... configure: error: LLVM is required to build Gallium R300 on x86 and x86_64 I understand that LLVM is a gcc-like compiler. What is the minimum amount of stuff that I need to do

[gentoo-user] Re: ebuild for gcc-independent llvm and clang for linux

2013-12-26 Thread Takayuki Yamaguchi
Sorry for earlier mis-send. I send the article again. I'm going to build and install llvm and clang packages in my Linux PC as 1. Binaries of llvm and claag installed finally were compiled by clang. 2. The binaries of 1. depend on libc++.so instead of libstdc++.so. 3. libc++.so

Re: [gentoo-user] Re: Emerge of sys-devel/llvm-3.3-r3 fails....

2014-08-12 Thread Volker Armin Hemmann
Am 12.08.2014 um 12:52 schrieb Jouni Kosonen: Volker Armin Hemmann wrote: Am 10.08.2014 um 08:33 schrieb Christopher Kurtis Koeber: *emerge --info =sys-devel/llvm-3.3-r3::gentoo*: Pastebin: http://pastebin.com/qF92DXSY I am not a fan of that. gcc-4.7.3, Intel-R-_Atom-TM *End Section

Re: [gentoo-user] llvm not updating with @world

2017-03-04 Thread Dutch Ingraham
On Sat, Mar 04, 2017 at 10:31:27AM -0500, Michael Orlitzky wrote: > On 03/04/2017 10:18 AM, Dutch Ingraham wrote: > > > > So, that will bring in the update, just like emerge -1a sys-devel/llvm > > will. > > > > But, why isn't --deep @world do

[gentoo-user] Is LLVM bytecode the future ?

2014-08-25 Thread Ivan Viso Altamirano
This has little to do with Gentoo , but still it is a interesting debate . You can compile a great sort of programing lenguages to llvm bytecode : C(++) , java , Objetive C(++) , C# , Haskell , Rust ... And a lot more . On the other side , you CAN'T compile , lenguages like python or perl

[gentoo-user] llvm install and python_fix_shebang: EPYTHON unset

2016-07-18 Thread Andrew Lowe
Hi all, I'm attempting to update llvm & clang and am getting a failure. Portage is reporting: * ERROR: sys-devel/llvm-3.8.1::gentoo failed (install phase): * python_fix_shebang: EPYTHON unset (pkg_setup not called?) I've looked in the ebuild and can't even find a mention of EPYTHON.

Re: [gentoo-user] llvm not updating with @world

2017-03-04 Thread Dutch Ingraham
On Sat, Mar 04, 2017 at 09:55:30AM -0500, Michael Orlitzky wrote: > On 03/04/2017 09:37 AM, Dutch Ingraham wrote: > > > > Michael, thanks for your response. No, I did not do a one-shot; llvm > > was brought in by way of mesa -> gallium; this is llvm's only use on > >

Re: [gentoo-user] ebuild ChangeLog and emerge -l

2011-05-23 Thread James Wall
is displayed, containing entries for ebuilds older than what is currently installed.  Some other times it's less dramatic, but still contains stuff that should not show up. The above seems to be the norm rather than the exception.  For example, right now I'm doing an update from llvm-2.9-r1

[gentoo-user] Re: ebuild for gcc-independent llvm and clang for linux

2013-12-25 Thread Takayuki Yamaguchi
Sorry, I mistook the operation of Gmail. I will send with full-written article again. 2013/12/26 やまぐちたかゆき tyamaguchi.gen...@gmail.com: Hello everybody, I'm going to build and install llvm and clang packages in my Linux PC as 1. Binaries of llvm and claag installed finally were compiled

Re: [gentoo-user] Emerge of sys-devel/llvm-3.3-r3 fails....

2014-08-12 Thread J. Roeleveld
On Sunday, August 10, 2014 02:33:40 AM Christopher Kurtis Koeber wrote: Hello, I am attempting to emerge xorg-server and sys-devel/llvm-3.3-r3 is pulled in as a dependency. So, when I emerge llvm it fails. Here is some relevant output: emerge --info =sys-devel/llvm-3.3-r3::gentoo

[gentoo-user] Re: Latest LLVM wants to pollute my machine with VIM stuff.....

2017-03-15 Thread Holger Hoffstätte
On Wed, 15 Mar 2017 22:33:10 +0800, Andrew Lowe wrote: > Hi all, > I'm still trying to come to grips with understanding ebuilds so please > bear with me if this is a simple question. I've just sync'd and then > done an > > emerge --ask -NuD world > > I h

Re: [gentoo-user] Latest LLVM wants to pollute my machine with VIM stuff.....

2017-03-15 Thread Nils Freydank
Am Mittwoch, 15. März 2017, 15:33:10 CET schrieb Andrew Lowe: > Hi all, Hi, > I'm still trying to come to grips with understanding ebuilds so please > bear with me if this is a simple question. I've just sync'd and then > done an > > emerge --ask -NuD world >

Re: [gentoo-user] curses of ncurses :(

2015-08-27 Thread Alec Ten Harmsel
On Thu, Aug 27, 2015 at 05:42:07PM +0200, J. Roeleveld wrote: That solved the block for me as it ended up removing llvm What is llvm actually used for? -- Joost Some of the graphics code in mesa is written in LLVM's IR and compiled on the fly using all of the x86 extensions (SSE, AVX

Re: [gentoo-user] Latest LLVM wants to pollute my machine with VIM stuff.....

2017-03-15 Thread Neil Bothwick
On Wed, 15 Mar 2017 22:33:10 +0800, Andrew Lowe wrote: > I have LLVM/clang installed and upon browsing the updates saw > app-vim/llvm-vim. This is some sort of syntax highlighting thingy for > Vim. I don't have Vim installed so went into the llvm-4.0.0 ebuild and > saw the line

Re: [gentoo-user] Re: rubinius fails to emerge with error about llvm-config

2012-08-20 Thread covici
suggestions would be appreciated. Check our bug database: https://bugs.gentoo.org/show_bug.cgi?id=417533 Thanks -- that did it -- I downgraded llvm and that fixed things. I did a search at bugs.gentoo.org for rubinius llvm, but that bug did not come up in the search. -- Your life is like

Re: [gentoo-user] curses of ncurses :(

2015-08-27 Thread Marc Joliet
Am Thu, 27 Aug 2015 17:42:07 +0200 schrieb J. Roeleveld jo...@antarean.org: I only had 1 required by set. Which basically got me to remove the llvm use-flag from mesa. That solved the block for me as it ended up removing llvm [...] FWIW, my experience yesterday was that you should be able

Re: [gentoo-user] Can't compile media-libs/mesa - do I need gallium?

2017-07-17 Thread Mart Raudsepp
Ühel kenal päeval, E, 17.07.2017 kell 03:46, kirjutas Rasmus Thomsen: > Hello, > > > undefined reference to > `llvm::RTDyldMemoryManager::getSymbolAddressInProcess(std::__cxx11::b > asic_string , std::allocator > const&)'  > > Seems to be the error, maybe you ha

Re: [gentoo-user] llvm compile error

2014-01-23 Thread Silvio Siefke
Hello, ok the version 3.3 run without problems, i think the 3.4. make troubles and the package Maintainer from Gentoo has hardmasked. Thank you for help Nice Day Silvio

[gentoo-user] Re: Is LLVM bytecode the future ?

2014-08-25 Thread Ivan Viso Altamirano
Sorry , i accidentally send it . What i wanted to say is that , Theoretically , you can : 1) Native compile statically typed non-native lenguages 2) Recompile binaries for another architecture and even plataforms . 3) Achive a .NET like CLI , but even better . And , notice , that the LLVM garbage

Re: [gentoo-user] llvm install and python_fix_shebang: EPYTHON unset

2016-07-18 Thread Fernando Rodriguez
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 07/18/2016 07:19 AM, Andrew Lowe wrote: > Hi all, > I'm attempting to update llvm & clang and am getting a failure. Portage > is reporting: > > * ERROR: sys-devel/llvm-3.8.1::gentoo failed (install phase): >

Re: [gentoo-user] Re: llvm compile error

2014-01-23 Thread Silvio Siefke
make emerge -av clang and become gentoomobile siefke # emerge -av clang These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N~] sys-devel/llvm-3.4:0/3.4 USE=clang libffi ncurses python static-analyzer xml -debug -doc -gold -multitarget -ocaml

[gentoo-user] Re: llvm clang ABI confusion

2016-02-10 Thread James
Alan McKinnon gmail.com> writes: > 1. Relax your stance and accept that some software out there that you > might want is 32 bits > 2. Refuse to have 32 bits, so give up on llvm and clang. Find something > else and move on. > You must pick one of those two. There is no mag

Re: [gentoo-user] Epic list of total FAIL.

2015-08-20 Thread Terry Z.
├── media-sound │ └── playmidi-2.5-r2 ├── media-video │ └── vcdimager-0.7.24 ├── sci-libs │ └── gdal-2.0.0 └── sys-devel └── llvm-3.6.2 36 directories, 0 files tortoise portage # ### In file included from

Re: [gentoo-user] Epic list of total FAIL.

2015-08-20 Thread Fernando Rodriguez
│ └── mesa-10.6.3 ├── media-sound │ └── playmidi-2.5-r2 ├── media-video │ └── vcdimager-0.7.24 ├── sci-libs │ └── gdal-2.0.0 └── sys-devel └── llvm-3.6.2 36 directories, 0 files tortoise portage

[gentoo-user] Epic list of total FAIL.

2015-08-20 Thread Alan Grimes
-libs │ └── gdal-2.0.0 └── sys-devel └── llvm-3.6.2 36 directories, 0 files tortoise portage # ### In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/functional:55:0, from /var/tmp

Re: [gentoo-user] Epic list of total FAIL.

2015-08-20 Thread Alan McKinnon
├── media-sound │ └── playmidi-2.5-r2 ├── media-video │ └── vcdimager-0.7.24 ├── sci-libs │ └── gdal-2.0.0 └── sys-devel └── llvm-3.6.2 36 directories, 0 files tortoise portage # ### In file included from /usr

Re: [gentoo-user] llvm compile error

2014-01-24 Thread Silvio Siefke
Hello, On Fri, 24 Jan 2014 09:00:26 +0200 Alan McKinnon alan.mckin...@gmail.com wrote: llvm-3.4 is not hardmasked. It is marked ~x86 which is something very different. Correct, i mean Clang in version 3.4 is hardmasked. I want install clang alone llvm i not need. I think mesa use llvm too

[gentoo-user] mesa-12.0.1 fails to emerge

2017-02-07 Thread Mick
How could I go beyond this point? /var/tmp/portage/media- libs/mesa-12.0.1/work/mesa-12.0.1/src/gallium/state_track ers/clover/llvm/invocation.cpp:212:75: error: no matching function for call to ‘ clang::CompilerInvocation::setLangDefaults(clang

Re: [gentoo-user] curses of ncurses :(

2015-08-28 Thread J. Roeleveld
On Thursday, August 27, 2015 07:13:58 PM Marc Joliet wrote: Am Thu, 27 Aug 2015 17:42:07 +0200 schrieb J. Roeleveld jo...@antarean.org: I only had 1 required by set. Which basically got me to remove the llvm use-flag from mesa. That solved the block for me as it ended up removing llvm

Re: [gentoo-user] llvm not updating with @world

2017-03-04 Thread Michael Orlitzky
On 03/04/2017 09:37 AM, Dutch Ingraham wrote: > > Michael, thanks for your response. No, I did not do a one-shot; llvm > was brought in by way of mesa -> gallium; this is llvm's only use on > this system as far as I know. > > Also, 'emerge -ac' shows no packages to remove.

Re: [gentoo-user] Can't compile media-libs/mesa - do I need gallium?

2017-07-17 Thread Mart Raudsepp
Ühel kenal päeval, E, 17.07.2017 kell 12:00, kirjutas Mart Raudsepp: > Ühel kenal päeval, E, 17.07.2017 kell 03:46, kirjutas Rasmus Thomsen: > > Hello, > > > > > undefined reference to > > > > `llvm::RTDyldMemoryManager::getSymbolAddressInProcess(std::_

[gentoo-user] llvm clang ABI confusion

2016-02-10 Thread James
ebuild U ~] dev-lang/scala-2.10.6:2.10/2.10.6::gentoo [2.10.4-r2:2.10/2.10.4::gentoo] USE="source -binary -doc -emacs" 82,629 KiB Total: 3 packages (3 upgrades), Size of downloads: 292,827 KiB WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

Re: [gentoo-user] Odd Update Issue

2014-05-27 Thread Walter Dnes
On Tue, May 27, 2014 at 08:58:56PM -0400, Hunter Jozwiak wrote VIDEOCARDS equals nouveauinin radeoninin vmwareinin media-libs/mesa-10.0.4 was built with the following: USE equals classic egl gallium gbm llvm nptl xa combindist comdebug comgles1 comgles2 comllvm-shared-libs comopencl

[gentoo-user] Re: llvm clang ABI confusion

2016-02-10 Thread James
James tampabay.rr.com> writes: > > 1. Relax your stance and accept that some software out there that you > > might want is 32 bits > > 2. Refuse to have 32 bits, so give up on llvm and clang. Find something > > else and move on. > > You must pick one of th

[gentoo-user] Portage getting slicker?

2016-07-13 Thread James
0.6::gentoo USE="classic dri3 egl gallium gbm gles2 llvm nptl openmax udev vaapi vdpau xvmc -bindist -d3d9 -debug -gles1 -opencl -osmesa -pax_kernel -pic (-selinux) -wayland -xa" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon radeonsi (-freedreno) -i915 -i965 -ilo -intel -nou

Re: [gentoo-user] Portage getting slicker?

2016-07-13 Thread Alan McKinnon
-libs/mesa-11.0.6::gentoo USE="classic dri3 egl gallium gbm gles2 llvm nptl openmax udev vaapi vdpau xvmc -bindist -d3d9 -debug -gles1 -opencl -osmesa -pax_kernel -pic (-selinux) -wayland -xa" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon radeonsi (-freedreno) -i915 -i965 -il

Re: [gentoo-user] llvm install and python_fix_shebang: EPYTHON unset

2016-07-18 Thread Andrew Lowe
On 18/07/16 20:03, Fernando Rodriguez wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 07/18/2016 07:19 AM, Andrew Lowe wrote: Hi all, I'm attempting to update llvm & clang and am getting a failure. Portage is reporting: * ERROR: sys-devel/llvm-3.8.1::gentoo failed (ins

Re: [gentoo-user] llvm / clang compile error

2016-08-16 Thread Fernando Rodriguez
On 08/16/2016 04:43 PM, Silvio Siefke wrote: > Hello, > > I'm trying to install llvm for days. But all versions fail with the > error message "internal compiler error: Killed (program cc1plus)". > > The last lines in the build log. > > [1820/2304] /usr/lib6

[gentoo-user] llvm / clang compile error

2016-08-16 Thread Silvio Siefke
Hello, I'm trying to install llvm for days. But all versions fail with the error message "internal compiler error: Killed (program cc1plus)". The last lines in the build log. [1820/2304] /usr/lib64/ccache/bin/x86_64-pc-linux-gnu-g++ -DCLANG_ENABLE_ARCMT -DCLANG_ENABLE_OBJ

[gentoo-user] Re: rubinius fails to emerge with error about llvm-config

2012-08-20 Thread Hans de Graaff
On Sun, 19 Aug 2012 16:02:15 -0400, covici wrote: Hi. In my update world of today, the system wanted to emerge rubinius -- for reasons known only to itself -- however it fails to emerge during its config phase with the following output: Any suggestions would be appreciated. Check our bug

Re: [gentoo-user] llvm compile error

2014-01-24 Thread Chris Stout
FreeBSD use it and say is stable. FreeBSD maybe not the reference on earth but the BSD's make a good job. When i saw all versions of Clang is masked. Isn't FBSD more similar than, say, Linux, to what OSX is, sort of? I could be way off. But I think of OSX as being FBSD built for people

Re: [gentoo-user] llvm compile error

2014-01-24 Thread Alan McKinnon
On 24/01/2014 20:44, Silvio Siefke wrote: Hello, On Fri, 24 Jan 2014 09:00:26 +0200 Alan McKinnon alan.mckin...@gmail.com wrote: llvm-3.4 is not hardmasked. It is marked ~x86 which is something very different. Correct, i mean Clang in version 3.4 is hardmasked. I want install clang

[gentoo-user] Re: Is LLVM bytecode the future ?

2014-08-25 Thread James
Ivan Viso Altamirano ivanviso123 at gmail.com writes: This has little to do with Gentoo , but still it is a interesting debate .  You can compile a great sort of programing lenguages to llvm bytecode : C(++) , java , Objetive C(++) , C# , Haskell , Rust ... And a lot more . On the other

Re: [gentoo-user] llvm / clang compile error

2016-08-17 Thread siefke_lis...@web.de
On Wed, 17 Aug 2016 08:36:12 -0400 james wrote: > On 08/16/2016 04:43 PM, Silvio Siefke wrote: > > Please submit a full bug report https://bugs.gentoo.org/show_bug.cgi?id=591514 Silvio

Re: [gentoo-user] llvm / clang compile error

2016-08-17 Thread siefke_lis...@web.de
On Wed, 17 Aug 2016 08:36:12 -0400 james wrote: Okay i will open Bug Report. But can it be that the memory / swap is to small? cat /proc/meminfo MemTotal:2024472 kB cat /proc/swaps FilenameTypeSizeUsedPriority /dev/sda2 partition

Re: [gentoo-user] llvm / clang compile error

2016-08-17 Thread Silvio Siefke
On Tue, 16 Aug 2016 21:40:40 -0400 Fernando Rodriguez wrote: Hi, > If you havent, try disabling ccache to rule that out. i have do now. Same mistake. Same error message. Silvio pgp0yrcGvf49z.pgp Description: PGP signature

Re: [gentoo-user] drivers for INTEL integrated GPU?

2017-03-28 Thread Adam Carter
, i have; Multiprocess Windows 1/1 (Enabled by user) and; Features CompositingOpenGL Asynchronous Pan/Zoomwheel input enabled; touch input enabled WebGL RendererX.Org -- Gallium 0.4 on AMD TONGA (DRM 3.8.0 / 4.9.6-gentoo-r1, LLVM 4.0.0) WebGL2 RendererX.Org -- Gallium 0.4 on AMD

[gentoo-user] How to update a system if some packages can't be updated

2017-03-07 Thread Helmut Jarausch
Hi, I have packages which can't be updated at the moment, e.g. dev-python/numba doesn't work with llvm-4.0.0(_rc3) But this makes emerge -uvp --tree --unordered-display --verbose-conflicts --deep --with-bdeps=y @world fail. Is there any means to proceed except masking all those packages

Re: [gentoo-user] llvm clang ABI confusion

2016-02-10 Thread Alan McKinnon
ot; 82,629 KiB > > Total: 3 packages (3 upgrades), Size of downloads: 292,827 KiB > > WARNING: One or more updates/rebuilds have been skipped due to a > dependency conflict: > > sys-devel/llvm:0 > > sys-devel/llvm-3.5.0:0/3.5::gentoo, ebuild scheduled for merge > conf

Re: [gentoo-user] llvm compile error

2014-01-24 Thread Michael Higgins
On Fri, 24 Jan 2014 19:44:38 +0100 Silvio Siefke siefke_lis...@web.de wrote: Hello, On Fri, 24 Jan 2014 09:00:26 +0200 Alan McKinnon alan.mckin...@gmail.com wrote: llvm-3.4 is not hardmasked. It is marked ~x86 which is something very different. Correct, i mean Clang in version 3.4

Re: [gentoo-user] llvm install and python_fix_shebang: EPYTHON unset

2016-07-18 Thread Andrew Lowe
On 18/07/16 21:18, Andrew Lowe wrote: On 18/07/16 20:03, Fernando Rodriguez wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 07/18/2016 07:19 AM, Andrew Lowe wrote: Hi all, I'm attempting to update llvm & clang and am getting a failure. Portage is reporting: * ERROR: sys-d

[gentoo-user] /usr/lib/dri/i810_dri.so: No such file or directory

2013-06-02 Thread Grant
sure X is working. I think it's supposed to be a mesa file but I've tried reinstalling mesa: [ebuild R] media-libs/mesa-9.1.2-r1 USE=classic egl gallium llvm nptl pax_kernel pic shared-glapi -bindist -debug -gbm -gles1 -gles2 -openvg -osmesa (-r600-llvm-compiler) (-selinux) -vdpau (-wayland

[gentoo-user] Re: [gentoo-user] /usr/lib/dri/i810_dri.so: No such file or directory

2013-06-02 Thread the guard
The system is remote to me but I'm pretty sure X is working. I think it's supposed to be a mesa file but I've tried reinstalling mesa: [ebuild R] media-libs/mesa-9.1.2-r1 USE=classic egl gallium llvm nptl pax_kernel pic shared-glapi -bindist -debug -gbm -gles1 -gles2 -openvg -osmesa

Re: [gentoo-user] Odd Update Issue

2014-05-28 Thread Neil Bothwick
/files/mesa-10.2-dont-require-llvm-fo r-r3004patch * were mesa-10.2-dont-require-llvm-for-r3004patch were * ERROR: media-libs/mesa-10.2.0.rc433gentoo failed (prepare phase): * Cannot find $EPATCHSOURCE! * * Call stack: * ebuildddsh, line 93: Called srcprepare * environment, line 4773

Re: [gentoo-user] mesa-12.0.1 fails to emerge

2017-02-07 Thread Corbin Bird
On 02/07/2017 05:02 PM, Mick wrote: > How could I go beyond this point? > > = > /var/tmp/portage/media- > libs/mesa-12.0.1/work/mesa-12.0.1/src/gallium/state_track > ers/clover/llvm/invocation.cpp:212:75: error: no matching

Re: [gentoo-user] mesa-12.0.1 fails to emerge

2017-02-07 Thread Mick
allium/state_track > > ers/clover/llvm/invocation.cpp:212:75: error: no matching function for > > call to ‘ > > clang::CompilerInvocation::setLangDefaults(clang::LangOptions&, > > clang::InputKind > > , llvm::Triple, clang::LangStandard::Kind)’ > > ==

[gentoo-user] what is /usr/lib64/debug ?

2011-08-18 Thread Allan Gottlieb
155992 icedtea6 161360 llvm 208932 qt4 304016 xulrunner-devel-2.0 308880 xulrunner-2.0 618408 firefox 669000 libwebkitgtk-1.0.so.0.7.2.debug 1087848 libreoffice ajglap lib64 # Is this correct? My system is ~amd64 thanks

[gentoo-user] MESA + opencl = requires video_cards_radeon

2014-05-01 Thread Chris Stankevitz
Hello, Regarding the following snip from /usr/portage/media-libs/mesa/mesa-10.0.4.ebuild: DEPEND=${RDEPEND} opencl? ( =sys-devel/llvm-3.3-r1[video_cards_radeon,${MULTILIB_USEDEP}] =sys-devel/clang-3.3[${MULTILIB_USEDEP}] =sys-devel/gcc-4.6

Re: [gentoo-user] Re: Is LLVM bytecode the future ?

2014-08-26 Thread Ivan Viso Altamirano
is very interesting , i'll take a look . 2014-08-25 20:00 GMT+00:00 James wirel...@tampabay.rr.com: Ivan Viso Altamirano ivanviso123 at gmail.com writes: This has little to do with Gentoo , but still it is a interesting debate . You can compile a great sort of programing lenguages to llvm

Re: [gentoo-user] Running gentoo ~amd64 as a virtualbox guest

2015-04-08 Thread Fernando Rodriguez
rasterizer, both of which are fast enough to satisfy the gnome3 shell. What does eselect mesa list shows for Software Renderer? I think to use llvmpipe you'll need the llvm and gallium use flags for mesa and select the gallium renderer. -- Fernando Rodriguez

[gentoo-user] why the sudden need for glamor in xf86-video-intel

2014-09-17 Thread gottlieb
] x11-libs/glamor-0.6.0 USE=xv -gles -static-libs 419 kB [ebuild R] media-libs/mesa-10.0.4 USE=classic egl gallium gbm* llvm nptl -bindist -debug -gles1 -gles2 -llvm-shared-libs -opencl -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xvmc ABI_X86=(64

Re: [gentoo-user] curses of ncurses :(

2015-08-27 Thread J. Roeleveld
the real error, and all that junk on the screen goes away. No reason to stop updating. I only had 1 required by set. Which basically got me to remove the llvm use-flag from mesa. That solved the block for me as it ended up removing llvm What is llvm actually used for? -- Joost

Re: [gentoo-user] curses of ncurses :(

2015-08-28 Thread Marc Joliet
Am Fri, 28 Aug 2015 11:44:29 +0200 schrieb J. Roeleveld jo...@antarean.org: On Thursday, August 27, 2015 07:13:58 PM Marc Joliet wrote: Am Thu, 27 Aug 2015 17:42:07 +0200 schrieb J. Roeleveld jo...@antarean.org: I only had 1 required by set. Which basically got me to remove the llvm

Re: [gentoo-user] Can't compile media-libs/mesa - do I need gallium?

2017-07-17 Thread IceAmber
ote: > Ühel kenal päeval, E, 17.07.2017 kell 12:00, kirjutas Mart Raudsepp: > > Ühel kenal päeval, E, 17.07.2017 kell 03:46, kirjutas Rasmus Thomsen: > > > Hello, > > > > > > > undefined reference to > > > > > > `llvm::RTDyldMemoryManager::get

Re: [gentoo-user] Can't compile media-libs/mesa - do I need gallium?

2017-07-19 Thread Stroller
d R ] media-libs/mesa-17.0.6::gentoo USE="bindist classic dri3 > egl gbm gles2 nptl -d3d9 -debug -gallium -gles1 -llvm -opencl -openmax > -osmesa -pax_kernel -pic (-selinux) -vaapi -valgrind -vdpau -vulkan -wayland > -xa -xvmc" VIDEO_CARDS="i915 intel (-freedreno) -i

[gentoo-user] llvm compile error

2014-01-23 Thread Silvio Siefke
Hello, i try to install llvm but it broke with: -- Performing Test CXX_SUPPORTS_COVERED_SWITCH_DEFAULT_FLAG - Failed -- Performing Test C_SUPPORTS_COVERED_SWITCH_DEFAULT_FLAG -- Performing Test C_SUPPORTS_COVERED_SWITCH_DEFAULT_FLAG - Failed -- Performing Test CXX_SUPPORTS_NON_VIRTUAL_DTOR_FLAG

Re: [gentoo-user] what is /usr/lib64/debug ?

2011-08-18 Thread Daniel Pielmeier
   34020       mesa    53148       gstreamer-0.10    155992      icedtea6    161360      llvm    208932      qt4    304016      xulrunner-devel-2.0    308880      xulrunner-2.0    618408      firefox    669000      libwebkitgtk-1.0.so.0.7.2.debug    1087848     libreoffice    ajglap lib64

Re: [gentoo-user] Can't enable effects in kde

2011-10-20 Thread Mick
On Thursday 20 Oct 2011 17:40:13 Vishnupradeep wrote: Calculating dependencies... done! [ebuild R] media-libs/mesa-7.11 USE=classic egl gallium llvm nptl shared-glapi -bindist -debug -gbm -gles -motif -openvg -pax_kernel -pic (-selinux) -shared-dricore VIDEO_CARDS=-intel* -mach64* -mga

[gentoo-user] Intel and Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)

2014-05-27 Thread Time Lucky
Hey,guys. Anyone can tell me how to switch Gallium 0.4 to intel driver? I dont know why it happened but now my computer is very slow when I use gnome 3.10. $ /usr/libexec/gnome-session-check-accelerated-helper -v libGL error: dlopen /usr/lib64/dri/i965_dri.so failed (/usr/lib64/dri/i965_dri.so:

Re: [gentoo-user] llvm clang ABI confusion

2016-02-10 Thread Neil Bothwick
On Wed, 10 Feb 2016 21:52:16 + (UTC), James wrote: > in my /etc/portage/package.use/000.abi I have this > entry:: */* -abi_x86_32 When package.use (and other package.*) is a directory, the files in it are concatenated, in lexical order. So your entry appears right at the start. This

[gentoo-user] Re: llvm clang ABI confusion

2016-02-10 Thread James
Neil Bothwick digimed.co.uk> writes: > > I still want to ensure I have no 32 bit packages on this system. > Why? What is special about 32 bit libraries? They are dependencies like > any other, if a package needs them why try to stop portage installing > them? Experimentation. I trying to

Re: [gentoo-user] How to update a system if some packages can't be updated

2017-03-07 Thread Neil Bothwick
On Tue, 07 Mar 2017 18:51:28 +0100, Helmut Jarausch wrote: > I have packages which can't be updated at the moment, e.g. > dev-python/numba doesn't work with llvm-4.0.0(_rc3) > But this makes > > emerge -uvp --tree --unordered-display --verbose-conflicts --deep > --w

Re: [gentoo-user] How to update a system if some packages can't be updated

2017-03-07 Thread Dale
Helmut Jarausch wrote: > Hi, > I have packages which can't be updated at the moment, e.g. > dev-python/numba doesn't work with llvm-4.0.0(_rc3) > But this makes > > emerge -uvp --tree --unordered-display --verbose-conflicts --deep > --with-bdeps=y @world > > fail. Is

Re: [gentoo-user] How do I use LLVM?

2011-12-12 Thread Walter Dnes
On Mon, Dec 12, 2011 at 07:30:32AM +, Mick wrote Unless you are using a new radeon card you may need sys-kernel/linux-firmware instead of radeon-ucode. As I mentioned in my reply to Michael Mol, building mesa with the llvm USE flag does the trick. It appears the web pages http

Re: [gentoo-user] Re: Questions about optimal mplayer settings

2012-12-19 Thread Dale
: mingdao@workstation ~/test $ md5sum XITHbsUUlYI.mp4 dab460274c1ce3ed8ebaf7caa6c0ad02 XITHbsUUlYI.mp4 Even before Walter's reply to me, I'd rebuilt mesa with new flags: media-libs/mesa-9.0 USE=classic egl g3dvl gallium llvm nptl r600-llvm-compiler shared-glapi xa xvmc -bindist -debug -gbm

Re: [gentoo-user] /usr/lib/dri/i810_dri.so: No such file or directory

2013-06-02 Thread Walter Dnes
to software rendering The system is remote to me but I'm pretty sure X is working. I think it's supposed to be a mesa file but I've tried reinstalling mesa: [ebuild R] media-libs/mesa-9.1.2-r1 USE=classic egl gallium llvm nptl pax_kernel pic shared-glapi -bindist -debug -gbm -gles1 -gles2

Re: [gentoo-user] /usr/lib/dri/i810_dri.so: No such file or directory

2013-06-03 Thread Raffaele BELARDI
The system is remote to me but I'm pretty sure X is working. I think it's supposed to be a mesa file but I've tried reinstalling mesa: [ebuild R] media-libs/mesa-9.1.2-r1 USE=classic egl gallium llvm nptl pax_kernel pic shared-glapi -bindist -debug -gbm -gles1 -gles2 -openvg -osmesa

Re: [gentoo-user] /usr/lib/dri/i810_dri.so: No such file or directory

2013-06-03 Thread Grant
pretty sure X is working. I think it's supposed to be a mesa file but I've tried reinstalling mesa: [ebuild R] media-libs/mesa-9.1.2-r1 USE=classic egl gallium llvm nptl pax_kernel pic shared-glapi -bindist -debug -gbm -gles1 -gles2 -openvg -osmesa (-r600-llvm-compiler) (-selinux) -vdpau

Re: [gentoo-user] /usr/lib/dri/i810_dri.so: No such file or directory

2013-06-03 Thread Grant
pretty sure X is working. I think it's supposed to be a mesa file but I've tried reinstalling mesa: [ebuild R] media-libs/mesa-9.1.2-r1 USE=classic egl gallium llvm nptl pax_kernel pic shared-glapi -bindist -debug -gbm -gles1 -gles2 -openvg -osmesa (-r600-llvm-compiler) (-selinux) -vdpau

  1   2   3   >