Re: [gentoo-user] Re: llvm compile error

2014-01-23 Thread Silvio Siefke
make emerge -av clang and become gentoomobile siefke # emerge -av clang These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N~] sys-devel/llvm-3.4:0/3.4 USE=clang libffi ncurses python static-analyzer xml -debug -doc -gold -multitarget -ocaml

[gentoo-user] Portage getting slicker?

2016-07-13 Thread James
veau -r100 -r200 -r300 -r600 -vmware" 7,103 KiB [nomerge ] sys-devel/llvm-3.7.1-r3:0/3.7.1::gentoo [3.5.0:0/3.5::gentoo] USE="clang libffi ncurses python static-analyzer -debug -doc -gold -libedit -lldb% -multitarget -ocaml {-test} -xml" ABI_X86="32 (64) (-x32)" PY

Re: [gentoo-user] Portage getting slicker?

2016-07-13 Thread Alan McKinnon
o -intel -nouveau -r100 -r200 -r300 -r600 -vmware" 7,103 KiB [nomerge ] sys-devel/llvm-3.7.1-r3:0/3.7.1::gentoo [3.5.0:0/3.5::gentoo] USE="clang libffi ncurses python static-analyzer -debug -doc -gold -libedit -lldb% -multitarget -ocaml {-test} -xml" ABI_X86="32 (64) (-x32)&q

[gentoo-user] llvm clang ABI confusion

2016-02-10 Thread James
ebuild U ~] dev-lang/scala-2.10.6:2.10/2.10.6::gentoo [2.10.4-r2:2.10/2.10.4::gentoo] USE="source -binary -doc -emacs" 82,629 KiB Total: 3 packages (3 upgrades), Size of downloads: 292,827 KiB WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

Re: [gentoo-user] llvm install and python_fix_shebang: EPYTHON unset

2016-07-18 Thread Andrew Lowe
On 18/07/16 20:03, Fernando Rodriguez wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 07/18/2016 07:19 AM, Andrew Lowe wrote: Hi all, I'm attempting to update llvm & clang and am getting a failure. Portage is reporting: * ERROR: sys-devel/llvm-3.8.1::gentoo failed (ins

Re: [gentoo-user] llvm clang ABI confusion

2016-02-10 Thread Alan McKinnon
licts with > > sys-devel/llvm-3.5.0[clang(-),-debug,python,static- > analyzer,abi_x86_32(-),abi_x86_64(-)] > > required by (sys-devel/clang-3.5.0-r100:0/3.5::gentoo, installed) > > I have both installed:: [I] sys-devel/llvm > > Installed versions: 3.5.0(06:15:37

Re: [gentoo-user] llvm install and python_fix_shebang: EPYTHON unset

2016-07-18 Thread Andrew Lowe
On 18/07/16 21:18, Andrew Lowe wrote: On 18/07/16 20:03, Fernando Rodriguez wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 07/18/2016 07:19 AM, Andrew Lowe wrote: Hi all, I'm attempting to update llvm & clang and am getting a failure. Portage is reporting: * ERROR: sys-d

Re: [gentoo-user] llvm / clang compile error

2016-08-16 Thread Fernando Rodriguez
On 08/16/2016 04:43 PM, Silvio Siefke wrote: > Hello, > > I'm trying to install llvm for days. But all versions fail with the > error message "internal compiler error: Killed (program cc1plus)". > > The last lines in the build log. > > [1820/2304] /usr/lib6

[gentoo-user] llvm / clang compile error

2016-08-16 Thread Silvio Siefke
Hello, I'm trying to install llvm for days. But all versions fail with the error message "internal compiler error: Killed (program cc1plus)". The last lines in the build log. [1820/2304] /usr/lib64/ccache/bin/x86_64-pc-linux-gnu-g++ -DCLANG_ENABLE_ARCMT -DCLANG_ENABLE_OBJ

[gentoo-user] llvm compile error

2014-01-23 Thread Silvio Siefke
Hello, i try to install llvm but it broke with: -- Performing Test CXX_SUPPORTS_COVERED_SWITCH_DEFAULT_FLAG - Failed -- Performing Test C_SUPPORTS_COVERED_SWITCH_DEFAULT_FLAG -- Performing Test C_SUPPORTS_COVERED_SWITCH_DEFAULT_FLAG - Failed -- Performing Test CXX_SUPPORTS_NON_VIRTUAL_DTOR_FLAG

[gentoo-user] Why is portage insisting that I upgrade media-libs/opencv?

2014-03-28 Thread Chris Stankevitz
] media-libs/mesa-10.0.4 [9.1.6] USE=classic egl gallium gles2 llvm nptl -bindist -debug -gbm -gles1 -llvm-shared-libs% -opencl% -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xvmc (-shared-glapi%*) (-xorg%) ABI_X86=(64%*) (-32) (-x32) PYTHON_SINGLE_TARGET=(-python2_6

Re: [gentoo-user] Why is portage insisting that I upgrade media-libs/opencv?

2014-03-28 Thread Alan McKinnon
-radeonsi -vmware 6,636 kB [ebuild U ] sys-devel/llvm-3.3-r3:0/3.3 [3.1-r2:0/0] USE=libffi static-analyzer%* xml%* -clang% -debug -doc% -gold -multitarget -ocaml -python% {-test} -udis86 (-vim-syntax%*) ABI_X86=(64%*) (-32) (-x32) PYTHON_TARGETS=python2_7%* (-pypy2_0) -python2_6

Re: [gentoo-user] Vim stops installing when it runs installman.sh

2011-11-21 Thread James Broadhead
-old-linux -perl (-selinux) -slang (-uclibc) 0 kB [ebuild U ] sys-devel/binutils-2.21.1-r1 [2.20.1-r1] USE=nls static-libs -multislot -multitarget -test -vanilla 18,572 kB [ebuild U ] sys-devel/llvm-2.9-r2 [2.8-r2] USE=libffi -debug -llvm-gcc -multitarget -ocaml -test -udis86 -vim-syntax