Re: [gentoo-user] error installing xorg

2006-09-14 Thread Benno Schulenberg
like this. checking for i686-pc-linux-gnu-pkg-config... no checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for XKBFILE... configure: error: Package requirements (x11 kbproto) were not met: No package 'x11' found Someone else

[gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-12 Thread Meino . Cramer
Hi, got a mysterious error message this morning (still building a new root...) One of the updates was gnutls: It ends with: ... checking for i686-pc-linux-gnu-pkg-config... /usr/bin/i686-pc-linux-gnu-pkg-config checking pkg-config is at least version 0.9.0... /var/tmp/portage/net-libs/gnutls

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-13 Thread Meino . Cramer
ith: > > ... > > checking for i686-pc-linux-gnu-pkg-config... > > /usr/bin/i686-pc-linux-gnu-pkg-config > > checking pkg-config is at least version 0.9.0... > > /var/tmp/portage/net-libs/gnutls-3.5.9/work/gnutls-3.5.9/configure: line > > 5020: /usr/bin/i686-p

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-13 Thread Hogren
On 13/02/2017 04:42, meino.cra...@gmx.de wrote: > Hi, > > got a mysterious error message this morning (still building a new > root...) > > One of the updates was gnutls: > It ends with: > ... > checking for i686-pc-linux-gnu-pkg-config... > /usr/bin/i686-pc-linux

Re: [gentoo-user] error installing xorg

2006-09-14 Thread Jean-Marc Beaune
the error message are usually enough for those who know thisstuff.Something like this. checking for i686-pc-linux-gnu-pkg-config... nochecking for pkg-config... /usr/bin/pkg-configchecking pkg-config is at least version 0.9.0... yeschecking for XKBFILE... configure: error: Package requirements (x11

[gentoo-user] pkg-config new ebuild - howto

2011-05-03 Thread Helmut Jarausch
Hi, I need webkitgtk-3.0.pc I've used net-libs/webkit-gtk-1.4.0-r200 from the gnome overlay. Unfortunately it installs only webkitgtk-1.0.pc (in /usr/lib64/ pkgconfig) How to specify the name of the pkg-config file in an ebuild? Many thanks for a hint, Helmut.

Re: [gentoo-user] glib-config and gtk-config point to version 1.2?

2005-08-03 Thread Matt Garman
. pkg-config is for the new version: pkg-config --cflags gtk+-2.0 pkg-config --libs gtk+-2.0 Somebody should have RTFM'ed me: http://gtk.org/tutorial/sec-compiling.html Thanks! Matt -- Matt Garman email at: http://raw-sewage.net/index.php?file=email -- gentoo-user

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-13 Thread Meino . Cramer
ith: > > ... > > checking for i686-pc-linux-gnu-pkg-config... > > /usr/bin/i686-pc-linux-gnu-pkg-config > > checking pkg-config is at least version 0.9.0... > > /var/tmp/portage/net-libs/gnutls-3.5.9/work/gnutls-3.5.9/configure: line > > 5020: /usr/bin/i686-p

Re: [gentoo-user] xorg-x11: Compile always fails.

2006-06-30 Thread Nico Schümann
This didn't solve the problem. # emerge =x11-libs/libXt-1.0.2 Calculating dependencies... done! Emerging (1 of 1) x11-libs/libXt-1.0.2 to / [...] appending configuration tag F77 to libtool checking for i686-pc-linux-gnu-pkg-config... no checking for pkg-config... /usr/bin/pkg-config checking pkg-config

[gentoo-user] pkg-config and qt4 in an ebuild

2005-12-04 Thread romildo
Hello. I am writing an ebuild for bookmarkbridge (bookmarkbridge.sf.net), which depends on qt-4.0.1. configure (by means of pkg-config) is not findind QtGui, although the file QtGui.pc is installed (as /usr/lib64/qt4/QtGui.pc). First of all, why QtGui.pc is not installed on a standard location

[gentoo-user] Package gl?

2009-12-27 Thread Willie Wong
Hi, brand new system I am trying to install. emerge gets to xorg-server-1.7.3.901-r1 and dies with the message that the config script cannot find package gl. And it is true, if I issue pkg-config --libs gl I get, instead of the expected -IGL Package gl was not found in the pkg-config search

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-13 Thread Johannes Rosenberger
o.cra...@gmx.de wrote: >>>>> Hi, >>>>> >>>>> got a mysterious error message this morning (still building a new >>>>> root...) >>>>> >>>>> One of the updates was gnutls: >;>>>> It ends with: >

[gentoo-user] emerge cblas-reference dies

2007-09-19 Thread Grant Edwards
-- [...] checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for BLAS... configure: error: Package requirements (blas) were not met: No package 'blas' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software

[gentoo-user] Java Config Problems.

2006-10-09 Thread Joshua Schmidlkofer
to be installing everything under /var/tmp/ /var/db/pkg/dev-java/java-config-1.3.7/CONTENTS === hosting java_config # cat /var/db/pkg/dev-java/java-config-1.3.7/CONTENTS dir /usr dir /usr/lib dir /usr/lib/python2.4 dir /usr/lib/python2.4/site-packages [snip] dir /var/tmp/portage/java

Re: [gentoo-user] Sonic-Visualiser compile error

2009-01-31 Thread Arttu V.
On 1/31/09, meino.cra...@gmx.de meino.cra...@gmx.de wrote: I tried to emerge sonic-visualiser (1.4) and it fails to compile From the logfile (attached): Project MESSAGE: WARNING: Failed to find pkg-config package redland Project MESSAGE: Using pkg-config package rasqal with version 0.9.10

Re: [gentoo-user] xorg-x11-7 emerge fails on libXt dependencies unmet

2006-07-15 Thread Donnie Berkholz
Mark Knecht wrote: Hi, Sorry this is a little long but it's mostly cut and paste stuff. Using the instructions here: http://gentoo-wiki.com/HOWTO_Modular_Xorg I am at the point of emerging xorg-x11-7. It fails pretty much immediately with this message: checking for pkg-config

[gentoo-user] Possible bug with ~arch libgphoto2 and libexif?

2009-09-01 Thread Arttu V.
Hello, Gentoo Humour Section strikes again, hitting me with a headshot, which almost dropped me from my chair. This time it came with something probably right out of Monty Python: checking for x86_64-pc-linux-gnu-pkg-config... (cached) /usr/bin/pkg-config checking pkg-config is at least version

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-13 Thread Johannes Rosenberger
>>> >>> One of the updates was gnutls: >>> It ends with: >>>; ... >>> checking for i686-pc-linux-gnu-pkg-config... >>> /usr/bin/i686-pc-linux-gnu-pkg-config >>> checking pkg-config is at least version 0.9.0... >>>; /var/tmp/portage/

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-13 Thread Meino . Cramer
gt; got a mysterious error message this morning (still building a new > >>> root...) > >>> > >>> One of the updates was gnutls: > >>> It ends with: > >>> ... > >>> checking for i686-pc-linux-gnu-pkg-config... > >>&g

[gentoo-user] Build error: Gnome update

2006-07-13 Thread Meino Christian Cramer
for glib-genmarshal... /usr/bin/glib-genmarshal checking for gconftool-2... /usr/bin/gconftool-2 checking what warning flags to pass to the C compiler... -Wall -Wmissing-prototypes checking what language compliance flags to pass to the C compiler... checking for i386-pc-linux-gnu-pkg-config

Re: [gentoo-user] [OT] Ebuild with scons and sandbox

2005-08-16 Thread Nagatoro
managed to put together, --- # This is a hack to be able to dynamically determine which directories # scons will try to create .scons* files in. get_config() { for lib in `grep ParseConfig('pkg-config SConstruct | tr ' ' ' | cut -d -f 5- | tr ')' ' '`; do echo `pkg-config

[gentoo-user] bind chrooting: mount permission denied...

2009-05-07 Thread Jarry
Hi, I just emerged bind and at the end I tried to set-up chroot for it just as it is adviced in messages: # emerge --config '=net-dns/bind-9.4.3_p2' Configuring pkg... * * Setting up the chroot directory...mount: permission denied Done. Where can I find

[gentoo-user] app-admin/system-config-printer-gnome-1.3.12 not building

2013-06-11 Thread Francisco Ares
}/lib64/python2.7/site-packages checking for python extension module directory... ${exec_prefix}/lib64/python2.7/site-packages checking for x86_64-pc-linux-gnu-pkg-config... /usr/bin/x86_64-pc-linux-gnu-pkg-config checking pkg-config is at least version 0.9.0... yes checking for GLIB... yes checking

Re: [gentoo-user] alsa-plugins emerge failure

2008-04-18 Thread Alan McKinnon
) checking how to hardcode library paths into programs... immediate checking for ANSI C header files... (cached) yes checking for i686-pc-linux-gnu-pkg-config... no checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for ALSA... yes checking

[gentoo-user] Emerge firefox error

2006-08-30 Thread Oliver Klein
Hi I want to re-emerge firefox but it ends with this error message checking for pkg-config... /usr/bin/pkg-config checking for gtk+-2.0 = 1.3.7... Package atk was not found in the pkg-config search path. Perhaps you should add the directory containing `atk.pc' to the PKG_CONFIG_PATH environment

[gentoo-user] Re: Safe to install libpng-1.2.44?

2010-07-04 Thread walt
On 07/04/2010 06:38 PM, Enrico Weigelt wrote: Hi folks, * library imports should _always_ happen via pkg-config (dont use .la files) +1 (Am I allowed +100?)

Re: [gentoo-user] Re: Safe to install libpng-1.2.44?

2010-07-06 Thread Mike Edenfield
On 7/4/2010 10:05 PM, walt wrote: On 07/04/2010 06:38 PM, Enrico Weigelt wrote: Hi folks, * library imports should _always_ happen via pkg-config (dont use .la files) +1 (Am I allowed +100?) If so, allow me to +1billion

Re: [gentoo-user] trouble with libxcb (and others)

2011-04-26 Thread Todd Goodman
checking for pkg-config... /usr/bin/pkg-config checking for libwpd-0.8 ... Package libwpd-0.8 was not found in the pkg-config search path. Perhaps you should add the directory containing `libwpd-0.8.pc' to the PKG_CONFIG_PATH environment variable No package 'libwpd-0.8' found

Re: [gentoo-user] Re: dev-libs/libgamin-0.1.10-r2 fails to emerge on a multilib profile

2010-02-27 Thread Arttu V.
these and the error shown above came up. grep for pkg-config inside the config.log (and maybe build.log as well). I'm betting on pkg-config not being found, although the ebuild seems to list it as a dependency. (Maybe your chroot settings affect the path?) IIRC another package did the same for me

Re: [gentoo-user] Re: dev-libs/libgamin-0.1.10-r2 fails to emerge on a multilib profile

2010-02-28 Thread Mick
. That was my first thought too. I ran lafixer and revdep-rebuild after emerging these and the error shown above came up. grep for pkg-config inside the config.log (and maybe build.log as well). I'm betting on pkg-config not being found, although the ebuild seems to list it as a dependency

Re: [gentoo-user] Possible bug with ~arch libgphoto2 and libexif?

2009-09-01 Thread Paul Hartman
On Tue, Sep 1, 2009 at 10:21 AM, Arttu V.arttu...@gmail.com wrote: Hello, Gentoo Humour Section strikes again, hitting me with a headshot, which almost dropped me from my chair. This time it came with something probably right out of Monty Python: checking for x86_64-pc-linux-gnu-pkg-config

Re: [gentoo-user] Gnome-config question

2005-06-16 Thread Zarick Lau
License: GPL-2 FDL-1.1 Al gnome2 based libs will use pkg-config, if you see gnome-config in Makefile, most likely, it is referring to gnome1 stuffs. So obviously, you need to the gnome applet library of gnome1.4 (not gnome2) Regards, Zarick Lau -- gentoo-user@gentoo.org mailing list

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-13 Thread Meino . Cramer
g...@iiiha.com> [17-02-13 17:06]: > >>>> On 13/02/2017 04:42, meino.cra...@gmx.de wrote: > >>>>> Hi, > >>>>> > >>>>> got a mysterious error message this morning (still building a new > >>>>> root...) > &g

Re: [gentoo-user] Building a new root for my Gentoo: Permission denied?

2017-02-14 Thread Johannes Rosenberger
ssage this morning (still building a new >>>>>>> root...) >;>>>>>> >>>>>>> One of the updates was gnutls: >>>>>>> It ends with: >>>>>>> ... >>>>>>;> checking for i686-pc

Re: [gentoo-user] New java-config package with no java installed?

2006-06-24 Thread Alexander Skwar
it? In the libidn ebuild, I find: inherit java-pkg And that's what pulling in java-config. Is there a way to wrap the inherit around some if statements, so that inherit java-pkg is only executed when java is set? Alexander Skwar -- It now costs more to amuse a child than it once did to educate his

Re: [gentoo-user] New java-config package with no java installed?

2006-06-25 Thread Rumen Yotov
? It doesn't make much sense, does it? In the libidn ebuild, I find: inherit java-pkg And that's what pulling in java-config. Is there a way to wrap the inherit around some if statements, so that inherit java-pkg is only executed when java is set? Alexander Skwar Hi, IIRC portage still can't

[gentoo-user] emerge luatex-0.30.3 fails

2009-09-02 Thread Strake
LIBMPLIBDEP=/usr/$(get_libdir)/libmplib/mplib.la LDZZIPLIB=$(pkg-config --libs zziplib) ZZIPLIBINC=$(pkg-config --cflags zziplib) LIBXPDFDEP= LDLIBXPDF=$(pkg-config --libs poppler) LIBXPDFINCLUDE=$(pkg-config --cflags poppler) LIBXPDFCPPFLAGS=$(pkg-config --cflags poppler) LIBPNGINCLUDES=$(pkg-config --cflags

Re: [gentoo-user] [SOLVED] Re: dev-libs/libgamin-0.1.10-r2 fails to emerge on a multilib profile

2010-02-28 Thread Mick
. That was my first thought too. I ran lafixer and revdep-rebuild after emerging these and the error shown above came up. grep for pkg-config inside the config.log (and maybe build.log as well). I'm betting on pkg-config not being found, although the ebuild seems to list it as a dependency

[gentoo-user] Re: Merging of config files in /etc

2005-10-06 Thread Remy Blank
was proposed. What is the output from emerge --info | grep CONFIG on both computers? On the one that did the update: CONFIG_PROTECT=/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control CONFIG_PROTECT_MASK=/etc/gconf /etc/terminfo /etc/env.d

Re: [gentoo-user] problem emerging Libdrm

2015-01-25 Thread Andrew Savchenko
? As for libpng: the problem is that after libpng update many pkg-config files still contain references to old libpng15.so. Usual way to fix this is to rebuild all libpng dependencies (emerge @revdep-rebuild or revdep-rebuild tool may be used for that). But this doesn't work on too old setups, where

Re: [gentoo-user] unable to compile totem

2007-08-10 Thread Bo Ørsted Andresen
the configure script would be: # pkg-config --exists firefox-xpcom which returns false in your case. You'd be more interested in: # pkg-config --exists --print-errors firefox-xpcom though, as that prints a human readable error message. I bet `equery check mozilla-firefox` will report that some

[gentoo-user] Re: libpng12 is missing

2010-05-09 Thread walt
notification-daemon-0.4.0-r1. the error found in the build log is: cannot find -lpng12 i have both libpng-1.2.43-r1 and libpng-1.4.2 installed, but i do not have libpng12.a in my /usr/lib64 directory. and 'pkg-config libpng --libs' only show '-lpng14'. This looks to me like a major portage screwup

Re: [gentoo-user] Safe to install libpng-1.2.44?

2010-07-04 Thread Enrico Weigelt
for that, some ideas: (of course, yet limited to C and similar languages ;-o) * libraries with (incompatible) interface changes should install their headers under some own versioned prefix * library imports should _always_ happen via pkg-config (dont use .la files) * pkg-config descriptors

Re: [gentoo-user] Safe to install libpng-1.2.44?

2010-07-04 Thread Dale
working on an generic design for that, some ideas: (of course, yet limited to C and similar languages ;-o) * libraries with (incompatible) interface changes should install their headers under some own versioned prefix * library imports should _always_ happen via pkg-config (dont use .la files

Re: [gentoo-user] Emerge @system causing gcc downgrade

2017-03-07 Thread White, Phil
used and messed up > system. The safest way to recreate it is probably to move the pkg > directory elsewhere and then run "emerge -e @world". > Yep! I think that would be a polite way of putting it! ;) > gcc is slotted, so emerging 4.9.4 will not touch your 5.4.0 installati

Re: [gentoo-user] bind chrooting: mount permission denied...

2009-05-07 Thread Mark Shields
On Thu, May 7, 2009 at 2:43 PM, Jarry mr.ja...@gmail.com wrote: Hi, I just emerged bind and at the end I tried to set-up chroot for it just as it is adviced in messages: # emerge --config '=net-dns/bind-9.4.3_p2' Configuring pkg... * * Setting up the chroot directory

Re: [gentoo-user] bind chrooting: mount permission denied...

2009-05-08 Thread Jarry
Mark Shields wrote: I just emerged bind and at the end I tried to set-up chroot for it just as it is adviced in messages: # emerge --config '=net-dns/bind-9.4.3_p2' Configuring pkg... * * Setting up the chroot directory...mount: permission denied Done. Where can

Re: [gentoo-user] bind chrooting: mount permission denied...

2009-05-08 Thread Alan McKinnon
On Friday 08 May 2009 18:10:10 Jarry wrote: Mark Shields wrote: I just emerged bind and at the end I tried to set-up chroot for it just as it is adviced in messages: # emerge --config '=net-dns/bind-9.4.3_p2' Configuring pkg... * * Setting up the chroot directory

Re: [gentoo-user] Re: Java java java, I miss my java

2005-06-14 Thread Zac Medico
to point to various places to get other things to happen? Yes, java-config -L will list every installed java vm. The actual portage database for installed packages is located in /var/db/pkg. Zac -- gentoo-user@gentoo.org mailing list

Re: [gentoo-user] MySQL 4.0 = 4.1 upgrade

2005-09-10 Thread Bastian Balthazar Bux
Free interpretation of Maurice van der Pot replay to this same email on gentoo-dev : --result-file=BACKUP_MYSQL_4.0.SQL [...] cmd# cat backup_mysql_4.0.sql \ Those two are the same file, so either use lower or UPPER case name. Also the password insterted during the ebuild /var/db/pkg

[gentoo-user] Error emerging media-videog/totem

2006-07-14 Thread Philipp Riegger
for msgmerge... /usr/bin/msgmerge checking for xgettext... /usr/bin/xgettext checking for i686-pc-linux-gnu-pkg-config... no checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for backend libraries... checking for GST... yes GStreamer-0.10

Re: [gentoo-user] Xulrunner 2.0 seems to demand Alsa : any advice ?

2011-03-29 Thread Philip Webb
110328 Florian Philipp wrote: Am 27.03.2011 20:51, schrieb Philip Webb: Wanting to try Firefox 4.0 , I tried to emerge Xulrunner 2.0 ran into this problem : root:527 profile emerge xulrunner checking for alsa... Package alsa was not found in the pkg-config search path. Definitely

[gentoo-user] trouble with libxcb (and others)

2011-04-26 Thread Allan Gottlieb
: No such file or directory gottlieb@ajglap ~ $ There is no libxcb-aux now on my system nor is there an libxcb-atom, which revdep rebuild mentioned. openoffice (picked up by revdep-rebuild) fails to build saying checking for pkg-config... /usr/bin/pkg-config checking for libwpd-0.8 ... Package

Re: [gentoo-user] trouble with libxcb (and others)

2011-04-26 Thread Allan Gottlieb
There is no libxcb-aux now on my system nor is there an libxcb-atom, which revdep rebuild mentioned. openoffice (picked up by revdep-rebuild) fails to build saying checking for pkg-config... /usr/bin/pkg-config checking for libwpd-0.8 ... Package libwpd-0.8 was not found in the pkg-config search

Re: [gentoo-user] Firefox no-sound problem (was local overlay problem)

2013-02-01 Thread Sebastian Beßler
On 02.02.2013 04:54, Philip Webb wrote: checking for alsa... Package alsa was not found in the pkg-config search path. ... configure: error: Need alsa for Ogg, Wave or WebM decoding on Linux. Disable with --disable-ogg --disable-wave --disable-webm. This looks like the next path

[gentoo-user] Re: autofs config

2017-01-08 Thread Harry Putnam
Harry Putnam <rea...@newsguy.com> writes: > I've never used autofs and am trying to get it setup. > > Following the debian wiki and an Ubuntu howto. > >; I've installed the pkg: > > aptitude search ^autofs|grep ^i > i autofs - kerne

Re: [gentoo-user] progress everywhere !

2008-10-19 Thread Alan McKinnon
? ( || ( net-libs/xulrunner:1.8 net-libs/xulrunner:1.9 =www-client/seamonkey-1* ) =dev-libs/nspr-4.6.6 =dev-libs/nss-3.11-r1 ) And later we have this snippet: pkg_setup() { if use nsplugin; then if pkg-config --exists libxul

Re: [gentoo-user] emerge confused about gnome-icon-theme version?

2006-12-31 Thread Bo Ørsted Andresen
of portage checking the environment before the actual compile. It uses the return value of: # pkg-config --exists --print-errors gnome-icon-theme = 2.15.91 to determine whether it's requirement is fulfilled. Maybe you have some orphaned pkg-config file (.pc) as Kent suggests. The output of e.g

Re: [gentoo-user] Re: [Extremely OT] Ansible/Puppet replacement

2015-01-27 Thread Alec Ten Harmsel
are on a mounted filesystem, it should be similar to the role below: file /etc/portage/make.conf root:root 644 ! emerge-webrsync ! emerge --sync file /etc/locale.gen root:root 600 ! locale-gen pkg sys-kernel/gentoo-sources file /usr/src/linux/.config root:root 644 ! make -C /usr

[gentoo-user] after world update cxfe will not emerge

2012-01-20 Thread covici
is DEPRECATED. Use pkg-config instead. x86_64-pc-linux-gnu-gcc -Wall -Wl,-O1 -Wl,--as-needed cxfe.o post.o termio/getch2.o `xine-config --libs` -L/usr/X11R6/lib -lXext -lxine -lncurses -lm -lXext \-lX11 -lX11 -o cxfe xine-config is DEPRECATED. Use pkg-config instead. cxfe.o: In function

Re: [gentoo-user] Removing Specific Kernel Sources

2005-12-18 Thread Myk Taylor
maintainable: --- from /etc/make.conf -- PORTAGE_TMPDIR=/var/portage DISTDIR=${PORTAGE_TMPDIR}/distfiles PKGDIR=${PORTAGE_TMPDIR}/portage-pkg DISTCC_DIR=${PORTAGE_TMPDIR}/distcc KBUILD_OUTPUT=${PORTAGE_TMPDIR}/kernel end -- then I have a script that builds the kernel

Re: [gentoo-user] Compilation failed...mcs not found

2016-07-28 Thread Fernando Rodriguez
ipt /usr/share/config.site >>> checking for a BSD-compatible install... >>> /usr/lib/portage/python2.7/ebuild-helpers/xattr/install -c >>> checking whether build environment is sane... yes >>> checking for a thread-safe mkdir -p... /bin/mkdir -p >>> chec

Re: [gentoo-user] Compilation failed...mcs not found

2016-07-28 Thread Meino . Cramer
build environment is sane... yes > > checking for a thread-safe mkdir -p... /bin/mkdir -p >; &gt; checking for gawk... gawk > > checking whether make sets $(MAKE)... yes > > checking how to create a ustar tar archive... gnutar > > checking whether to enable maintainer-specif

Re: [gentoo-user] Confusing boot up messages

2006-08-14 Thread Neil Bothwick
know if it was a path level update? Sorry, typo. I meant to type patch level upgrade, as in pkg-x.y.z-r1 to pkg-x.y.z-r4. There were some significant changes between baselayout 1.11 and 1.12, this is probably the cause of the problems. If you know which services were affected but didn't catch

[gentoo-user] emerge --buildpkg --unmerge

2010-10-29 Thread Fatih Tümen
in FEATURES at the time of emerging them. Doing this now by hand sounds kinda fatigue unless... the output of --pretend was parsable so I do what I want by.. for pkg in ${PKGS}; do quickpkg --include-config\=y $pkg; done or by something better? Thanks for ideas in advance. --    Fatih

Re: [gentoo-user] emerge --buildpkg --unmerge

2010-10-29 Thread Alan McKinnon
--include-config\=y $pkg; done or by something better? Thanks for ideas in advance. -- Fatih Write a wrapper script around quickpkg and emerge. And set buildpkg in FEATURES so this doesn't happen again :-) -- alan dot mckinnon at gmail dot com

Re: [gentoo-user] Haskell packages and keeptemp

2015-09-20 Thread Michael Orlitzky
he next build. > Please open a bug. Portage probably has its own reasons for handling ${T} the way it does. The problem with the Haskell stuff is (in haskell-cabal.eclass), # Newer cabal can generate a package conf for us: ./setup register --gen-pkg-config="${T}/${P}.conf" ghc-in

Re: [gentoo-user] sys-libs/db-4.5.20_p2-r1 fails before compile starts

2008-09-22 Thread Alan McKinnon
-config? NV_DEPEND: tcl? ( =dev-lang/tcl-8.4 ) java? ( =virtual/jdk-1.4 ) =sys-devel/binutils-2.16.1 test? ( =dev-lang/tcl-8.4 ) java? ( =dev-java/java-config-2.0.33-r1 =sys-apps/portage-2.1.2.7 ) =sys-devel/automake-1.10* =sys-devel/autoconf-2.61 sys-devel

Re: [gentoo-user] Package gl?

2009-12-27 Thread Willie Wong
On Sun, Dec 27, 2009 at 12:27:47PM -0500, Penguin Lover Willie Wong squawked: Hi, brand new system I am trying to install. emerge gets to xorg-server-1.7.3.901-r1 and dies with the message that the config script cannot find package gl. And it is true, if I issue pkg-config --libs gl I

[gentoo-user] Java problem

2010-05-22 Thread David Relson
elibc_glibc kernel_linux multilib userland_GNU !!! ERROR: Package ant-junit was not found! * Unable to determine VM for building from dependencies: NV_DEPEND: =virtual/jdk-1.4 !dev-java/ant-tasks !dev-java/ant-optional =dev-java/java-config-2.1.9-r1 source? ( app-arch/zip

[gentoo-user] help w/ mobo/cpu combo

2005-05-15 Thread maxim wexler
Hello everbody, for an Asus K8N-E, skt 754, nForce3 w/ Sempron3100, 512DDR400 RAM, 120G ATA(IDE)drive, Radeon9250 video card. Anybody have any pointers, gotchas re setting up gentoo on such a system. USE flags? Proper kernel config? etc, etc... I have the 2004.3 and 2005.0 universal-install

Re: [gentoo-user] livejournal server gentoo vs mod_perl

2005-06-14 Thread A. Khattri
these days). At the end of the ebuild is this message: Execute ebuild /var/db/pkg/www-apache/mod_perl/mod_perl-1.27-r4.ebuild config to have your apache.conf auto-updated for use with this module. You should then edit your /etc/conf.d/apache file to suit. -- -- gentoo-user@gentoo.org mailing

Re: [gentoo-user] Re: KDE (mono to meta) migration

2006-06-27 Thread Neil Bothwick
On Sat, 24 Jun 2006 18:28:39 +0200, Bo Ørsted Andresen wrote: You seem to have been more confused than enlightened by the tricks I posted. If you want to nuke kde completely you should just do: # cd /var/db/pkg emerge -Cva kde-base/* You should also rm -fr /usr/kde or rm -fr /usr/kde/3.[0

Re: [gentoo-user] New java-config package with no java installed?

2006-06-28 Thread Bo Ørsted Andresen
On Sunday 25 June 2006 10:21, Mick wrote: I suspect that it has something to do with the latest portage-2.1-r1 update or the one before.  Up until now the -java default USE flag seemed to do the trick. It had nothing to do with portage. It had to do with a change in the java-pkg eclass

[gentoo-user] problem with upgrading Xorg from 6.8.2 up to 7.0

2006-08-24 Thread Dmitry
... immediate appending configuration tag F77 to libtool checking for ANSI C header files... (cached) yes checking whether byte ordering is bigendian... no checking for vasnprintf... no checking for cos in -lm... yes checking for i686-pc-linux-gnu-pkg-config... no checking for pkg-config... /usr/bin/pkg-config

[gentoo-user] libpng12 is missing

2010-05-09 Thread Xi Shen
, but i do not have libpng12.a in my /usr/lib64 directory. and 'pkg-config libpng --libs' only show '-lpng14'. i guess these 2 versions do not work well with each other. how can i fix this? P.S. i have 'png' in my USE flags. -- Best Regards, David Shen http://twitter.com/davidshen84/

Re: [gentoo-user] trouble with libxcb (and others)

2011-04-27 Thread Allan Gottlieb
by revdep-rebuild) fails to build saying checking for pkg-config... /usr/bin/pkg-config checking for libwpd-0.8 ... Package libwpd-0.8 was not found in the pkg-config search path. Perhaps you should add the directory containing `libwpd-0.8.pc' to the PKG_CONFIG_PATH environment variable

Re: [gentoo-user] trouble with libxcb (and others)

2011-04-27 Thread Todd Goodman
. My system is ~amd64. [SNIP] openoffice (picked up by revdep-rebuild) fails to build saying checking for pkg-config... /usr/bin/pkg-config checking for libwpd-0.8 ... Package libwpd-0.8 was not found in the pkg-config search path. Perhaps you should add the directory

[gentoo-user] Error building gpick-0.2.3 on gentoo linux

2011-05-01 Thread José Romildo Malaquias
Hello. I would like to have the latest version (0.2.3) of gpick installed on my ~amd64 gentoo linux system, but configure is failling with the error: [...] scons -j3 scons: Reading SConscript files ... Checking for dbus-glib-1 = 0.76... no # pkg-config --modversion dbus-glib-1 0.92 # scons

Re: [gentoo-user] Re: Java java java, I miss my java

2005-06-14 Thread Kevin O'Gorman
all those old versions, and I just need java-config to point to various places to get other things to happen? Yes, java-config -L will list every installed java vm. The actual portage database for installed packages is located in /var/db/pkg. Zac Great! Thanks one and all

[gentoo-user] failed to install tinyERP: how to fix?

2007-03-19 Thread Zhang Weiwu
Hello. When I emerged tinyERP server I was told I should run the below command to configure it. But it doesn't work. emerson files # emerge --config =app-office/tinyerp-server-4.0.2 Configuring pkg... * In the following, the 'postgres

[gentoo-user] re: Failed to load x86_pkg_temp_thermal

2014-04-12 Thread Alexander Kapshuk
...@linux.intel.com description:X86 PKG TEMP Thermal Driver alias: x86cpu:vendor::family:*:model:*:feature:*00E6* depends: intree: Y vermagic: 3.12.13-gentoo SMP mod_unload CORE2 parm: notify_delay_ms:User space notification delay in milli seconds. (int) I found

Re: [gentoo-user] Anyone else's Gentoo unruly lately?

2008-06-29 Thread Philip Webb
080629 Alan McKinnon wrote: Doesn't that give you a huge world file ... No: of course, I 'emerge -1' when the pkg is not marked 'W/S' in my pkg.ref. Currently, 'world' lists 97 pkgs ; pkg.ref lists 513 pkgs. ... and no easy way to identify redundant and unused libs? This is clear when

Re: [gentoo-user] New MySQL doc

2005-07-11 Thread Nick Rout
config. the config step only needs to be carried out the very first time mysql is emerged. Thats why the instructions that appear at the end of the emerge say: You might want to run: ebuild /var/db/pkg/dev-db/mysql-4.0.24-r1/mysql-4.0.24-r1.ebuild config IF THIS IS A NEW INSTALL. (my emphasis

Re: [gentoo-user] unable to compile totem

2007-08-10 Thread John covici
of relevance is useful to make sure no error messages are missing. Anyway the relevant command from the configure script would be: # pkg-config --exists firefox-xpcom which returns false in your case. You'd be more interested in: # pkg-config --exists --print-errors firefox-xpcom

Re: [gentoo-user] emerge --buildpkg --unmerge

2010-10-29 Thread Fatih Tümen
was parsable so I do what I want by.. for pkg in ${PKGS}; do quickpkg --include-config\=y $pkg; done or by something better? Thanks for ideas in advance. --    Fatih Write a wrapper script around quickpkg and emerge. And set buildpkg in FEATURES so this doesn't happen again

[gentoo-user] Compilation failed...mcs not found

2016-07-28 Thread Meino . Cramer
or a thread-safe mkdir -p... /bin/mkdir -p checking for gawk... gawk checking whether make sets $(MAKE)... yes checking how to create a ustar tar archive... gnutar checking whether to enable maintainer-specific portions of Makefiles... no checking for pkg-config... /usr/bin/pkg-config checking f

Re: [gentoo-user] Emerge @system causing gcc downgrade

2017-03-07 Thread Dale
lient, and on > to a web-based thing. >; > > If you copied over /var/db/pkg you have a rather confused and > messed up > system. The safest way to recreate it is probably to move the pkg > directory elsewhere and then run "emerge -e @world". > > > Yep! I think

Re: [gentoo-user] Emerge @system causing gcc downgrade

2017-03-07 Thread Alan McKinnon
roper mail client, and on > to a web-based thing. &gt; > > If you copied over /var/db/pkg you have a rather confused and messed up > system. The safest way to recreate it is probably to move the pkg > directory elsewhere and then run "emerge -e @world&q

Re: [gentoo-user] emerge confused about gnome-icon-theme version?

2006-12-31 Thread Kent Fredric
? It appears no one has any suggestions. Can someone perhaps tell me how portage goes about determining the installed version to give me a direction to start trying to figure this out. -- gentoo-user@gentoo.org mailing list Hi there, All installed packages are recorded in /var/db/pkg so in your

[gentoo-user] Problem installing subversion

2007-01-29 Thread Jeffrey Rollin
self.take_action( File /usr/lib/python2.4/optparse.py, line 726, in take_action self.callback(self, opt, value, parser, *args, **kwargs) File /usr/bin/depend-java-query, line 49, in get_vm vm = verman.get_vm(value) File /usr/share/java-config-2/pym/java_config/VersionManager.py, line

Re: [gentoo-user] Emerge @system causing gcc downgrade

2017-03-07 Thread Neil Bothwick
), I have accidentally copied over files that do not >; belong. My guess is a completely useless /var/db/pkg/* is confusing the > hell out of portage/emerge. If you copied over /var/db/pkg you have a rather confused and messed up system. The safest way to recreate it is probably to move the pkg dire

Re: [gentoo-user] Cleaning redundant configuration files

2011-06-02 Thread Indi
to -C or -c options on an emerge command, not the internal actions during an upgrade/rebuild. I have stated that several times in this thread, so I thought I had made myself clear. Even if the -C option is used, I would still want it to be something extra to remove config files

Re: [gentoo-user] re: Failed to load x86_pkg_temp_thermal

2014-04-12 Thread Dragostin Yanev
srinivas.pandruv...@linux.intel.com description:X86 PKG TEMP Thermal Driver alias: x86cpu:vendor::family:*:model:*:feature:*00E6* depends: intree: Y vermagic: 3.12.13-gentoo SMP mod_unload CORE2 parm: notify_delay_ms:User space notification delay in milli

Re: [gentoo-user] Old machine update - libexpat upgrade instructions?

2008-04-11 Thread Alan McKinnon
chipset and the machine broke. Hope this explains my comment. Portage to the rescue!! :-) Well, eix actually. It comes with a script - eix-test-obsolete - that scans your portage config files looking for inconsistencies and redundancies, then splits huge amounts of output to the console. One

Re: [gentoo-user] paludis and make.conf

2009-05-21 Thread Dirk Heinrichs
Am Mittwoch, 20. Mai 2009 22:57:05 schrieb maxim wexler: Now that I'm starting to use paludis in place of portage Congratulations :-) Sure enough, under /var/db/pkg/.cache, appear the following: all_CONFIG_PROTECT all_CONFIG_PROTECT_MASK But how did paludis decide to use these variables

[gentoo-user] Re: [Way OT] Kernel Symlink use or not use?

2007-03-23 Thread Steve Long
Xavier Parizet wrote: I think that the /usr/src/linux symlink is used in Gentoo by ebuilds (as vmware-modules for example) that build kernel modules for specific hardware which aren't yet in the kernel, and so needs to know the current kernel config to see if it match their dependencies

Re: [gentoo-user] EMERGENCY - GCC GONE!

2006-05-31 Thread Mike Williams
emerging gcc-3.4.4-r1.  emerge --unmerge gcc-3.4.5 gcc-3.4.5-r1 (the only two greater that 3.4.4 that I had installed). For reasons that I can't fathom, gcc, is now gone.  Totally. Completely.  Not there. gcc-config -l or poke around in /var/db/pkg I thought libstdc++.so.6 was the gcc 3.4 c++ abi

Re: [gentoo-user] fsck + emerge = crash

2009-11-16 Thread Volker Armin Hemmann
user: emerge: incomplete set configuration, missing set(s): world and system This usually means that '/usr/share/portage/config/sets.conf' is missing or corrupt. probably that files endet in LOST+FOUND. You also can get them from a portage tarfile as su I get a bunch

[gentoo-user] Re: libpng12 is missing

2010-05-09 Thread walt
-1.2.43-r1 and libpng-1.4.2 installed, but i do not have libpng12.a in my /usr/lib64 directory. and 'pkg-config libpng --libs' only show '-lpng14'. Are you sure you still have version 1.2.43 installed? I'm going thru the same thing now on x86 and libpng-1.2 was deleted during the update. I now

  1   2   3   >