Is there any way for you to test if the problem exists if you don't allow simultaneous POP3 logins?


Oversea Site via xmail schreef op 26/05/15 om 08:14:
POP3Utils.cpp - ADD POP3 Concurrent Login. I used this function over 5 years.. 
I don't know C++ programming. Sorry :)
====================================================================================================================

        }
         if (pPOPMD->ulFlags & POPF_MSG_DELETED) {
                 UPopSendErrorResponse(hBSock, ERR_MSG_DELETED, 
pPOPSD->iTimeout);

                 ErrSetErrorCode(ERR_MSG_DELETED);
                 return ERR_MSG_DELETED;
         }

         UsrGetMailboxPath(pPOPSD->pUI, szMsgFilePath, sizeof(szMsgFilePath), 
1);
         StrNCat(szMsgFilePath, pPOPMD->szMsgName, sizeof(szMsgFilePath));
/*
  * ADDED CODE START
  */

FILE *pMsgFile = fopen(szMsgFilePath, "rb");
if (pMsgFile == NULL) {
UPopSendErrorResponse(hBSock, ERR_FILE_OPEN, pPOPSD->iTimeout);

ErrSetErrorCode(ERR_FILE_OPEN);
return ERR_FILE_OPEN;
}
fclose(pMsgFile);

/*
  * ADDED CODE END
  */

         SysSNPrintf(szResponse, sizeof(szResponse) - 1,
                     "+OK " SYS_OFFT_FMT " bytes", pPOPMD->llMsgSize);
         if (BSckSendString(hBSock, szResponse, pPOPSD->iTimeout) < 0)
                 return ErrGetErrorCode();

         if (pPOPMD->llMsgSize > 0 &&


---- Original Message ----
From: Oversea Site via xmail <xmail@xmailserver.org>
To: "XMail Users Mailing List" <xmail@xmailserver.org>
Sent: Tue, May 26, 2015, 1:56 PM
Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL

FEDORA 4 X86_64 GLIBC 2.3.6-3 (I can't upgrade it to the lastest version. 
Because I have a chiliasp 3.6.2 32-bit run ASP VBSCRIPT on APACHE 1.3 32-bit 
software, it need GLIBC 2.3.x and Kernel 2.6)

KERNEL 3.3 MOD FROM FC15 (It will display KERNEL 2.6.43 Number). Kernel is not 
a main problem. Because I have been test 2.6.32 or other. same problem was 
found.

REAL HARDWARE -> INTEL B85M i3-4150 16G RAM SATA3 RAID 1 LINUX SOFTRAID1 MDADM

Corp. Email System is not heavily use when I test it in HK TIME midnight.

Anyway I will test this issue in other linux distribution in VM, such as 
CentOS. (You can give me any linux distribution, let's build the same platform 
in VM. I use virtualbox.

[root@bravo logs]# uname -a
Linux bravo 2.6.43-gcc402 #3 SMP Sun May 17 23:10:29 HKT 2015 x86_64 x86_64 
x86_64 GNU/Linux
[root@bravo logs]#
[root@bravo logs]# ldd /var/MailRoot/bin/XMail127v3
        linux-vdso.so.1 =>  (0x00007ffff7f0e000)
        libssl.so.0.9.8 => /usr/local/ssl/lib/libssl.so.0.9.8 
(0x00007f43b00bc000)
        libcrypto.so.0.9.8 => /usr/local/ssl/lib/libcrypto.so.0.9.8 
(0x00007f43afd35000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000003e18200000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003e18600000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f43afa37000)
        libm.so.6 => /lib64/libm.so.6 (0x0000003e18000000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003e19400000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003e17d00000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003e17b00000)

*******************************************************************
/var/MailRoot/bin/XMail127v3 -Md -Ms /var/MailRoot -Sl -Pl -Cl \
-SI 0.0.0.0:8025 -SI 0.0.0.0:25 \
-PI 0.0.0.0:8110 -PI 0.0.0.0:110 \
-BI 0.0.0.0:995 \
-XI 0.0.0.0:465 \
-Ql -Ln 256 -Pt 60 -St 150 -F- -SX 2048 -Mx 64 \
-Qn 64 -PX 2048 -Qr 10000 -Qt 1 -QT 150 -Qg -CX 256
*******************************************************************

---- Original Message ----
From: "U.Mutlu" <um4...@mutluit.com>
To: t...@os.st, "XMail Users Mailing List" <xmail@xmailserver.org>
Sent: Tue, May 26, 2015, 1:06 PM
Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL

Oversea Site via xmail wrote on 05/26/2015 05:14 AM:
No Log Error. No Fatal Error log. No Core Dump

It's not RAM or HW problem. It's XMAIL internal issue, because when I switch to 
stunnel, all problems solved. And then when I test K9-MAIL with XMAIL+STUNNEL, 
K9 Client will not have any JAVA somethings Exception Error

Two tests

1. Very Important Thing in Xmail 1.27 Native SSL

If the emailbox has many emails such as 10000, Microsoft Outlook with SSL or 
NON-SSL download them, it WILL NOT have this issue.
Some Tencent Foxmail for Windows, after finish ssl session, it will take the 
server be FIN_WAIT2 (some version, not all)
But K9-MAIL for Android, Download first 1000, it will appear the error in 
K9-MAIL randomly.


2. Xmail 1.27 + Stunnel Proxy

If the emailbox has many emails such as 10000, Microsoft Outlook with SSL or 
NON-SSL download them, it WILL NOT have this issue.
Some Tencent Foxmail for Windows, after finish ssl session, it WILL NOT have 
any problem. Server WILL NOT TAKE FIN_WAIT_2
K9-MAIL for Android, Download first 1000, it will NOT DISPLAY any error when it 
finished download emails.
I would need full description about the server HW and SW (OS version,
xmail start params etc., any xmail patches applied etc.).

There is of course also the possibility that the bug lies in the
said mobile client program, especially if it goes online via
unstable mobile links as it seems to be a link latency problem,
or the client does not close the socket cleanly. Take a look at these:
https://github.com/Automattic/socket.io/issues/1380
http://stackoverflow.com/questions/5328155/preventing-fin-wait2-when-closing-socket

cu
Uenal


---- Original Message ----
From: "U.Mutlu" <um4...@mutluit.com>
To: t...@os.st, "XMail Users Mailing List" <xmail@xmailserver.org>
Sent: Tue, May 26, 2015, 10:11 AM
Subject: Re: [xmail] BUG : XMAIL 1.27 with SSL

Oversea Site via xmail wrote on 05/25/2015 09:23 PM:
I found the bug on XMAIL 1.27 with SSL (POP3S is main), SSMTP service maybe
has a same bug too

1. it will have too many FIN_WAIT_2 on POP3S with two many requests, It is
because of some non-popular WINDOWS CLIENT e.g. tencent foxmail , outlook will
not have this issue.

2. If you're using XMAIL'S internal SSL POP3S with any openssl lib. (tested
0.9.8za 1.0.0, tested gcc 4.0.2/4.0.4/4.3.6) and the email account contain too
many emails (1000-2000 emails), the mobile client POP3 such as Samsung
internal Email Client is using SSL, K9-MAIL on any android devices using SSL,
some iPhone devices (connect with XMAIL SSL port 995), will not download them
successfully (Android Error - Java Exception Error) and some
iPhone device will stuck with it, it will not download all emails
successfully. But if you disable XMAIL'S internal POP3S with -B- startup
option, and switch stunnel 5.17 port 995 tunnel to port 110, it will solve
this problem and kick out FIN_WAIT_2

***** stunnel 5.17 config *****
[pop3s]
accept  = 995
connect = 110
cert = /etc/stunnel/stunnel.pem
***************************

What do the logs (server, client) say about the errors?

I think you need a faster server HW and/or need to optimize the resources,
for example the number of threads, and possibly also RAM.
An excerpt from the doc:
"
If you have an heavily loaded server remember to setup the best number of
XMAIL threads by specifying the '-Qn nthreads' option (you must do some
tentatives to find the best value for your needs). Also you can limit the
number of SMTP, POP3 and CTRL service threads by specifying the options '-SX
maxthreads', '-PX maxthreads' and '-CX maxthreads'.
"

If there are mail filters, you can put them into a ramdisk and set PATH
accordingly, or use an absolute path to them. See also XMAIL_TEMP in the doc.

In task manager / system monitor you can see how the resource usage is,
especially CPU, memory, and network.

--
cu
Uenal
_______________________________________________
xmail mailing list
xmail@xmailserver.org
http://xmailserver.org/mailman/listinfo/xmail

_______________________________________________
xmail mailing list
xmail@xmailserver.org
http://xmailserver.org/mailman/listinfo/xmail
_______________________________________________
xmail mailing list
xmail@xmailserver.org
http://xmailserver.org/mailman/listinfo/xmail


_______________________________________________
xmail mailing list
xmail@xmailserver.org
http://xmailserver.org/mailman/listinfo/xmail

Reply via email to