Here's something I haven't noticed before - I'm developing some html/js
files that display in a webarea in a 4D form. For development I'm opening a
separate process which displays a dialog with a webarea and a button on it.
Clicking the button let's me put in a record number, 4D looks up the
record, and puts it into a c-object variable. Then I open the index.html in
the web area, a javascript function gets the c-obj
<http://kb.4d.com/assetid=77177> and through the magic of Handlebars
renders it into the web area.

So here's the odd part - 4D seems to be caching the js files. I noticed
that if I make a change to the .js files, save them and re-load the web
area I can see in the Web Inspector that it's still running the unchanged
file.

And I can't figure out how to force it to clear. In fact I suddenly realize
I don't know how to do the equivalent of Clear Cache in a web area. I tried
opening a new process but that didn't work. I also tried calling


WA SET PAGE CONTENT(*;$webArea;"";"file:///")


​before re-loading but that didn't work either. ​Restart the database works
but seems a bit inelegant. Here's hoping someone has some insight.

-- 
Kirk Brooks
San Francisco, CA
=======================
**********************************************************************
4D Internet Users Group (4D iNUG)
FAQ:  http://lists.4d.com/faqnug.html
Archive:  http://lists.4d.com/archives.html
Options: http://lists.4d.com/mailman/options/4d_tech
Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com
**********************************************************************

Reply via email to