I resolved this issue though I'm not entirely sure what the fix is. I ran
MSC and did a 'repair' on the structure. Same results. Next I put the
specific call to the EOS method into a test method and found the issue
seemed to happen when called in the context of the form method it was
running. This is mature code so I couldn't really understand what had
changed but apparently something did.

Ultimately I made a new form method and began with this EOS method and its
supporting code. It worked. I continued adding more code back in until I
had basically re-built the form method. I did clear out some cruff along
the way and something in that must have been creating a situation where the
EOS call failed. ​

On Thu, Feb 22, 2018 at 5:26 PM, Kirk Brooks <lists.k...@gmail.com> wrote:

> I don't recall ever having this issue. I have a method set to execute on
> server. It takes a series of pointers and looks like this:
>
> $errMsg:=EOS_method (\
> ->$obj;\
> ->aMY_name;\
> ->aMY_ref;\
> ->aMy_recID;\
> ->aMY_info;\
> ->aMY_address;\
> ->aMY_amount;\
> ->aMY_billed;\
> ->aMY_invoiced)
>
>
> If I turn off the EOS attribute things run just fine. When I turn it back
> on I get the error.
> If I run the method as EOS with no params it loads on the server just
> fine.
>
> I've checked and re-checked the var typing on the parameters. In fact I
> put the declarations immediately before the method call just to be sure.
> And the params are correctly declared in EOS_method.
>
> I'm at a loss and have been looking at it for too long now. Does anyone
> else have some ideas?
>
> Thanks
>
> --
> Kirk Brooks
> San Francisco, CA
> =======================
>
> *We go vote - they go home*
>
> *​​*
>
>


-- 
Kirk Brooks
San Francisco, CA
=======================

*We go vote - they go home*
**********************************************************************
4D Internet Users Group (4D iNUG)
FAQ:  http://lists.4d.com/faqnug.html
Archive:  http://lists.4d.com/archives.html
Options: https://lists.4d.com/mailman/options/4d_tech
Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com
**********************************************************************

Reply via email to