Miyako,

I can confirm that there is a difference between V16.3 and V17.0 Beta, in how 
time is stored in an object property. In V16 it is stored in milliseconds, but 
in V17.0 it is stored in seconds.

This code returns different values between versions:

C_TIME($hh)
C_OBJECT($o)
$hh:=Current time
OB SET($o;"time";$hh)
ALERT("$hh:"+String($hh;HH MM AM PM)+",  $o:"+String(Time(OB Get($o;"time"));HH 
MM AM PM)+", object:"+JSON Stringify($o))

In V16 it shows John’s reported behaviour, while in V17 it outputs correct 
values.

Is that intentional. I mean, is that something that will change in V17?


> On Apr 16, 2018, at 11:06 PM, Julio Carneiro <jjfo...@gmail.com> wrote:
> 
> is that different in V16 and V17?
> 
> because in the code I posted I get the same result, but I am not dividing the 
> time value by 1000!!
> 
>> On Apr 16, 2018, at 10:59 PM, Keisuke Miyako via 4D_Tech 
>> <4d_tech@lists.4d.com> wrote:
>> 
>> time is stored in milliseconds, not seconds.
>> 
>> you have to
>> 
>> $oMyObject:=New object("reporttime";?14:43:01?)
>> 
>> $t:=String(Time($oMyObject.reporttime/1000);HH MM AM PM)
>> 
>> ...or
>> 
>> $t:=String(OB Get($oMyObject;"reporttime";Is time);HH MM AM PM)
>> 
>>> 2018/04/17 10:02、John Baughman via 4D_Tech <4d_tech@lists.4d.com> のメール:
>>> I thought this worked but It does not return the correct time...
>> 
> 
> --
> Julio Carneiro
> jjfo...@gmail.com
> 
> 
> 

--
Julio Carneiro
jjfo...@gmail.com



**********************************************************************
4D Internet Users Group (4D iNUG)
FAQ:  http://lists.4d.com/faqnug.html
Archive:  http://lists.4d.com/archives.html
Options: https://lists.4d.com/mailman/options/4d_tech
Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com
**********************************************************************

Reply via email to