Is the system running as a service and you don't know it?


-----Original Message-----
From: 4D_Tech <4d_tech-boun...@lists.4d.com> On Behalf Of David Rose via 4D_Tech
Sent: Thursday, February 7, 2019 1:06 PM
To: 4d_tech@lists.4d.com
Cc: David Rose <drose...@gmail.com>
Subject: Urgent! Port conflict - 4D Server

On a Windows 7 box running 4D Server v15, I rebooted the computer today and 
found, when I restarted 4D Server and tried to open the database (or a brand 
new database), I get this error:
"Failed to launch DB4D Server. Please make sure that the port assigned to the 
DB4D Server is not used by another application." When I click Continue I get 
"Failed to create a listening socket."

I tried opening the database in 4D, but got a message asking if I wanted to 
open it in read only mode. If I say yes, I am not able to get into the design 
environment in order to get into Database Settings in order to try changing the 
port numbers for the application server, web server, SQL server.

I tried repairing both the structure and data files, trashing the 4D  and 4D 
Server Preferences files, and reinstalling 4D Server. No luck. I also user the 
Unlocker utility to check to see if the data files are falsely locked. They're 

If you know of a solution to this problem, please email me directly:


4D Internet Users Group (4D iNUG)
Archive:  http://lists.4d.com/archives.html
Options: https://lists.4d.com/mailman/options/4d_tech
Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com

Reply via email to