Recently, I tried fossil on 9front (libventi library) and came across
2 issues.

1. flfmt -v fails with "no qidSpace"
2. fossil hangs while snap -a is working in the background. This
happens during the initial load as there is more data to work
through. A few GB of unventi'd data can cause this.

These are probably issues that do not happen during routine usage.

Details of the issues:
1. flfmt -v
    snap -a in the console: http://okturing.com/src/4288/body
        main: archive vac:5c1bb334c0e40b080c245409d0a9ea8b73e9d074
    no qidSpace with the same vac (fossil/last has the same vac): 
    dumpvacroots and vacchain.rc: http://okturing.com/src/4287/body
    I should have tried this without the 'vac:' prefix:
      fossil/flfmt -v vac:da39a3ee5e6b4b0d3255bfef95601890afd80709 
      this is the 'short' vac reported by vacchain.rc
    I do not have the fossil install to try it now. But, hopefully
      this information might prove useful to the next guy coming along.

2.fossil hang
    stack trace when the hang happens:
    fossil setup: http://okturing.com/src/4268/body

>From fossil to venti, it took almost a day or more to push through
30GB uncompressed data. Whereas, vac did it within an
hour'ish. Though, one does not get the snapshot and active partitions,
it appears that vac is much more attuned to venti than fossil.

Again, I am a newbie and might be missing something
fundamental. Hopefully, this documents some hurdles for the next guy
coming along.


Adriano Verardo wrote:
> six, since 2007 at home and on several industrial plants
> adriano
> > Five. I just haven't had the heart to decommission it yet.
> >
> > On Mon, Apr 16, 2018 at 4:22 AM, Lucio De Re <lucio.d...@gmail.com> wrote:
> >> Four. Long-standing nobody, too.
> >>
> >> Lucio.
> >>
> >

Reply via email to