I have an Intel device that provides a sample rate only of 44100, but I want
to record a stream at 8000. The hardware device is: hw:0,0,0.

As far as I can tell, this is "easily" doable with a plugin, but I haven't
been able to make it work (this is the first time I've tried to use a plugin).

After a lot of messing around, my .asoundrc file currently looks like this:


pcm.!default {
        type hw
        card 0
        device 0
        subdevice 0

ctl.!default {
        type hw
        card 0
        device 0
        subdevice 0

pcm_slave.rate_converter {
        pcm default

pcm.rate8000 {
    type plug
    slave {
        pcm rate_converter
        rate 8000


and when I try to use this, I get:
n7dr@shack20:~$ arecord -c 2 -d 10 -vvv -D rate8000 -f S16_LE q8000.wav
                                        │ALSA lib
pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM rate_converter
                                   │arecord: main:828: audio open error: No
such file or directory

I suspect a simple error in the .asoundrc. I hope.

I've tried a lot of variations, attempting to follow examples of plugin use on
various web pages [at least some of which I suspect are out of date], but they
all give errors, so I decided that the best way to get this working is to ask
for help somewhere where people who really understand this stuff hang out :-)


Web:  http://enginehousebooks.com/drevans

Attachment: signature.asc
Description: OpenPGP digital signature

Alsa-user mailing list

Reply via email to