Good morning, my illustrious List Members and Administrators, at
alsa-user at

I have been at this problem for nearly a year without any solution.

I want to have duplex operation for my sound card by Realtek, as
mentioned by Lenovo portal, here:,
... summary: Realtek Audio_6.0.1.8652.A

The issue is dealt with in details here:

    lspci -k generates the following data:

    ... ... [snipped] ... ...
    00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    Subsystem: Lenovo Sunrise Point-LP HD Audio
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl
    ... ... [snipped] ... ...

I have tried the debian-user and debian-laptop mailing list here:, but
solution evades me. I am compelled to go around in circles. Tried
latest buster but met with failure, here:
Earlier we used to invoke alsaconf for setting up our sound cards
which is no longer available.

So could you please advise on how to have this duplex operation
enabled, without pulseaudio, which makes the matter cakewalk. But in
my system pulseaudio doesn't work. Whereas, in my other laptop from
HP, it works very smoothly

I was advised to find "debian non-free drivers "Realtek
Audio_6.0.1.8652.A"" but didn't find any.

Have installed most of the alsa binaries [like: alsabat       alsactl
     alsaloop      alsatplg
alsabat-test  alsa-info     alsamixer     alsaucm] and packages
[alsa-utils (ver:1.1.8-2 knoppix and  1.1.3-1 debian stretch 9.11.0),
alsa-firmware-loaders  (ver:1.1.7-1 knoppix only), alsa-tools
(ver:1.1.7-1 knoppix only), gnome-alsamixer
(ver:0.9.7~cvs.20060916.ds.1-5+b1 knoppix and
0.9.7~cvs.20060916.ds.1-5+b1 debian stretch 9.11.0)], volumeicon-alsa
[ver:0.4.6-2.2+b1  debian stretch 9.11.0 only] in my system but don't
know how to enable Full Duplex operations.

I have found your website and subscribed to your Emailing List.

I request you to please allow me a meaningful stay here.

Rajib Bandopadhyay
A dedicated Debian and Knoppix user

Alsa-user mailing list

Reply via email to