Hi all,

I have a FiiO K5 Pro connected one of the USB3 ports on my primary system,
running Ubuntu Jammy. I have so far been unable to isolate a persistent
problem with audio playback, and I am writing to you all in the hope that
maybe someone on this mailing list might have experienced (and solved!) the
same problem.

I work in IT and have thirty years of using Linux as my primary OS. I'm
confident that I can solve any audio-related configuration issues on my
own, but what I have been unable to do so far is definitively correlate
what I hear with a kernel module or software package. I am pretty certain
that if someone has had the same issue as I have, they will know what I am
talking about simply by a description of what I hear.

When I have audio playing (normally music) there are irregular noises that
sound at times exactly like a turntable stylus hitting a scratch or two
(but not repeating), and at other times almost exactly as if someone has
bumped a turntable - a slightly longer sound with a stuttery aspect to it.
If you've ever been to a nightclub where they are playing vinyl you will
know the sounds I am talking about. The music is not interrupted or
distorted as far as I can tell - though I wouldn't be surprised if there
were timing deviations that I can't pick up from just listening.

I hear these sounds irrespective of whether I'm using mplayer, vlc, or
playing video, etc. The noises are irregular as I said, happening one or
two times a minute. They are not tied to the sound being played, which is
to say I can play the same music file and the noises will not occur at the
same timestamps. Nothing is reported by the applications (incl. with debug
settings), in the dmesg output, or anywhere else.

I am fairly sure that the problem has something to do with
the snd_usb_audio kernel module, but I have tried both standard and
non-standard module options (quirk flags) to see if I could influence what
is happening. Whatever is causing it, the problem has persisted through OS
upgrades and the switch from Pulseaudio to Pipewire.

What I really hope for is for someone who recognises the specific problem I
describe and knows precisely where I should be looking for a solution. I
haven't found any similar reports though, so I concede that the chances of
someone actually having come across this before are probably pretty slim,
but no harm in asking, right?

The FiiO K5 Pro has a XMOS XUF208 for USB decoding, and a AK4493 DAC. I
haven't entirely ruled out a hardware problem, but I can tell you that I
hear the same disturbances when the K5 is used with other Linux systems as
well. I have yet to test it with Windows, partly because I'm terrified that
it will just work flawlessly!

If you think you know what might be going on, please let me know. If you
haven't come across this problem before yourself, but have some tips on how
I might better articulate the problem, or if you could suggest strategies
for how I might make some headway in diagnosing the problem, I would love
to hear from you.

Many thanks,
Paul Dorman
Alsa-user mailing list

Reply via email to