This series adds a "name" member to the radeon_ring structure and uses it instead of ring indexes in logs and std outputs. This change is proposed for better logs readability and ring identification as much for the average user as for debugging purposes.
It uses the same naming convention as the one used under amdgpu for coherence between the two drivers. Alexandre Demers (4): drm/radeon: add name member to radeon_ring structure drm/radeon: rename ring to ring_idx in radeon_fence_driver_start_ring() drm/radeon: name rings drm/radeon: switch from ring->idx to ring->name for printouts drivers/gpu/drm/radeon/cik.c | 33 +++++++++++++++------ drivers/gpu/drm/radeon/cik_sdma.c | 6 ++-- drivers/gpu/drm/radeon/ni.c | 10 +++++-- drivers/gpu/drm/radeon/r600.c | 8 ++--- drivers/gpu/drm/radeon/r600_dma.c | 8 ++--- drivers/gpu/drm/radeon/radeon.h | 1 + drivers/gpu/drm/radeon/radeon_fence.c | 42 ++++++++++++++------------- drivers/gpu/drm/radeon/radeon_ring.c | 4 +-- drivers/gpu/drm/radeon/radeon_vce.c | 13 +++++---- drivers/gpu/drm/radeon/si.c | 36 +++++++++++++++++------ drivers/gpu/drm/radeon/uvd_v1_0.c | 14 ++++----- 11 files changed, 109 insertions(+), 66 deletions(-) -- 2.50.1