I finally solved my problem. Here is how I did it for the record :

First, I used the Angstrom distribution 2015.06 (Yocto 1.8). I had no more
issues with the raspberry pi firmwares not compatible with my model of
Raspberry Pi.
For the login issue, I had to mount the root partition of the target on the
build machine, and I patched the etc/shadow file with the following patch.
It adds a password to the root account (pw: root). And it finally let me
I am now writing a recipe to apply the patch automaticaly.
But I still do not understand why it would not work before. A blank
password is supposed to be legit, isn't it?

--- shadow_original 2015-04-27 15:45:09.055446002 +0200
+++ shadow_new 2015-04-27 15:44:56.467446069 +0200
@@ -1,4 +1,4 @@

On Mon, Apr 27, 2015 at 10:31 AM, qrthur sfz <arthur.s...@gmail.com> wrote:

> Hello,
> I am trying to run Angstrom on a Raspberry Pi B+. I am running into
> several issues.
> At first, the board would not boot. I changed the firmware boot files with
> newer ones, because apparently it can't work on a Raspberry Pi B+. Then I
> finally got the login prompt, but I can not login. It says "Login
> incorrect".
> I tried to remove /etc/securetty, to update /etc/login.defs. But I had no
> success with these tweaks.
> I am using Angstrom v2014.06, kernel 3.12.21 (default)
> Any help would be much appreciated.
> Thanks,
> --
> Arthur SFEZ

Arthur SFEZ
Angstrom-distro-devel mailing list

Reply via email to