I have checked out the Yocto version of Angstrom, and i'm trying to get
started with it.
My goal is to update a device which is running an ancient version of
angstrom, and on which i have outdated programs running.

i executed a bitbake of dropbear (which is one of the programs to be
updated) for my at91sam9x5ek machine, but when i tried to install the ipkg
on my machine, it was complaining about some missing dependencies.
I found almost all of the dependencies back  in the build/tmp/work tree of
except for libc6.
At first i copied the wrong libc6 ( i searched for the dependencies with
"find . -name DepName", and ended up in the directory for armv5e, which is
not my architecture(should be armv5te). When i tried to install that ipk of
libc6, the package manager refused to install it. It took me a while before
i realised that it was due to the priority of the architecture (the
currently installed version of libc6 is coming from the angstrom feeds, and
is compiled for armv5te, so the priority of the installed libc6 package was
higher then the one i tried to install (the one compiled for armv5e).
So it seems that, even if the version is newer, the package manager gives
prio to the correct architecture.

I searched for libc6, but could not find it in the armv5te version.

So now my (newbie) question: how do i adapt the yocto/bitbake scripts so
that i get a libc6 compiled for armv5te?
Angstrom-distro-devel mailing list

Reply via email to