Severity: important 

Affected versions:

- Apache ActiveMQ 6.0.0 before 6.3.3
- Apache ActiveMQ before 5.19.12
- Apache ActiveMQ Runtime Config 6.0.0 before 6.3.3
- Apache ActiveMQ Runtime Config before 5.19.12

Description:

Improper invalidation of cached authorizations vulnerability in Apache 
ActiveMQ, Apache ActiveMQ Runtime Config.



After the runtime configuration plugin removes a principal's write grant on a 
destination, an authenticated connection opened before the change can keep 
sending to that destination, including through a new anonymous producer, while 
fresh connections and new explicit producers are denied.



This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; 
Apache ActiveMQ Runtime Config: from 6.0.0 before 6.3.3, before 5.19.12.



Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which 
fixes the issue.

Credit:

hataehoon (finder)

References:

https://activemq.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-111822

Reply via email to