I'm attempting to automate the creation of elasticsearch nodes via ansible, 
using the appropriate module.

in the yml I have:
      - name: add elasticsearch plugins
        elasticsearch_plugin: state=present name="license" 
also tried:
        elasticsearch_plugin: state=present name="elasticsearch/license" 
(as those worked manually)

What I get with debug output is this:

failed: [elasticsearch05] => {"failed": true}
msg: implementation error: unknown type path requested for plugin_bin

What I've found in the plugin source file (checked out from github)

is this:
            - Location of the plugin binary
        required: False
        default: /usr/share/elasticsearch/bin/plugin

which looks ok...

Is there something obvious I'm missing?..
This is all on ubuntu 14.04


You received this message because you are subscribed to the Google Groups 
"Ansible Project" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to ansible-project+unsubscr...@googlegroups.com.
To post to this group, send email to ansible-project@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to