I am new to Ansible and I'm trying to configure windows 2012 R2 from RHEL 7 
Ansible Node. I'm able to establish connection between them using Winrm 
Credssp. Below is /etc/ansible/group_vars/windows.yml file


COMPONENT NAME
urllib3.connectionpool https://192.168.2.211:5986 "POST /wsman HTTP/1.1" 
500 1320


ANSIBLE VERSION
ansible 2.3.1.0

python version = 2.7.5


ansible_user: admin
ansible_password: XXXXXXX
ansible_winrm_scheme: https
ansible_winrm_transport: credssp
ansible_port: 5986
ansible_connection: winrm
ansible_winrm_server_cert_validation: ignore
validate_certs: false

When I execute win_ping module for testing connection from Ansible node to 
Windows 2012 R2 server it was successful.

[root@Ansible-Server playbooks]# ansible windows -m win_ping
XX.XX.XX.XX | SUCCESS => {
"changed": false,
"ping": "pong"
}

But When I have tried executing Windows 2012 R2 playbook file, after 
submitting ansible-playbook playbook.yml command, it is continuously 
waiting for indefinite time, as It is not completing.

Below is the log that is constantly displaying same. Waiting continuously. 
/var/log/ansible/log

2018-03-07 19:34:14,255 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:34:34,256 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:34:54,256 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:35:14,258 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:35:34,257 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:35:54,272 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:36:14,272 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:36:34,273 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:36:54,273 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:37:14,273 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:37:34,273 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:37:54,274 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:38:14,274 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:38:34,274 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320
2018-03-07 19:38:54,274 urllib3.connectionpool https://192.168.2.211:5986 "POST 
/wsman HTTP/1.1" 500 1320

above log continues/updates same for every 20 sec.

Could you please any one suggest where it' got stuck and how i can identify 
and troubleshoot .



-- 
You received this message because you are subscribed to the Google Groups 
"Ansible Project" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to ansible-project+unsubscr...@googlegroups.com.
To post to this group, send email to ansible-project@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/ansible-project/2259051b-823c-4dfc-9080-ff8b863f54e1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to