Hi Amadin,

Follow below steps to to ping hosts:
Create ssh connection with host 
And ping to the host using below command:
#ansible <host> -i <inventory-file> -m ping
and then run playbook on that host.
Or
You can avoid this by providing ansible_password (The password to use to 
authenticate to the host) in inventory

Hope this will work.

Regards,
Nivedita

On Tuesday, January 7, 2020 at 8:46:50 AM UTC+5:30, Amadin Jones wrote:
>
> Dear Colleagues,
>
> I have been working of ansible with my ping command working well with pong 
> response but whenever i want to deploy playbooks it will fail with this 
> command atal: [172.31.85.22]: UNREACHABLE! => {"changed": false, "msg": 
> "Failed to connect to the host via ssh: Permission denied 
> (publickey,gssapi-keyex,gssapi-with-mic,password).", "unreachable": true} 
> even when i do password authentication to yes and host check to false it 
> will still not connect . please colleagues help me
>
>
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"Ansible Project" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/ansible-project/c8c24a43-3309-46a2-8cb4-8651a5bde00e%40googlegroups.com.

Reply via email to