----- Original Message ----- From: "Erik Hatcher" <[EMAIL PROTECTED]>
> I've considered writing an EclipsePath (or perhaps more generic name) Path > extension that would parse that file and create the appropriate path for it. > I'm using WSAD and there are variables in there that need to be expanded > like WAS_PLUGINDIR. I'll have to do more homework on the <classpathentry> > elements in there to know which ones to pick up and which ones (if any) to > ignore (or to have a switch controlling the choices). Perhaps something > like this: [...] It is crystal clear that we lack of pluggability being in task or anywhere else. > Stephane - do you have any pointers to more info on the .classpath file? Hard to figure out. For eclipse I think you have to look into org.eclipse.jdt.core.IClasspathEntry and try to find the way down from here, like the org.eclipse.jdt.internal.core.ClasspathEntry and org.eclipse.jdt.core.JavaCore Stephane -- To unsubscribe, e-mail: <mailto:[EMAIL PROTECTED]> For additional commands, e-mail: <mailto:[EMAIL PROTECTED]>
