On Wednesday 09 June 2004 00:51, you wrote:
> Zoran,
>
> Ok I tried
>
> [exec /bin/csh -c "/opt/myscript"]
>
> and I get the same error.
>
> I also tried launching aolserver from /bin/csh instead of bash and I still
> had the same problem.

Oh... I must say that I had the same problem with one of the
older SuSE (7.3) releases. It apparently has nothing to do
with the trapping of the SIGCHLD signal. What I did is to
set breakpoints on all signal-related calls and then launch
the nsd executable under debugger. Now, there are no places
in the code which mingle with SIGCHLD signal whatsoever.
I ran the vanilla AS distro, which means no extra modules
apart from AS standard ones (nssock, nsperm, nslog).
By running the server from /bin/csh the signal problem went
away. It does not happen in your setup. Hm... So, there is
something else wrong there... I will have to see wether I
can find something. It has definitely something to do
with the Linux OS.
To make it even more interesting, even the plain tclsh
executable on that system seems to have the same problem:

  mickey:/tmp # tclsh
  % exec ls
  kde-root
  ksocket-root
  lexxsrv.adr
  mcop-root
  run-crons.EDjFSK
  run-crons.o9xwkI
  run-crons.rIVDf9
  error waiting for process to exit: child process lost (is SIGCHLD ignored or 
trapped?)

Strange...
Zoran


--
AOLserver - http://www.aolserver.com/

To Remove yourself from this list, simply send an email to <[EMAIL PROTECTED]> with the
body of "SIGNOFF AOLSERVER" in the email message. You can leave the Subject: field of 
your email blank.

Reply via email to