Hi ,

As mentioned on the lists that 64 bit code of aolserver is not thoroughly tested , I decided to compile a 32 bit aolserver .

What flags do i need to use to compile aolserver on an AMD opteron which is x86_64 bit processor . i tried --disable-64bit but i can still see it links against 64 bit libraries .

I thought if i compile aolserver on x86 and use it on amd machine it should be fine , but that was not easy either :) . I have a x86 Fedora core 4 machine , downloaded cvs version of aolserver 4.0.10 . and tried tcl 8.4.12 - 13 -14 -15 but i got this error on aolserver compilation .

gcc -shared -O2 -Wall -Wno-implicit-int -fno-strict-aliasing -fPIC -pipe -I../include -I/bayt/software/tclg/include -DNO_CONST -DHAVE_LIMITS_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -D_REENTRANT=1 -D_THREAD_SAFE=1 -DHAVE_PTHREAD_ATTR_SETSTACKSIZE=1 -DHAVE_PTHREAD_ATFORK=1 -DTCL_THREADS=1 -DPEEK_XCLOSEIM=1 -D_LARGEFILE64_SOURCE=1 -DTCL_WIDE_INT_TYPE=long\ long -DHAVE_STRUCT_STAT64=1 -DHAVE_OPEN64=1 -DHAVE_LSEEK64=1 -DHAVE_TYPE_OFF64_T=1 -DHAVE_GETCWD=1 -DHAVE_OPENDIR=1 -DHAVE_STRSTR=1 -DHAVE_STRTOL=1 -DHAVE_STRTOLL=1 -DHAVE_STRTOULL=1 -DHAVE_TMPNAM=1 -DHAVE_WAITPID=1 -DHAVE_GETPWUID_R_5=1 -DHAVE_GETPWUID_R=1 -DHAVE_GETPWNAM_R_5=1 -DHAVE_GETPWNAM_R=1 -DHAVE_GETGRGID_R_5=1 -DHAVE_GETGRGID_R=1 -DHAVE_GETGRNAM_R_5=1 -DHAVE_GETGRNAM_R=1 -DHAVE_GETHOSTBYNAME_R_6=1 -DHAVE_GETHOSTBYNAME_R=1 -DHAVE_GETHOSTBYADDR_R_8=1 -DHAVE_GETHOSTBYADDR_R=1 -DUSE_TERMIOS=1 -DHAVE_SYS_TIME_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_TM_ZONE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_TM_GMTOFF=1 -DHAVE_TIMEZONE_VAR=1 -DHAVE_ST_BLKSIZE=1 -DSTDC_HEADERS=1 -DHAVE_SIGNED_CHAR=1 -DHAVE_LANGINFO=1 -DHAVE_FTS=1 -DHAVE_SYS_IOCTL_H=1 -DTCL_CFG_OPTIMIZED=1 -DTCL_CFG_DEBUG=1 -DHAVE_INTTYPES_H=1 -DHAVE_TIMEGM=1 -DHAVE_POLL=1 -DHAVE_DRAND48=1 -DHAVE_RANDOM=1 -DHAVE_CMMSG=1 -DHAVE_GETADDRINFO=1 -DHAVE_GETNAMEINFO=1 -DHAVE_ZLIB_H=1 -DHAVE_LIBZ=1 -DNsthreadsInit=_init -L../nsthread -L../nsd -L../nsthread -L../nsd -o libnsthread.so error.o master.o memory.o mutex.o cslock.o rwlock.o reentrant.o sema.o thread.o tls.o signal.o compat.o time.o fork.o pthread.o -L/bayt/software/tclg/lib -ltcl8.4 -ldl -lpthread -lieee -lm -lz -lgcc_s -Wl,-rpath,/bayt/software/aol/aol411/lib -Wl,-rpath,/bayt/software/tclg/lib
pthread.o(.text+0x0): In function `_init':
pthread.c: multiple definition of `_init'
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../crti.o(.init+0x0): first defined here
collect2: ld returned 1 exit status
make[1]: *** [libnsthread.so] Error 1
make[1]: Leaving directory `/opt/tmp/aol411/aolserver/nsthread'

On googling i got Dossy's comments about adding -nostartfiles , modified ./include/Makefile.global added -nostartfiles in front of gcc . than i started receiving this error .

make[1]: *** [unix.o] Error 1
make[1]: Leaving directory `/opt/tmp/aol411/aolserver/nsd'
make: *** [all] Error 1

Can any one help me resolve this , my goal is to have aolserver compiled as 32 bit on amd opteron server ,

This is gcc -v output on Fedora core 4 x86 machine

[EMAIL PROTECTED] /opt/tmp/aol411/aolserver]$ gcc -v
Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile --enable-languages=c,c++,objc,java,f95,ada --enable-java-awt=gtk --with-java-home=/usr/lib/jvm/java-1.4.2-gcj- --host=i386-redhat-linux
Thread model: posix
gcc version 4.0.0 20050519 (Red Hat 4.0.0-8)

Syed Atif Ali
D. +971 4 3911914
F. +971 4 3911915
___________________________________________ "I never let my schooling get in the way of my education." -- Mark Twain

AOLserver - http://www.aolserver.com/

To Remove yourself from this list, simply send an email to <[EMAIL PROTECTED]> 
with the
body of "SIGNOFF AOLSERVER" in the email message. You can leave the Subject: 
field of your email blank.

Reply via email to