On Sun, May 24, 2015 at 02:14:05PM +0200, Christian Boltz wrote: > Hello, > > this patch replaces rule-specific names with generic names: > - s/'capability'/ruletype/ > - s/cap_obj/rule_obj/ > - s/'network'/ruletype/ > - s/net_obj/rule_obj/
I would probably just do s/rule_obj/rule/ but maybe that's just me. > It also sets ruletype at the beginning of each block. > > The long-term goal is to have > for ruletype in ['capability', 'network', ...]: > with common code to handle all rule types, and having common names makes > it easier to compare the blocks. > > [ 13-mergeprof-use-generic-names.diff ] Acked-by: Steve Beattie <[email protected]> either with or without my suggested change. -- Steve Beattie <[email protected]> http://NxNW.org/~steve/
signature.asc
Description: Digital signature
-- AppArmor mailing list [email protected] Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/apparmor
