Date: Friday, February 27, 2015 @ 05:56:03
  Author: fyan
Revision: 232039

upgpkg: pyqt4 4.11.3-3

move sip files into -common (FS#43821)

Modified:
  pyqt4/trunk/PKGBUILD

----------+
 PKGBUILD |   11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2015-02-27 04:53:13 UTC (rev 232038)
+++ PKGBUILD    2015-02-27 04:56:03 UTC (rev 232039)
@@ -1,5 +1,6 @@
 # $Id$
-# Maintainer: Andrea Scarpino <and...@archlinux.org>
+# Maintainer: Felix Yan <felixonm...@archlinux.org>
+# Contributor: Andrea Scarpino <and...@archlinux.org>
 # Contributor: Douglas Soares de Andrade <doug...@archlinux.org>
 # Contributor: riai <r...@bigfoot.com> Ben <b...@benmazer.net>
 
@@ -6,7 +7,7 @@
 pkgbase=pyqt4
 pkgname=('pyqt4-common' 'python-pyqt4' 'python2-pyqt4')
 pkgver=4.11.3
-pkgrel=2
+pkgrel=3
 arch=('i686' 'x86_64')
 url='http://www.riverbankcomputing.com/software/pyqt/intro'
 license=('GPL')
@@ -21,6 +22,7 @@
   cd PyQt-x11-gpl-${pkgver}
   python configure-ng.py \
     --confirm-license \
+    --no-sip-files \
     --qsci-api \
     -q /usr/bin/qmake-qt4
 
@@ -33,7 +35,7 @@
   cd ../Py2Qt-x11-gpl-${pkgver}
   python2 configure-ng.py \
     --confirm-license \
-    -v /usr/share/sip/Py2-PyQt4 \
+    --no-sip-files \
     --qsci-api \
     -q /usr/bin/qmake-qt4
 
@@ -55,6 +57,9 @@
   make -C pylupdate INSTALL_ROOT="${pkgdir}" install
 
   install -Dm644 PyQt4.api "${pkgdir}"/usr/share/qt4/qsci/api/python/PyQt4.api
+
+  install -d "${pkgdir}"/usr/share/sip/PyQt4
+  cp -r sip/* "${pkgdir}"/usr/share/sip/PyQt4
 }
 
 package_python-pyqt4(){

Reply via email to