Date: Thursday, August 6, 2015 @ 06:46:55
  Author: allan
Revision: 243065

upgpkg: glibc 2.22-1

upstream update

Modified:
  glibc/trunk/PKGBUILD
  glibc/trunk/glibc.install

---------------+
 PKGBUILD      |   37 ++++++++++++++++++++-----------------
 glibc.install |    2 +-
 2 files changed, 21 insertions(+), 18 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2015-08-06 04:29:58 UTC (rev 243064)
+++ PKGBUILD    2015-08-06 04:46:55 UTC (rev 243065)
@@ -7,15 +7,15 @@
 # NOTE: adjust version in install script when locale files are updated
 
 pkgname=glibc
-pkgver=2.21
-pkgrel=4
+pkgver=2.22
+pkgrel=1
 pkgdesc="GNU C Library"
 arch=('i686' 'x86_64')
 url="http://www.gnu.org/software/libc";
 license=('GPL' 'LGPL')
 groups=('base')
-depends=('linux-api-headers>=4.0' 'tzdata' 'filesystem')
-makedepends=('gcc>=4.9')
+depends=('linux-api-headers>=4.1' 'tzdata' 'filesystem')
+makedepends=('gcc>=5.2')
 backup=(etc/gai.conf
         etc/locale.gen
         etc/nscd.conf)
@@ -22,12 +22,10 @@
 options=('!strip' 'staticlibs')
 install=glibc.install
 source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
-        glibc-2.21-roundup.patch
         locale.gen.txt
         locale-gen)
-md5sums=('9cb398828e8f84f57d1f7d5588cf40cd'
+md5sums=('e51e02bf552a0a1fbbdc948fb2f5e83c'
          'SKIP'
-         'feb826d5f4965e9892ee6e851fec43a9'
          '07ac979b6ab5eeb778d55f041529d623'
          '476e9113489f93b348b21e144b6a8fcf')
 validpgpkeys=('F37CDAB708E65EA183FD1AF625EF0A436C2A4AFF')  # Carlos O'Donell
@@ -36,7 +34,7 @@
   cd ${srcdir}/glibc-${pkgver}
 
   # glibc-2.21..01b07c70
-  patch -p1 -i $srcdir/glibc-2.21-roundup.patch
+  #patch -p1 -i $srcdir/glibc-2.21-roundup.patch
 
   mkdir ${srcdir}/glibc-build
 }
@@ -87,12 +85,9 @@
 }
 
 check() {
-  # the linker commands need to be reordered - fixed in 2.19
-  LDFLAGS=${LDFLAGS/--as-needed,/}
-
   cd ${srcdir}/glibc-build
 
-  # tst-cleanupx4 failure on i686 is "expected"
+  # some failures are "expected"
   make check || true
 }
 
@@ -125,6 +120,9 @@
   # libc, libdl, libm and libpthread are required for toolchain testsuites
   # in addition libcrypt appears widely required
   rm $pkgdir/usr/lib/lib{anl,BrokenLocale,nsl,resolv,rt,util}.a
+  if [[ $CARCH = "x86_64" ]]; then
+    rm $pkgdir/usr/lib/libmvec.a
+  fi
 
   # Do not strip the following files for improved debugging support
   # ("improved" as in not breaking gdb and valgrind...):
@@ -138,13 +136,18 @@
                         usr/bin/{ldconfig,locale,localedef,nscd,makedb} \
                         usr/bin/{pcprofiledump,pldd,rpcgen,sln,sprof} \
                         usr/lib/getconf/*
-  [[ $CARCH = "i686" ]] && strip $STRIP_BINARIES usr/bin/lddlibc4
+  if [[ $CARCH = "i686" ]]; then
+    strip $STRIP_BINARIES usr/bin/lddlibc4
+  fi
 
   strip $STRIP_STATIC usr/lib/*.a
 
-  strip $STRIP_SHARED usr/lib/{libanl,libBrokenLocale,libcidn,libcrypt}-*.so \
+  strip $STRIP_SHARED usr/lib/lib{anl,BrokenLocale,cidn,crypt}-*.so \
                       
usr/lib/libnss_{compat,db,dns,files,hesiod,nis,nisplus}-*.so \
-                      usr/lib/{libdl,libm,libnsl,libresolv,librt,libutil}-*.so 
\
-                      usr/lib/{libmemusage,libpcprofile,libSegFault}.so \
-                      usr/lib/{audit,gconv}/*.so
+                      usr/lib/lib{dl,m,nsl,resolv,rt,util}-*.so \
+                      usr/lib/lib{memusage,pcprofile,SegFault}.so \
+                      usr/lib/{audit,gconv}/*.so || true
+  if [[ $CARCH = "x86_64" ]]; then
+    strip STRIP_SHARED usr/lib/libmvec-*.so
+  fi
 }

Modified: glibc.install
===================================================================
--- glibc.install       2015-08-06 04:29:58 UTC (rev 243064)
+++ glibc.install       2015-08-06 04:46:55 UTC (rev 243065)
@@ -4,7 +4,7 @@
 post_upgrade() {
   ldconfig -r .
   
-  if [[ $(vercmp 2.21-2 $2) = 1 ]]; then
+  if [[ $(vercmp 2.22-1 $2) = 1 ]]; then
     locale-gen
   fi
   

Reply via email to