Date: Monday, September 19, 2016 @ 13:23:48
  Author: jgc
Revision: 276707

archrelease: copy trunk to gnome-unstable-i686, gnome-unstable-x86_64

Added:
  at-spi2-atk/repos/gnome-unstable-i686/
  at-spi2-atk/repos/gnome-unstable-i686/PKGBUILD
    (from rev 276706, at-spi2-atk/trunk/PKGBUILD)
  at-spi2-atk/repos/gnome-unstable-x86_64/
  at-spi2-atk/repos/gnome-unstable-x86_64/PKGBUILD
    (from rev 276706, at-spi2-atk/trunk/PKGBUILD)

--------------------------------+
 gnome-unstable-i686/PKGBUILD   |   44 +++++++++++++++++++++++++++++++++++++++
 gnome-unstable-x86_64/PKGBUILD |   44 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 88 insertions(+)

Copied: at-spi2-atk/repos/gnome-unstable-i686/PKGBUILD (from rev 276706, 
at-spi2-atk/trunk/PKGBUILD)
===================================================================
--- gnome-unstable-i686/PKGBUILD                                (rev 0)
+++ gnome-unstable-i686/PKGBUILD        2016-09-19 13:23:48 UTC (rev 276707)
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Ionut Biru <ib...@archlinux.org>
+
+pkgname=at-spi2-atk
+pkgver=2.21.91+1+gd559d68
+pkgrel=1
+pkgdesc="A GTK+ module that bridges ATK to D-Bus at-spi"
+arch=('i686' 'x86_64')
+url="https://wiki.gnome.org/Accessibility";
+license=('GPL2')
+depends=('at-spi2-core' 'libx11' 'atk')
+makedepends=('git')
+provides=('at-spi')
+replaces=('at-spi')
+conflicts=('at-spi')
+_commit=d559d6882dc172628c16d5fd21f457a1695ac490
+source=("git://git.gnome.org/at-spi2-atk#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+  cd $pkgname
+  git describe --tags | sed -e 's/AT_SPI2_ATK_//' -e 's/_/\./g' -e 's/-/+/g'
+}
+
+prepare() {
+  cd $pkgname
+  sed -i -e '/AC_PATH_XTRA/d' configure.ac
+  NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+  cd $pkgname
+  ./configure --prefix=/usr --sysconfdir=/etc \
+    --disable-schemas-compile
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+  make
+}
+
+package() {
+  cd $pkgname
+  make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:

Copied: at-spi2-atk/repos/gnome-unstable-x86_64/PKGBUILD (from rev 276706, 
at-spi2-atk/trunk/PKGBUILD)
===================================================================
--- gnome-unstable-x86_64/PKGBUILD                              (rev 0)
+++ gnome-unstable-x86_64/PKGBUILD      2016-09-19 13:23:48 UTC (rev 276707)
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Ionut Biru <ib...@archlinux.org>
+
+pkgname=at-spi2-atk
+pkgver=2.21.91+1+gd559d68
+pkgrel=1
+pkgdesc="A GTK+ module that bridges ATK to D-Bus at-spi"
+arch=('i686' 'x86_64')
+url="https://wiki.gnome.org/Accessibility";
+license=('GPL2')
+depends=('at-spi2-core' 'libx11' 'atk')
+makedepends=('git')
+provides=('at-spi')
+replaces=('at-spi')
+conflicts=('at-spi')
+_commit=d559d6882dc172628c16d5fd21f457a1695ac490
+source=("git://git.gnome.org/at-spi2-atk#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+  cd $pkgname
+  git describe --tags | sed -e 's/AT_SPI2_ATK_//' -e 's/_/\./g' -e 's/-/+/g'
+}
+
+prepare() {
+  cd $pkgname
+  sed -i -e '/AC_PATH_XTRA/d' configure.ac
+  NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+  cd $pkgname
+  ./configure --prefix=/usr --sysconfdir=/etc \
+    --disable-schemas-compile
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+  make
+}
+
+package() {
+  cd $pkgname
+  make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:

Reply via email to