Date: Monday, September 19, 2016 @ 15:28:09
  Author: arojas
Revision: 189985

Use GTK2, the GTK3 version is too buggy

Modified:
  pan/trunk/PKGBUILD

----------+
 PKGBUILD |    8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2016-09-19 13:16:40 UTC (rev 189984)
+++ PKGBUILD    2016-09-19 15:28:09 UTC (rev 189985)
@@ -4,12 +4,12 @@
 
 pkgname=pan
 pkgver=0.140
-pkgrel=2
+pkgrel=3
 pkgdesc="A powerful Newsgroup Article reader"
 arch=(i686 x86_64)
 url="http://pan.rebelbase.com/";
 license=(GPL2)
-depends=(gtkspell3 webkitgtk gmime)
+depends=(gtkspell webkitgtk2 gmime)
 makedepends=(intltool)
 
source=("http://pan.rebelbase.com/download/releases/$pkgver/source/$pkgname-$pkgver.tar.bz2";)
 md5sums=('6c6a879e8ea73efbb5512ac00977fd82')
@@ -17,11 +17,13 @@
 prepare() {
   cd $pkgname-$pkgver
   sed -e 's|@WEBKITGTK_CFLAGS@-DPANLOCALEDIR|@WEBKITGTK_CFLAGS@ 
-DPANLOCALEDIR|' -i pan/gui/Makefile.am
+  sed -e 's|webkitgtk-1.0|webkit-1.0|g' -i configure.ac
+  autoreconf -vi
 }
 
 build() {
   cd $pkgname-$pkgver
-  ./configure --prefix=/usr --with-gtk3 --with-webkit --with-gnutls
+  ./configure --prefix=/usr --with-webkit --with-gnutls
   make
 }
 

Reply via email to