Date: Wednesday, September 21, 2016 @ 12:10:43
  Author: jgc
Revision: 276800

archrelease: copy trunk to gnome-unstable-i686, gnome-unstable-x86_64

Added:
  evince/repos/gnome-unstable-i686/
  evince/repos/gnome-unstable-i686/PKGBUILD
    (from rev 276799, evince/trunk/PKGBUILD)
  evince/repos/gnome-unstable-x86_64/
  evince/repos/gnome-unstable-x86_64/PKGBUILD
    (from rev 276799, evince/trunk/PKGBUILD)

--------------------------------+
 gnome-unstable-i686/PKGBUILD   |   63 +++++++++++++++++++++++++++++++++++++++
 gnome-unstable-x86_64/PKGBUILD |   63 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 126 insertions(+)

Copied: evince/repos/gnome-unstable-i686/PKGBUILD (from rev 276799, 
evince/trunk/PKGBUILD)
===================================================================
--- gnome-unstable-i686/PKGBUILD                                (rev 0)
+++ gnome-unstable-i686/PKGBUILD        2016-09-21 12:10:43 UTC (rev 276800)
@@ -0,0 +1,63 @@
+# $Id$
+# Maintainer: Jan de Groot <j...@archlinux.org>
+
+pkgname=evince
+pkgver=3.22.0+1+gc1dd9eb
+pkgrel=1
+pkgdesc="Document viewer (PDF, Postscript, djvu, tiff, dvi, XPS, SyncTex 
support with gedit, comics books (cbr,cbz,cb7 and cbt))"
+url="https://wiki.gnome.org/Apps/Evince";
+arch=(i686 x86_64)
+license=(GPL)
+depends=(gtk3 libgxps libspectre gsfonts poppler-glib djvulibre t1lib dconf
+         libsecret gsettings-desktop-schemas gnome-desktop libarchive
+         gst-plugins-base-libs)
+makedepends=(itstool libnautilus-extension texlive-bin gobject-introspection
+             intltool docbook-xsl python gtk-doc git gnome-common)
+optdepends=('texlive-bin: DVI support'
+           'gvfs: bookmark support and session saving')
+groups=(gnome)
+options=('!emptydirs')
+_commit=c1dd9eb697a58044e9d04846590fdfe1e65dda0f
+source=("git://git.gnome.org/evince#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+  cd $pkgname
+  git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+  cd $pkgname
+  NOCONFIGURE=1 ./autogen.sh
+}
+  
+
+build() {
+  cd $pkgname
+
+  BROWSER_PLUGIN_DIR=/usr/lib/epiphany/plugins \
+  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+    --libexecdir=/usr/lib/$pkgname \
+    --disable-static \
+    --enable-compile-warnings=minimum \
+    --enable-introspection \
+    --enable-nautilus \
+    --enable-pdf \
+    --enable-tiff \
+    --enable-djvu \
+    --enable-dvi \
+    --enable-t1lib \
+    --enable-comics \
+    --enable-gtk-doc \
+    --enable-multimedia \
+    --disable-schemas-compile
+
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+  make
+}
+
+package() {
+  cd $pkgname
+  make DESTDIR="$pkgdir" install
+}

Copied: evince/repos/gnome-unstable-x86_64/PKGBUILD (from rev 276799, 
evince/trunk/PKGBUILD)
===================================================================
--- gnome-unstable-x86_64/PKGBUILD                              (rev 0)
+++ gnome-unstable-x86_64/PKGBUILD      2016-09-21 12:10:43 UTC (rev 276800)
@@ -0,0 +1,63 @@
+# $Id$
+# Maintainer: Jan de Groot <j...@archlinux.org>
+
+pkgname=evince
+pkgver=3.22.0+1+gc1dd9eb
+pkgrel=1
+pkgdesc="Document viewer (PDF, Postscript, djvu, tiff, dvi, XPS, SyncTex 
support with gedit, comics books (cbr,cbz,cb7 and cbt))"
+url="https://wiki.gnome.org/Apps/Evince";
+arch=(i686 x86_64)
+license=(GPL)
+depends=(gtk3 libgxps libspectre gsfonts poppler-glib djvulibre t1lib dconf
+         libsecret gsettings-desktop-schemas gnome-desktop libarchive
+         gst-plugins-base-libs)
+makedepends=(itstool libnautilus-extension texlive-bin gobject-introspection
+             intltool docbook-xsl python gtk-doc git gnome-common)
+optdepends=('texlive-bin: DVI support'
+           'gvfs: bookmark support and session saving')
+groups=(gnome)
+options=('!emptydirs')
+_commit=c1dd9eb697a58044e9d04846590fdfe1e65dda0f
+source=("git://git.gnome.org/evince#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+  cd $pkgname
+  git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+  cd $pkgname
+  NOCONFIGURE=1 ./autogen.sh
+}
+  
+
+build() {
+  cd $pkgname
+
+  BROWSER_PLUGIN_DIR=/usr/lib/epiphany/plugins \
+  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+    --libexecdir=/usr/lib/$pkgname \
+    --disable-static \
+    --enable-compile-warnings=minimum \
+    --enable-introspection \
+    --enable-nautilus \
+    --enable-pdf \
+    --enable-tiff \
+    --enable-djvu \
+    --enable-dvi \
+    --enable-t1lib \
+    --enable-comics \
+    --enable-gtk-doc \
+    --enable-multimedia \
+    --disable-schemas-compile
+
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+  make
+}
+
+package() {
+  cd $pkgname
+  make DESTDIR="$pkgdir" install
+}

Reply via email to