Date: Wednesday, October 12, 2016 @ 17:11:15
  Author: arojas
Revision: 192072

archrelease: copy trunk to community-i686, community-x86_64

Added:
  xmoto/repos/community-i686/PKGBUILD
    (from rev 192071, xmoto/trunk/PKGBUILD)
  xmoto/repos/community-i686/lua52_compat.patch
    (from rev 192071, xmoto/trunk/lua52_compat.patch)
  xmoto/repos/community-x86_64/PKGBUILD
    (from rev 192071, xmoto/trunk/PKGBUILD)
  xmoto/repos/community-x86_64/lua52_compat.patch
    (from rev 192071, xmoto/trunk/lua52_compat.patch)
Deleted:
  xmoto/repos/community-i686/PKGBUILD
  xmoto/repos/community-i686/lua52_compat.patch
  xmoto/repos/community-x86_64/PKGBUILD
  xmoto/repos/community-x86_64/lua52_compat.patch

-------------------------------------+
 /PKGBUILD                           |  106 ++++++++++++++++++++++++++++++++++
 /lua52_compat.patch                 |   90 ++++++++++++++++++++++++++++
 community-i686/PKGBUILD             |   53 -----------------
 community-i686/lua52_compat.patch   |   45 --------------
 community-x86_64/PKGBUILD           |   53 -----------------
 community-x86_64/lua52_compat.patch |   45 --------------
 6 files changed, 196 insertions(+), 196 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD     2016-10-12 17:10:43 UTC (rev 192071)
+++ community-i686/PKGBUILD     2016-10-12 17:11:15 UTC (rev 192072)
@@ -1,53 +0,0 @@
-# $Id$
-# Maintainer: Ronald van Haren <ronald.archlinux.org>
-# Contributor: Travis Willard <trav...@wmpub.ca>
-# Contributor: Denis (dtona...@gmail.com)
-
-pkgname=xmoto
-pkgver=0.5.11
-pkgrel=5
-pkgdesc="A challenging 2D motocross platform game, where physics play an 
important role."
-arch=('i686' 'x86_64')
-url="http://xmoto.tuxfamily.org";
-license=('GPL')
-depends=('libjpeg' 'libpng' 'lua52' 'sdl_mixer' 'ode' 'curl' 'sqlite' 'sdl_ttf'
-         'desktop-file-utils' 'sdl_net' 'glu' 'libxdg-basedir' 'libxml2')
-makedepends=('mesa')
-source=("http://download.tuxfamily.org/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}-src.tar.gz";
-        'lua52_compat.patch')
-sha1sums=('a795616fb359e60be343e339f7acf5e95e0f1ce2'
-          '104542546fbbd24172ddaa179f87e1b26df8b761')
-
-prepare() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-
-  patch -Np1 -i "${srcdir}/lua52_compat.patch"
-  ./bootstrap
-
-  # Remove bundled ode library because its headers get picked up during build
-  rm -r src/ode
-}
-
-build() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-
-  # Build using the old C++ ABI to fix issue with missing text; the issue
-  # should be fixed in the next stable release (if that ever does happen)
-  CPPFLAGS+=' -D_GLIBCXX_USE_CXX11_ABI=0'
-
-  ./configure --prefix=/usr --disable-sdltest
-  make
-}
-
-package() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  make DESTDIR="${pkgdir}" mangdir=/usr/share/man/man6 install
-
-  # install desktop file
-  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.desktop" \
-        "${pkgdir}/usr/share/applications/xmoto.desktop"
-
-  # install icon for desktop file
-  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.xpm" \
-        "${pkgdir}/usr/share/pixmaps/xmoto.xpm"
-}

Copied: xmoto/repos/community-i686/PKGBUILD (from rev 192071, 
xmoto/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD                             (rev 0)
+++ community-i686/PKGBUILD     2016-10-12 17:11:15 UTC (rev 192072)
@@ -0,0 +1,53 @@
+# $Id$
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Travis Willard <trav...@wmpub.ca>
+# Contributor: Denis (dtona...@gmail.com)
+
+pkgname=xmoto
+pkgver=0.5.11
+pkgrel=6
+pkgdesc="A challenging 2D motocross platform game, where physics play an 
important role."
+arch=('i686' 'x86_64')
+url="http://xmoto.tuxfamily.org";
+license=('GPL')
+depends=('libjpeg' 'libpng' 'lua52' 'sdl_mixer' 'ode' 'curl' 'sqlite' 'sdl_ttf'
+         'sdl_net' 'glu' 'libxdg-basedir' 'libxml2')
+makedepends=('mesa')
+source=("http://download.tuxfamily.org/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}-src.tar.gz";
+        'lua52_compat.patch')
+sha1sums=('a795616fb359e60be343e339f7acf5e95e0f1ce2'
+          '104542546fbbd24172ddaa179f87e1b26df8b761')
+
+prepare() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  patch -Np1 -i "${srcdir}/lua52_compat.patch"
+  ./bootstrap
+
+  # Remove bundled ode library because its headers get picked up during build
+  rm -r src/ode
+}
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  # Build using the old C++ ABI to fix issue with missing text; the issue
+  # should be fixed in the next stable release (if that ever does happen)
+  CPPFLAGS+=' -D_GLIBCXX_USE_CXX11_ABI=0'
+
+  ./configure --prefix=/usr --disable-sdltest
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" mangdir=/usr/share/man/man6 install
+
+  # install desktop file
+  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.desktop" \
+        "${pkgdir}/usr/share/applications/xmoto.desktop"
+
+  # install icon for desktop file
+  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.xpm" \
+        "${pkgdir}/usr/share/pixmaps/xmoto.xpm"
+}

Deleted: community-i686/lua52_compat.patch
===================================================================
--- community-i686/lua52_compat.patch   2016-10-12 17:10:43 UTC (rev 192071)
+++ community-i686/lua52_compat.patch   2016-10-12 17:11:15 UTC (rev 192072)
@@ -1,45 +0,0 @@
-diff --git a/configure.in b/configure.in
-index 452f196..dbceb05 100644
---- a/configure.in
-+++ b/configure.in
-@@ -157,8 +157,8 @@ AM_CONDITIONAL([USE_SDLGFX], test "$USE_SDLGFX" = "1")
- # m
- AC_CHECK_LIB(m, floor, , AC_MSG_ERROR(No math library found))
- 
--AC_SEARCH_LIBS(lua_pushboolean,lua lua5.1 lua50, [], [AC_MSG_ERROR(liblua5.1, 
liblua50, or liblua required)])
--AC_SEARCH_LIBS(luaopen_math,lualib lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.1, liblualib50, or liblualib required)])
-+AC_SEARCH_LIBS(lua_pushboolean,lua lua5.2 lua5.1 lua50, [], 
[AC_MSG_ERROR(liblua5.2 liblua5.1, liblua50, or liblua required)])
-+AC_SEARCH_LIBS(luaopen_math,lualib liblua5.2 lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.2 liblualib5.1, liblualib50, or liblualib required)])
- 
- dnl ***** Check lua headers, as they are prone to be located random places on 
random systems! *****
- dnl The following three lines where suggested by Eric Piel, but they don't 
seem to work on my system
-@@ -174,6 +174,8 @@ AC_CHECK_HEADER(lua/lua.h,    AC_DEFINE(HAVE_LUA_LUA_H)   
[USE_LUA_VERSION="unkn
- AC_CHECK_HEADER(lua50/lua.h,  AC_DEFINE(HAVE_LUA50_LUA_H) 
[USE_LUA_VERSION="5.0"])
- AC_CHECK_HEADER(lua51/lua.h,  AC_DEFINE(HAVE_LUA51_LUA_H) 
[USE_LUA_VERSION="5.1"])
- AC_CHECK_HEADER(lua5.1/lua.h, 
AC_DEFINE(HAVE_LUA5_1_LUA_H)[USE_LUA_VERSION="5.1"])
-+AC_CHECK_HEADER(lua52/lua.h,  AC_DEFINE(HAVE_LUA52_LUA_H) 
[USE_LUA_VERSION="5.2"])
-+AC_CHECK_HEADER(lua5.2/lua.h, 
AC_DEFINE(HAVE_LUA5_2_LUA_H)[USE_LUA_VERSION="5.2"])
- AC_DEFINE(LUA_COMPAT_MODULE, 1)
- 
- AC_LANG_PUSH([C++])
-diff --git a/src/include/xm_lua.h b/src/include/xm_lua.h
-index 8a2cc17..f470de2 100644
---- a/src/include/xm_lua.h
-+++ b/src/include/xm_lua.h
-@@ -4,7 +4,15 @@ extern "C" {
-     #include "lauxlib.h"
-     #include "lualib.h"
-   #else
--    #if defined(HAVE_LUA5_1_LUA_H)
-+    #if defined(HAVE_LUA5_2_LUA_H)
-+      #include <lua5.2/lua.h>
-+      #include <lua5.2/lauxlib.h>
-+      #include <lua5.2/lualib.h>
-+    #elif defined(HAVE_LUA52_LUA_H)
-+      #include <lua52/lua.h>
-+      #include <lua52/lauxlib.h>
-+      #include <lua52/lualib.h>
-+    #elif defined(HAVE_LUA5_1_LUA_H)
-       #include <lua5.1/lua.h>
-       #include <lua5.1/lauxlib.h>
-       #include <lua5.1/lualib.h>

Copied: xmoto/repos/community-i686/lua52_compat.patch (from rev 192071, 
xmoto/trunk/lua52_compat.patch)
===================================================================
--- community-i686/lua52_compat.patch                           (rev 0)
+++ community-i686/lua52_compat.patch   2016-10-12 17:11:15 UTC (rev 192072)
@@ -0,0 +1,45 @@
+diff --git a/configure.in b/configure.in
+index 452f196..dbceb05 100644
+--- a/configure.in
++++ b/configure.in
+@@ -157,8 +157,8 @@ AM_CONDITIONAL([USE_SDLGFX], test "$USE_SDLGFX" = "1")
+ # m
+ AC_CHECK_LIB(m, floor, , AC_MSG_ERROR(No math library found))
+ 
+-AC_SEARCH_LIBS(lua_pushboolean,lua lua5.1 lua50, [], [AC_MSG_ERROR(liblua5.1, 
liblua50, or liblua required)])
+-AC_SEARCH_LIBS(luaopen_math,lualib lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.1, liblualib50, or liblualib required)])
++AC_SEARCH_LIBS(lua_pushboolean,lua lua5.2 lua5.1 lua50, [], 
[AC_MSG_ERROR(liblua5.2 liblua5.1, liblua50, or liblua required)])
++AC_SEARCH_LIBS(luaopen_math,lualib liblua5.2 lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.2 liblualib5.1, liblualib50, or liblualib required)])
+ 
+ dnl ***** Check lua headers, as they are prone to be located random places on 
random systems! *****
+ dnl The following three lines where suggested by Eric Piel, but they don't 
seem to work on my system
+@@ -174,6 +174,8 @@ AC_CHECK_HEADER(lua/lua.h,    AC_DEFINE(HAVE_LUA_LUA_H)   
[USE_LUA_VERSION="unkn
+ AC_CHECK_HEADER(lua50/lua.h,  AC_DEFINE(HAVE_LUA50_LUA_H) 
[USE_LUA_VERSION="5.0"])
+ AC_CHECK_HEADER(lua51/lua.h,  AC_DEFINE(HAVE_LUA51_LUA_H) 
[USE_LUA_VERSION="5.1"])
+ AC_CHECK_HEADER(lua5.1/lua.h, 
AC_DEFINE(HAVE_LUA5_1_LUA_H)[USE_LUA_VERSION="5.1"])
++AC_CHECK_HEADER(lua52/lua.h,  AC_DEFINE(HAVE_LUA52_LUA_H) 
[USE_LUA_VERSION="5.2"])
++AC_CHECK_HEADER(lua5.2/lua.h, 
AC_DEFINE(HAVE_LUA5_2_LUA_H)[USE_LUA_VERSION="5.2"])
+ AC_DEFINE(LUA_COMPAT_MODULE, 1)
+ 
+ AC_LANG_PUSH([C++])
+diff --git a/src/include/xm_lua.h b/src/include/xm_lua.h
+index 8a2cc17..f470de2 100644
+--- a/src/include/xm_lua.h
++++ b/src/include/xm_lua.h
+@@ -4,7 +4,15 @@ extern "C" {
+     #include "lauxlib.h"
+     #include "lualib.h"
+   #else
+-    #if defined(HAVE_LUA5_1_LUA_H)
++    #if defined(HAVE_LUA5_2_LUA_H)
++      #include <lua5.2/lua.h>
++      #include <lua5.2/lauxlib.h>
++      #include <lua5.2/lualib.h>
++    #elif defined(HAVE_LUA52_LUA_H)
++      #include <lua52/lua.h>
++      #include <lua52/lauxlib.h>
++      #include <lua52/lualib.h>
++    #elif defined(HAVE_LUA5_1_LUA_H)
+       #include <lua5.1/lua.h>
+       #include <lua5.1/lauxlib.h>
+       #include <lua5.1/lualib.h>

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD   2016-10-12 17:10:43 UTC (rev 192071)
+++ community-x86_64/PKGBUILD   2016-10-12 17:11:15 UTC (rev 192072)
@@ -1,53 +0,0 @@
-# $Id$
-# Maintainer: Ronald van Haren <ronald.archlinux.org>
-# Contributor: Travis Willard <trav...@wmpub.ca>
-# Contributor: Denis (dtona...@gmail.com)
-
-pkgname=xmoto
-pkgver=0.5.11
-pkgrel=5
-pkgdesc="A challenging 2D motocross platform game, where physics play an 
important role."
-arch=('i686' 'x86_64')
-url="http://xmoto.tuxfamily.org";
-license=('GPL')
-depends=('libjpeg' 'libpng' 'lua52' 'sdl_mixer' 'ode' 'curl' 'sqlite' 'sdl_ttf'
-         'desktop-file-utils' 'sdl_net' 'glu' 'libxdg-basedir' 'libxml2')
-makedepends=('mesa')
-source=("http://download.tuxfamily.org/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}-src.tar.gz";
-        'lua52_compat.patch')
-sha1sums=('a795616fb359e60be343e339f7acf5e95e0f1ce2'
-          '104542546fbbd24172ddaa179f87e1b26df8b761')
-
-prepare() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-
-  patch -Np1 -i "${srcdir}/lua52_compat.patch"
-  ./bootstrap
-
-  # Remove bundled ode library because its headers get picked up during build
-  rm -r src/ode
-}
-
-build() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-
-  # Build using the old C++ ABI to fix issue with missing text; the issue
-  # should be fixed in the next stable release (if that ever does happen)
-  CPPFLAGS+=' -D_GLIBCXX_USE_CXX11_ABI=0'
-
-  ./configure --prefix=/usr --disable-sdltest
-  make
-}
-
-package() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  make DESTDIR="${pkgdir}" mangdir=/usr/share/man/man6 install
-
-  # install desktop file
-  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.desktop" \
-        "${pkgdir}/usr/share/applications/xmoto.desktop"
-
-  # install icon for desktop file
-  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.xpm" \
-        "${pkgdir}/usr/share/pixmaps/xmoto.xpm"
-}

Copied: xmoto/repos/community-x86_64/PKGBUILD (from rev 192071, 
xmoto/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD                           (rev 0)
+++ community-x86_64/PKGBUILD   2016-10-12 17:11:15 UTC (rev 192072)
@@ -0,0 +1,53 @@
+# $Id$
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Travis Willard <trav...@wmpub.ca>
+# Contributor: Denis (dtona...@gmail.com)
+
+pkgname=xmoto
+pkgver=0.5.11
+pkgrel=6
+pkgdesc="A challenging 2D motocross platform game, where physics play an 
important role."
+arch=('i686' 'x86_64')
+url="http://xmoto.tuxfamily.org";
+license=('GPL')
+depends=('libjpeg' 'libpng' 'lua52' 'sdl_mixer' 'ode' 'curl' 'sqlite' 'sdl_ttf'
+         'sdl_net' 'glu' 'libxdg-basedir' 'libxml2')
+makedepends=('mesa')
+source=("http://download.tuxfamily.org/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}-src.tar.gz";
+        'lua52_compat.patch')
+sha1sums=('a795616fb359e60be343e339f7acf5e95e0f1ce2'
+          '104542546fbbd24172ddaa179f87e1b26df8b761')
+
+prepare() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  patch -Np1 -i "${srcdir}/lua52_compat.patch"
+  ./bootstrap
+
+  # Remove bundled ode library because its headers get picked up during build
+  rm -r src/ode
+}
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  # Build using the old C++ ABI to fix issue with missing text; the issue
+  # should be fixed in the next stable release (if that ever does happen)
+  CPPFLAGS+=' -D_GLIBCXX_USE_CXX11_ABI=0'
+
+  ./configure --prefix=/usr --disable-sdltest
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" mangdir=/usr/share/man/man6 install
+
+  # install desktop file
+  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.desktop" \
+        "${pkgdir}/usr/share/applications/xmoto.desktop"
+
+  # install icon for desktop file
+  install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.xpm" \
+        "${pkgdir}/usr/share/pixmaps/xmoto.xpm"
+}

Deleted: community-x86_64/lua52_compat.patch
===================================================================
--- community-x86_64/lua52_compat.patch 2016-10-12 17:10:43 UTC (rev 192071)
+++ community-x86_64/lua52_compat.patch 2016-10-12 17:11:15 UTC (rev 192072)
@@ -1,45 +0,0 @@
-diff --git a/configure.in b/configure.in
-index 452f196..dbceb05 100644
---- a/configure.in
-+++ b/configure.in
-@@ -157,8 +157,8 @@ AM_CONDITIONAL([USE_SDLGFX], test "$USE_SDLGFX" = "1")
- # m
- AC_CHECK_LIB(m, floor, , AC_MSG_ERROR(No math library found))
- 
--AC_SEARCH_LIBS(lua_pushboolean,lua lua5.1 lua50, [], [AC_MSG_ERROR(liblua5.1, 
liblua50, or liblua required)])
--AC_SEARCH_LIBS(luaopen_math,lualib lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.1, liblualib50, or liblualib required)])
-+AC_SEARCH_LIBS(lua_pushboolean,lua lua5.2 lua5.1 lua50, [], 
[AC_MSG_ERROR(liblua5.2 liblua5.1, liblua50, or liblua required)])
-+AC_SEARCH_LIBS(luaopen_math,lualib liblua5.2 lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.2 liblualib5.1, liblualib50, or liblualib required)])
- 
- dnl ***** Check lua headers, as they are prone to be located random places on 
random systems! *****
- dnl The following three lines where suggested by Eric Piel, but they don't 
seem to work on my system
-@@ -174,6 +174,8 @@ AC_CHECK_HEADER(lua/lua.h,    AC_DEFINE(HAVE_LUA_LUA_H)   
[USE_LUA_VERSION="unkn
- AC_CHECK_HEADER(lua50/lua.h,  AC_DEFINE(HAVE_LUA50_LUA_H) 
[USE_LUA_VERSION="5.0"])
- AC_CHECK_HEADER(lua51/lua.h,  AC_DEFINE(HAVE_LUA51_LUA_H) 
[USE_LUA_VERSION="5.1"])
- AC_CHECK_HEADER(lua5.1/lua.h, 
AC_DEFINE(HAVE_LUA5_1_LUA_H)[USE_LUA_VERSION="5.1"])
-+AC_CHECK_HEADER(lua52/lua.h,  AC_DEFINE(HAVE_LUA52_LUA_H) 
[USE_LUA_VERSION="5.2"])
-+AC_CHECK_HEADER(lua5.2/lua.h, 
AC_DEFINE(HAVE_LUA5_2_LUA_H)[USE_LUA_VERSION="5.2"])
- AC_DEFINE(LUA_COMPAT_MODULE, 1)
- 
- AC_LANG_PUSH([C++])
-diff --git a/src/include/xm_lua.h b/src/include/xm_lua.h
-index 8a2cc17..f470de2 100644
---- a/src/include/xm_lua.h
-+++ b/src/include/xm_lua.h
-@@ -4,7 +4,15 @@ extern "C" {
-     #include "lauxlib.h"
-     #include "lualib.h"
-   #else
--    #if defined(HAVE_LUA5_1_LUA_H)
-+    #if defined(HAVE_LUA5_2_LUA_H)
-+      #include <lua5.2/lua.h>
-+      #include <lua5.2/lauxlib.h>
-+      #include <lua5.2/lualib.h>
-+    #elif defined(HAVE_LUA52_LUA_H)
-+      #include <lua52/lua.h>
-+      #include <lua52/lauxlib.h>
-+      #include <lua52/lualib.h>
-+    #elif defined(HAVE_LUA5_1_LUA_H)
-       #include <lua5.1/lua.h>
-       #include <lua5.1/lauxlib.h>
-       #include <lua5.1/lualib.h>

Copied: xmoto/repos/community-x86_64/lua52_compat.patch (from rev 192071, 
xmoto/trunk/lua52_compat.patch)
===================================================================
--- community-x86_64/lua52_compat.patch                         (rev 0)
+++ community-x86_64/lua52_compat.patch 2016-10-12 17:11:15 UTC (rev 192072)
@@ -0,0 +1,45 @@
+diff --git a/configure.in b/configure.in
+index 452f196..dbceb05 100644
+--- a/configure.in
++++ b/configure.in
+@@ -157,8 +157,8 @@ AM_CONDITIONAL([USE_SDLGFX], test "$USE_SDLGFX" = "1")
+ # m
+ AC_CHECK_LIB(m, floor, , AC_MSG_ERROR(No math library found))
+ 
+-AC_SEARCH_LIBS(lua_pushboolean,lua lua5.1 lua50, [], [AC_MSG_ERROR(liblua5.1, 
liblua50, or liblua required)])
+-AC_SEARCH_LIBS(luaopen_math,lualib lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.1, liblualib50, or liblualib required)])
++AC_SEARCH_LIBS(lua_pushboolean,lua lua5.2 lua5.1 lua50, [], 
[AC_MSG_ERROR(liblua5.2 liblua5.1, liblua50, or liblua required)])
++AC_SEARCH_LIBS(luaopen_math,lualib liblua5.2 lualib5.1 lualib50, [], 
[AC_MSG_ERROR(liblualib5.2 liblualib5.1, liblualib50, or liblualib required)])
+ 
+ dnl ***** Check lua headers, as they are prone to be located random places on 
random systems! *****
+ dnl The following three lines where suggested by Eric Piel, but they don't 
seem to work on my system
+@@ -174,6 +174,8 @@ AC_CHECK_HEADER(lua/lua.h,    AC_DEFINE(HAVE_LUA_LUA_H)   
[USE_LUA_VERSION="unkn
+ AC_CHECK_HEADER(lua50/lua.h,  AC_DEFINE(HAVE_LUA50_LUA_H) 
[USE_LUA_VERSION="5.0"])
+ AC_CHECK_HEADER(lua51/lua.h,  AC_DEFINE(HAVE_LUA51_LUA_H) 
[USE_LUA_VERSION="5.1"])
+ AC_CHECK_HEADER(lua5.1/lua.h, 
AC_DEFINE(HAVE_LUA5_1_LUA_H)[USE_LUA_VERSION="5.1"])
++AC_CHECK_HEADER(lua52/lua.h,  AC_DEFINE(HAVE_LUA52_LUA_H) 
[USE_LUA_VERSION="5.2"])
++AC_CHECK_HEADER(lua5.2/lua.h, 
AC_DEFINE(HAVE_LUA5_2_LUA_H)[USE_LUA_VERSION="5.2"])
+ AC_DEFINE(LUA_COMPAT_MODULE, 1)
+ 
+ AC_LANG_PUSH([C++])
+diff --git a/src/include/xm_lua.h b/src/include/xm_lua.h
+index 8a2cc17..f470de2 100644
+--- a/src/include/xm_lua.h
++++ b/src/include/xm_lua.h
+@@ -4,7 +4,15 @@ extern "C" {
+     #include "lauxlib.h"
+     #include "lualib.h"
+   #else
+-    #if defined(HAVE_LUA5_1_LUA_H)
++    #if defined(HAVE_LUA5_2_LUA_H)
++      #include <lua5.2/lua.h>
++      #include <lua5.2/lauxlib.h>
++      #include <lua5.2/lualib.h>
++    #elif defined(HAVE_LUA52_LUA_H)
++      #include <lua52/lua.h>
++      #include <lua52/lauxlib.h>
++      #include <lua52/lualib.h>
++    #elif defined(HAVE_LUA5_1_LUA_H)
+       #include <lua5.1/lua.h>
+       #include <lua5.1/lauxlib.h>
+       #include <lua5.1/lualib.h>

Reply via email to