Date: Thursday, October 13, 2016 @ 16:24:18
  Author: arojas
Revision: 278792

Still requires python2

Modified:
  kdegames-kajongg/trunk/PKGBUILD

----------+
 PKGBUILD |    8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2016-10-13 16:16:52 UTC (rev 278791)
+++ PKGBUILD    2016-10-13 16:24:18 UTC (rev 278792)
@@ -4,13 +4,13 @@
 
 pkgname=kdegames-kajongg
 pkgver=16.08.2
-pkgrel=1
+pkgrel=2
 pkgdesc="The ancient Chinese board game for 4 players"
 url="http://kde.org/applications/games/kajongg/";
 arch=('any')
 license=('GPL' 'LGPL' 'FDL')
 groups=('kde-applications' 'kdegames')
-depends=('kdebase-runtime' 'python-twisted' 'kdebindings-python' 
'libkmahjongg')
+depends=('kdebase-runtime' 'python2-twisted' 'kdebindings-python2' 
'libkmahjongg')
 makedepends=('cmake' 'automoc4')
 optdepends=('vorbis-tools: for playing sounds')
 conflicts=('libkmahjongg4')
@@ -19,6 +19,10 @@
 
 prepare() {
   mkdir -p build
+
+  cd kajongg-${pkgver}
+  sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+    src/{deferredutil,kajongg,kajonggserver,server}.py
 }
 
 build() {

Reply via email to