Date: Tuesday, October 18, 2016 @ 05:56:45
  Author: arojas
Revision: 192479

Update to 4.0

Modified:
  kadu/trunk/PKGBUILD

----------+
 PKGBUILD |   24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2016-10-18 02:28:48 UTC (rev 192478)
+++ PKGBUILD    2016-10-18 05:56:45 UTC (rev 192479)
@@ -4,20 +4,19 @@
 # Contributor: Jaroslaw Swierczynski <swier...@aur.archlinux.org>
 
 pkgname=kadu
-pkgver=3.0
-pkgrel=2
+pkgver=4.0
+pkgrel=1
 pkgdesc='Qt-based Jabber/XMPP and Gadu-Gadu client'
 arch=('i686' 'x86_64')
 url='http://www.kadu.net/'
 license=('GPL')
-depends=('libgadu' 'libxss' 'enchant' 'phonon-qt5' 'qca-qt5'
-         'libmpdclient' 'libotr' 'libarchive' 'injeqt' 'xdg-utils' 
'qt5-multimedia'
+options=(!makeflags)
+depends=('libgadu' 'libxss' 'enchant' 'libmpdclient' 'libotr' 'libarchive' 
'injeqt' 'xdg-utils' 'qt5-multimedia'
          'qt5-x11extras' 'qt5-svg' 'qt5-script' 'qt5-webkit' 
'hicolor-icon-theme')
-makedepends=('cmake' 'libao' 'libsndfile' 'libxtst' 'curl' 'chrpath' 'ninja'
-             'qt5-tools' 'qxmpp')
+makedepends=('cmake' 'libao' 'libsndfile' 'libxtst' 'curl' 'qt5-tools' 'qxmpp')
 optdepends=('qxmpp: Jabber protocol')
 source=(http://download.kadu.im/stable/$pkgname-$pkgver.tar.bz2)
-md5sums=('9d42c16682b338c14e6a912efd739447')
+md5sums=('639dd102474e2cea73876d4051459082')
 
 prepare() {
   sed -i 's/unity_integration//g' $pkgname-$pkgver/Plugins.cmake
@@ -29,14 +28,15 @@
   cd build
 
   cmake ../$pkgname-$pkgver \
-    -GNinja \
     -DCMAKE_BUILD_TYPE=Release \
     -DCMAKE_INSTALL_PREFIX=/usr \
-    -DCMAKE_INSTALL_LIBDIR=/usr/lib
-  ninja
+    -DCMAKE_INSTALL_LIBDIR=lib \
+    -DCMAKE_CXX_STANDARD=14 \
+    -DENABLE_TESTS=OFF
+  make
 }
 
 package() {
-  DESTDIR="$pkgdir" LIBDIR=/usr/lib ninja -C build install
-  chrpath -d "$pkgdir"/usr/lib/kadu/plugins/*.so
+  cd build
+  make DESTDIR="$pkgdir" LIBDIR=/usr/lib install
 }

Reply via email to