Date: Saturday, August 5, 2017 @ 08:08:29
  Author: felixonmars
Revision: 248598

archrelease: copy trunk to community-any

Added:
  python-pyflakes/repos/community-any/PKGBUILD
    (from rev 248597, python-pyflakes/trunk/PKGBUILD)
Deleted:
  python-pyflakes/repos/community-any/PKGBUILD

----------+
 PKGBUILD |  124 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 62 insertions(+), 62 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2017-08-05 08:08:10 UTC (rev 248597)
+++ PKGBUILD    2017-08-05 08:08:29 UTC (rev 248598)
@@ -1,62 +0,0 @@
-# $Id$
-# Maintainer: Felix Yan <felixonm...@archlinux.org>
-# Contributor: Karol 'Kenji Takahashi' Woźniak <kenji.sx>
-# Contributor: Tianjiao Yin <ytj000+...@gmail.com>
-# Contributor: Thomas Dziedzic < gostrc at gmail >
-# Contributor: TDY <t...@gmx.com>
-# Contributor: Tiago Pierezan Camargo <tcama...@gmail.com>
-
-pkgbase=python-pyflakes
-pkgname=(python-pyflakes python2-pyflakes)
-pkgver=1.5.0
-pkgrel=1
-pkgdesc='A lint-like tool for Python to identify common errors quickly without 
executing code'
-arch=('any')
-url='http://pypi.python.org/pypi/pyflakes'
-license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://pypi.io/packages/source/p/pyflakes/pyflakes-$pkgver.tar.gz";)
-sha1sums=('ff77b05dc782a1a5e2b662ff93e8b0646a0d8316')
-
-prepare() {
-  cp -a "pyflakes-$pkgver"{,-py2}
-}
-
-build() {
-  cd "$srcdir"/pyflakes-$pkgver
-  python setup.py build
-
-  cd "$srcdir"/pyflakes-$pkgver-py2
-  python2 setup.py build
-}
-
-check() {
-  cd "$srcdir"/pyflakes-$pkgver
-  python setup.py test
-
-  cd "$srcdir"/pyflakes-$pkgver-py2
-  python2 setup.py test
-}
-
-package_python-pyflakes() {
-  depends=('python-setuptools')
-
-  cd pyflakes-$pkgver
-  python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
-
-  # We have python 3 as default python, and want to keep compatibility with 
the old pyflakes3k naming
-  ln -s pyflakes "$pkgdir/usr/bin/pyflakes3k"
-
-  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-
-package_python2-pyflakes() {
-  depends=('python2-setuptools')
-
-  cd pyflakes-$pkgver-py2
-  python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
-
-  mv "$pkgdir"/usr/bin/pyflakes{,-python2}
-
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}

Copied: python-pyflakes/repos/community-any/PKGBUILD (from rev 248597, 
python-pyflakes/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2017-08-05 08:08:29 UTC (rev 248598)
@@ -0,0 +1,62 @@
+# $Id$
+# Maintainer: Felix Yan <felixonm...@archlinux.org>
+# Contributor: Karol 'Kenji Takahashi' Woźniak <kenji.sx>
+# Contributor: Tianjiao Yin <ytj000+...@gmail.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: TDY <t...@gmx.com>
+# Contributor: Tiago Pierezan Camargo <tcama...@gmail.com>
+
+pkgbase=python-pyflakes
+pkgname=(python-pyflakes python2-pyflakes)
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='A lint-like tool for Python to identify common errors quickly without 
executing code'
+arch=('any')
+url='http://pypi.python.org/pypi/pyflakes'
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://pypi.io/packages/source/p/pyflakes/pyflakes-$pkgver.tar.gz";)
+sha512sums=('7e9c2aad6ebed638a1354cef51c7e1f68b25e59f8caf4694997a9afecd7cd8baa629a9363297ac0d961430f007fd22dcae7dae1bcbd7838a3b5d4285063bc7c5')
+
+prepare() {
+  cp -a "pyflakes-$pkgver"{,-py2}
+}
+
+build() {
+  cd "$srcdir"/pyflakes-$pkgver
+  python setup.py build
+
+  cd "$srcdir"/pyflakes-$pkgver-py2
+  python2 setup.py build
+}
+
+check() {
+  cd "$srcdir"/pyflakes-$pkgver
+  python setup.py test
+
+  cd "$srcdir"/pyflakes-$pkgver-py2
+  python2 setup.py test
+}
+
+package_python-pyflakes() {
+  depends=('python-setuptools')
+
+  cd pyflakes-$pkgver
+  python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+
+  # We have python 3 as default python, and want to keep compatibility with 
the old pyflakes3k naming
+  ln -s pyflakes "$pkgdir/usr/bin/pyflakes3k"
+
+  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pyflakes() {
+  depends=('python2-setuptools')
+
+  cd pyflakes-$pkgver-py2
+  python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+
+  mv "$pkgdir"/usr/bin/pyflakes{,-python2}
+
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}

Reply via email to