Date: Thursday, August 10, 2017 @ 22:13:04
  Author: svenstaro
Revision: 249795

archrelease: copy trunk to community-i686, community-x86_64

Added:
  openvdb/repos/community-i686/PKGBUILD
    (from rev 249794, openvdb/trunk/PKGBUILD)
  openvdb/repos/community-x86_64/PKGBUILD
    (from rev 249794, openvdb/trunk/PKGBUILD)
Deleted:
  openvdb/repos/community-i686/PKGBUILD
  openvdb/repos/community-x86_64/PKGBUILD

---------------------------+
 /PKGBUILD                 |  102 ++++++++++++++++++++++++++++++++++++++++++++
 community-i686/PKGBUILD   |   50 ---------------------
 community-x86_64/PKGBUILD |   50 ---------------------
 3 files changed, 102 insertions(+), 100 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD     2017-08-10 22:12:33 UTC (rev 249794)
+++ community-i686/PKGBUILD     2017-08-10 22:13:04 UTC (rev 249795)
@@ -1,50 +0,0 @@
-# Maintainer: Sven-Hendrik Haase <s...@lutzhaase.com>
-
-# I would just like to take a minute here to state that this is probably one
-# of the worst packaged software packages that I have ever looked at.
-# The Makefile has defaults set to the upstream developers' specific systems
-# as well as other oddities.
-
-pkgname=openvdb
-pkgver=3.2.0
-pkgrel=3
-pkgdesc='A large suite of tools for the efficient storage and manipulation of 
sparse volumetric data discretized on three-dimensional grids'
-url='https://github.com/dreamworksanimation/openvdb'
-arch=('i686' 'x86_64')
-license=('MPL')
-depends=('openexr' 'boost-libs' 'intel-tbb' 'zlib' 'jemalloc' 'blosc')
-makedepends=('doxygen' 'boost' 'python2' 'log4cplus' 'epydoc' 'python2-numpy' 
'texlive-core' 'ghostscript' 'epydoc')
-optdepends=('python2-numpy: Python module')
-source=("https://github.com/dreamworksanimation/openvdb/archive/v${pkgver}.tar.gz";)
-sha512sums=('df9a4895b219aae3b5a9616c34eb846d565877ff76648405691f0c903507f6faba94e8eba9173423b50cb5cef80f3ec500a9f70977cb7161701d39fd105abc91')
-
-build() {
-  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
-
-  make all \
-    OPENVDB_ENABLE_3_ABI_COMPATIBLE=ON \
-    PYTHON_VERSION='2.7' \
-    CPPUNIT_INCL_DIR='' \
-    HDSO='/usr' \
-    PYTHON_INCL_DIR=/usr/include/python2.7 \
-    PYTHON_LIB_DIR=/usr/lib \
-    EXR_LIB_DIR=/usr/lib \
-    ILMBASE_LIB_DIR=/usr/lib \
-    NUMPY_INCL_DIR=/usr/lib/python2.7/site-packages/numpy/core/include/numpy \
-    GLFW_INCL_DIR='' \
-    BOOST_PYTHON_LIB_DIR=/usr/lib \
-    BOOST_PYTHON_LIB=-lboost_python
-
-}
-
-package() {
-  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
-
-  mkdir ${pkgdir}/usr
-  make install \
-    GLFW_INCL_DIR='' \
-    EPYDOC=/usr/bin/epydoc \
-    DESTDIR=${pkgdir}/usr
-}
-
-# vim:set sw=2 sts=2 et:

Copied: openvdb/repos/community-i686/PKGBUILD (from rev 249794, 
openvdb/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD                             (rev 0)
+++ community-i686/PKGBUILD     2017-08-10 22:13:04 UTC (rev 249795)
@@ -0,0 +1,51 @@
+# Maintainer : Sven-Hendrik Haase <s...@lutzhaase.com>
+
+# I would just like to take a minute here to state that this is probably one
+# of the worst packaged software packages that I have ever looked at.
+# The Makefile has defaults set to the upstream developers' specific systems
+# as well as other oddities.
+
+pkgname=openvdb
+pkgver=3.2.0
+pkgrel=4
+pkgdesc='A large suite of tools for the efficient storage and manipulation of 
sparse volumetric data discretized on three-dimensional grids'
+url='https://github.com/dreamworksanimation/openvdb'
+arch=('i686' 'x86_64')
+license=('MPL')
+depends=('openexr' 'boost-libs' 'intel-tbb' 'zlib' 'jemalloc' 'blosc')
+makedepends=('doxygen' 'boost' 'python2' 'log4cplus' 'python2-numpy' 
'texlive-core' 'ghostscript')
+optdepends=('python2-numpy: Python module'
+            'log4cplus: for vdb_print')
+source=("https://github.com/dreamworksanimation/openvdb/archive/v${pkgver}.tar.gz";)
+sha512sums=('df9a4895b219aae3b5a9616c34eb846d565877ff76648405691f0c903507f6faba94e8eba9173423b50cb5cef80f3ec500a9f70977cb7161701d39fd105abc91')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
+
+  make all \
+    OPENVDB_ENABLE_3_ABI_COMPATIBLE=ON \
+    PYTHON_VERSION='2.7' \
+    CPPUNIT_INCL_DIR='' \
+    HDSO='/usr' \
+    PYTHON_INCL_DIR=/usr/include/python2.7 \
+    PYTHON_LIB_DIR=/usr/lib \
+    EXR_LIB_DIR=/usr/lib \
+    ILMBASE_LIB_DIR=/usr/lib \
+    NUMPY_INCL_DIR=/usr/lib/python2.7/site-packages/numpy/core/include/numpy \
+    GLFW_INCL_DIR='' \
+    BOOST_PYTHON_LIB_DIR=/usr/lib \
+    BOOST_PYTHON_LIB=-lboost_python
+
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
+
+  mkdir ${pkgdir}/usr
+  make install \
+    GLFW_INCL_DIR='' \
+    EPYDOC='' \
+    DESTDIR=${pkgdir}/usr
+}
+
+# vim:set sw=2 sts=2 et:

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD   2017-08-10 22:12:33 UTC (rev 249794)
+++ community-x86_64/PKGBUILD   2017-08-10 22:13:04 UTC (rev 249795)
@@ -1,50 +0,0 @@
-# Maintainer: Sven-Hendrik Haase <s...@lutzhaase.com>
-
-# I would just like to take a minute here to state that this is probably one
-# of the worst packaged software packages that I have ever looked at.
-# The Makefile has defaults set to the upstream developers' specific systems
-# as well as other oddities.
-
-pkgname=openvdb
-pkgver=3.2.0
-pkgrel=3
-pkgdesc='A large suite of tools for the efficient storage and manipulation of 
sparse volumetric data discretized on three-dimensional grids'
-url='https://github.com/dreamworksanimation/openvdb'
-arch=('i686' 'x86_64')
-license=('MPL')
-depends=('openexr' 'boost-libs' 'intel-tbb' 'zlib' 'jemalloc' 'blosc')
-makedepends=('doxygen' 'boost' 'python2' 'log4cplus' 'epydoc' 'python2-numpy' 
'texlive-core' 'ghostscript' 'epydoc')
-optdepends=('python2-numpy: Python module')
-source=("https://github.com/dreamworksanimation/openvdb/archive/v${pkgver}.tar.gz";)
-sha512sums=('df9a4895b219aae3b5a9616c34eb846d565877ff76648405691f0c903507f6faba94e8eba9173423b50cb5cef80f3ec500a9f70977cb7161701d39fd105abc91')
-
-build() {
-  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
-
-  make all \
-    OPENVDB_ENABLE_3_ABI_COMPATIBLE=ON \
-    PYTHON_VERSION='2.7' \
-    CPPUNIT_INCL_DIR='' \
-    HDSO='/usr' \
-    PYTHON_INCL_DIR=/usr/include/python2.7 \
-    PYTHON_LIB_DIR=/usr/lib \
-    EXR_LIB_DIR=/usr/lib \
-    ILMBASE_LIB_DIR=/usr/lib \
-    NUMPY_INCL_DIR=/usr/lib/python2.7/site-packages/numpy/core/include/numpy \
-    GLFW_INCL_DIR='' \
-    BOOST_PYTHON_LIB_DIR=/usr/lib \
-    BOOST_PYTHON_LIB=-lboost_python
-
-}
-
-package() {
-  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
-
-  mkdir ${pkgdir}/usr
-  make install \
-    GLFW_INCL_DIR='' \
-    EPYDOC=/usr/bin/epydoc \
-    DESTDIR=${pkgdir}/usr
-}
-
-# vim:set sw=2 sts=2 et:

Copied: openvdb/repos/community-x86_64/PKGBUILD (from rev 249794, 
openvdb/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD                           (rev 0)
+++ community-x86_64/PKGBUILD   2017-08-10 22:13:04 UTC (rev 249795)
@@ -0,0 +1,51 @@
+# Maintainer : Sven-Hendrik Haase <s...@lutzhaase.com>
+
+# I would just like to take a minute here to state that this is probably one
+# of the worst packaged software packages that I have ever looked at.
+# The Makefile has defaults set to the upstream developers' specific systems
+# as well as other oddities.
+
+pkgname=openvdb
+pkgver=3.2.0
+pkgrel=4
+pkgdesc='A large suite of tools for the efficient storage and manipulation of 
sparse volumetric data discretized on three-dimensional grids'
+url='https://github.com/dreamworksanimation/openvdb'
+arch=('i686' 'x86_64')
+license=('MPL')
+depends=('openexr' 'boost-libs' 'intel-tbb' 'zlib' 'jemalloc' 'blosc')
+makedepends=('doxygen' 'boost' 'python2' 'log4cplus' 'python2-numpy' 
'texlive-core' 'ghostscript')
+optdepends=('python2-numpy: Python module'
+            'log4cplus: for vdb_print')
+source=("https://github.com/dreamworksanimation/openvdb/archive/v${pkgver}.tar.gz";)
+sha512sums=('df9a4895b219aae3b5a9616c34eb846d565877ff76648405691f0c903507f6faba94e8eba9173423b50cb5cef80f3ec500a9f70977cb7161701d39fd105abc91')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
+
+  make all \
+    OPENVDB_ENABLE_3_ABI_COMPATIBLE=ON \
+    PYTHON_VERSION='2.7' \
+    CPPUNIT_INCL_DIR='' \
+    HDSO='/usr' \
+    PYTHON_INCL_DIR=/usr/include/python2.7 \
+    PYTHON_LIB_DIR=/usr/lib \
+    EXR_LIB_DIR=/usr/lib \
+    ILMBASE_LIB_DIR=/usr/lib \
+    NUMPY_INCL_DIR=/usr/lib/python2.7/site-packages/numpy/core/include/numpy \
+    GLFW_INCL_DIR='' \
+    BOOST_PYTHON_LIB_DIR=/usr/lib \
+    BOOST_PYTHON_LIB=-lboost_python
+
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
+
+  mkdir ${pkgdir}/usr
+  make install \
+    GLFW_INCL_DIR='' \
+    EPYDOC='' \
+    DESTDIR=${pkgdir}/usr
+}
+
+# vim:set sw=2 sts=2 et:

Reply via email to