Date: Saturday, August 12, 2017 @ 20:00:20
  Author: muflone
Revision: 250015

archrelease: copy trunk to community-any

Added:
  spyder/repos/community-any/PKGBUILD
    (from rev 250014, spyder/trunk/PKGBUILD)
  spyder/repos/community-any/bug_51437_spyder2.patch
    (from rev 250014, spyder/trunk/bug_51437_spyder2.patch)
  spyder/repos/community-any/bug_53489_python2-optional-nbconvert.patch
    (from rev 250014, spyder/trunk/bug_53489_python2-optional-nbconvert.patch)
  spyder/repos/community-any/bug_54508_missing_pyqt4_qtwebkit.patch
    (from rev 250014, spyder/trunk/bug_54508_missing_pyqt4_qtwebkit.patch)
  spyder/repos/community-any/python2.patch
    (from rev 250014, spyder/trunk/python2.patch)
  spyder/repos/community-any/spyder2.install
    (from rev 250014, spyder/trunk/spyder2.install)
Deleted:
  spyder/repos/community-any/PKGBUILD
  spyder/repos/community-any/bug_54508_missing_pyqt4_qtwebkit.patch
  spyder/repos/community-any/python2-optional-nbconvert.patch
  spyder/repos/community-any/python2-pep8.patch
  spyder/repos/community-any/python2.patch
  spyder/repos/community-any/python3-pep8.patch

--------------------------------------------+
 PKGBUILD                                   |  196 ++++++++++++++-------------
 bug_51437_spyder2.patch                    |   51 +++++++
 bug_53489_python2-optional-nbconvert.patch |   12 +
 bug_54508_missing_pyqt4_qtwebkit.patch     |   48 +++---
 python2-optional-nbconvert.patch           |   12 -
 python2-pep8.patch                         |   45 ------
 python2.patch                              |   46 ++----
 python3-pep8.patch                         |   45 ------
 spyder2.install                            |    8 +
 9 files changed, 219 insertions(+), 244 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2017-08-12 19:59:48 UTC (rev 250014)
+++ PKGBUILD    2017-08-12 20:00:20 UTC (rev 250015)
@@ -1,89 +0,0 @@
-# $Id$
-# Maintainer: Muflone http://www.muflone.com/contacts/english/
-# Contributor: Francois Boulogne <fboulo...@april.org>
-# Contributor: TDY <t...@gmx.com>
-
-pkgbase='spyder'
-pkgname=('spyder' 'spyder3')
-pkgver=3.1.4
-pkgrel=2
-pkgdesc='Scientific PYthon Development EnviRonment providing MATLAB-like 
features.'
-makedepends=('python2-setuptools' 'python-setuptools' 'python-sphinx' 
'python2-sphinx')
-arch=('any')
-url='https://github.com/spyder-ide/spyder/'
-license=('MIT')
-source=("${pkgbase}-${pkgver}.tar.gz"::"https://github.com/spyder-ide/${pkgbase}/archive/v${pkgver}.tar.gz";
-        "python2.patch"
-        "python2-optional-nbconvert.patch"
-        "python2-pep8.patch"
-        "python3-pep8.patch"
-        "bug_54508_missing_pyqt4_qtwebkit.patch")
-sha256sums=('bcd75ebe65309a5f9184eedc59c415fe0d09e9b54a2b51bc31199a6095cd0b85'
-            '4fb415fb358371da4a8b9524712de9338d391eed3bdabc5e217cf54f558771b5'
-            'f6afdd08971a2022649af0be70cac67aa4d95fff06ade57f708693cffe073528'
-            'dbebf909bf59027d22247e3e3c1736b5ec9337a879358f8117a967bb03e913b2'
-            'f4eba4c414e655f0f2797e9864aa199607a6706f6b245aca56a54b250febc382'
-            '28d4aa8938d809c299ab6bf6b00a2f82677f9a98a9763b7127970881b76276f5')
-
-prepare() {
-  cd "${pkgbase}-${pkgver}"
-  # Forced QT API to pyqt5 (see https://bugs.archlinux.org/task/54508)
-  patch -p1 -i "../bug_54508_missing_pyqt4_qtwebkit.patch"
-}
-
-package_spyder() {
-  pkgdesc='Scientific PYthon Development EnviRonment providing MATLAB-like 
features for Python 2.x series.'
-  depends=('python2-pyqt5' 'qt5-webkit' 'python2-qtconsole' 'python2-qtpy' 
'python2-qtawesome'
-           'python2-pyflakes' 'python2-pyzmq' 'python2-pygments' 
'python2-psutil' 'python2-pickleshare'
-           'python2-rope' 'python2-jedi' 'python2-pylint' 
'python2-pycodestyle' 'python2-sphinx'
-           'icu' 'gtk-update-icon-cache')
-  optdepends=('python2-numpy: N-dimensional arrays'
-              'python2-scipy: signal/image processing'
-              'python2-h5py: HDF5 support'
-              'python2-matplotlib: interactive 2D/3D data plotting'
-              'python2-sympy: symbolic mathematics for the IPython console'
-              'python2-pandas: view and edit DataFrames and Series in the 
Variable Explorer')
-  [ -d "build" ] && rm -rf "build"
-  cp -r "${pkgbase}-${pkgver}" build
-  cd build
-  patch -p1 -i "../python2.patch"
-  patch -p1 -i "../python2-pep8.patch"
-  patch -p1 -i "../python2-optional-nbconvert.patch"
-  python2 setup.py build
-  python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
-  # Install license file
-  install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-  # Install icon and desktop file
-  install -D -m644 "scripts/${pkgname}.desktop" 
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
-  install -D -m644 "spyder/images/spyder.svg" 
"${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
-  # Remove useless spyder_win_post_install script
-  rm -f "${pkgdir}/usr/bin/spyder_win_post_install.py"
-}
-
-package_spyder3() {
-  pkgdesc='Scientific PYthon Development EnviRonment providing MATLAB-like 
features for Python 3.x series.'
-  depends=('python-pyqt5' 'qt5-webkit' 'python-qtconsole' 'python-qtpy' 
'python-qtawesome'
-           'python-pyflakes' 'python-pyzmq' 'python-pygments' 'python-psutil' 
'python-pickleshare'
-           'jupyter' 'jupyter-nbconvert'
-           'python-rope' 'python-jedi' 'python-pylint' 'python-pycodestyle' 
'python-sphinx'
-           'icu' 'gtk-update-icon-cache')
-  optdepends=('python-numpy: N-dimensional arrays'
-              'python-scipy: signal/image processing'
-              'python-h5py: HDF5 support'
-              'python-matplotlib: interactive 2D/3D data plotting'
-              'python-sympy: symbolic mathematics for the IPython console'
-              'python-pandas: view and edit DataFrames and Series in the 
Variable Explorer')
-  [ -d "build" ] && rm -rf "build"
-  cp -r "${pkgbase}-${pkgver}" build
-  cd build
-  patch -p1 -i "../python3-pep8.patch"
-  python3 setup.py build
-  python3 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
-  # Install license file
-  install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-  # Install icon and desktop file
-  install -D -m644 "scripts/${pkgname}.desktop" 
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
-  install -D -m644 "spyder/images/spyder.svg" 
"${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
-  # Remove useless spyder_win_post_install script
-  rm -f "${pkgdir}/usr/bin/spyder_win_post_install.py"
-}

Copied: spyder/repos/community-any/PKGBUILD (from rev 250014, 
spyder/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2017-08-12 20:00:20 UTC (rev 250015)
@@ -0,0 +1,107 @@
+# $Id$
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Francois Boulogne <fboulo...@april.org>
+# Contributor: TDY <t...@gmx.com>
+
+pkgbase='spyder'
+pkgname=('spyder2' 'spyder3')
+pkgver=3.2.0
+pkgrel=1
+pkgdesc='Scientific PYthon Development EnviRonment providing MATLAB-like 
features.'
+makedepends=('python2-setuptools' 'python-setuptools' 'python-sphinx' 
'python2-sphinx')
+arch=('any')
+url='https://github.com/spyder-ide/spyder/'
+license=('MIT')
+source=("${pkgbase}-${pkgver}.tar.gz"::"https://github.com/spyder-ide/${pkgbase}/archive/v${pkgver}.tar.gz";
+        "python2.patch"
+        "bug_53489_python2-optional-nbconvert.patch"
+        "bug_54508_missing_pyqt4_qtwebkit.patch"
+        "bug_51437_spyder2.patch")
+sha256sums=('5dea4755e68ee20377d3ab090ffa6a3739bf8f8da05943acd558434a1f3622a3'
+            '84b8d5e9640d5d347ac4564130f217368cc3f823de30b458d467a05e60bbc8da'
+            '7486faba90da062ef8da6912bfabd22b59343b1275758f04e4a41df2b3b8eec0'
+            '28d4aa8938d809c299ab6bf6b00a2f82677f9a98a9763b7127970881b76276f5'
+            'ae077fc95bc6861402a90c55bc11b3a2dda3fde4005e9d7ad65df3b1a120d8c1')
+
+prepare() {
+  cd "${pkgbase}-${pkgver}"
+  # Forced QT API to pyqt5 (see https://bugs.archlinux.org/task/54508)
+  patch -p1 -i "../bug_54508_missing_pyqt4_qtwebkit.patch"
+  # Replace spyder with spyder2 (see https://bugs.archlinux.org/task/51437)
+  patch -p1 -i "../bug_51437_spyder2.patch"
+  mv "img_src/spyder.png" "img_src/spyder2.png"
+  mv "scripts/spyder.desktop" "scripts/spyder2.desktop"
+
+  # Prepare sources for spyder2 build
+  cp -r "${srcdir}/${pkgbase}-${pkgver}" "${srcdir}/spyder2-${pkgver}"
+  cd "${srcdir}/spyder2-${pkgver}"
+  patch -p1 -i "../python2.patch"
+  patch -p1 -i "../bug_53489_python2-optional-nbconvert.patch"
+
+  # Prepare sources for spyder3 build
+  cp -r "${srcdir}/${pkgbase}-${pkgver}" "${srcdir}/spyder3-${pkgver}"
+  cd "${srcdir}/spyder3-${pkgver}"
+}
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  python2 setup.py build
+
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  python3 setup.py build
+}
+
+package_spyder2() {
+  pkgdesc='Scientific PYthon Development EnviRonment providing MATLAB-like 
features for Python 2.x series.'
+  depends=('python2-pyqt5' 'qt5-webkit' 'python2-qtconsole' 'python2-qtpy' 
'python2-qtawesome'
+           'python2-pyflakes' 'python2-pyzmq' 'python2-pygments' 
'python2-psutil' 'python2-pickleshare'
+           'python2-rope' 'python2-jedi' 'python2-pylint' 
'python2-pycodestyle' 'python2-sphinx'
+           'icu' 'gtk-update-icon-cache')
+  provides=('spyder')
+  conflicts=('spyder')
+  replaces=('spyder')
+  optdepends=('python2-numpy: N-dimensional arrays'
+              'python2-scipy: signal/image processing'
+              'python2-h5py: HDF5 support'
+              'python2-matplotlib: interactive 2D/3D data plotting'
+              'python2-sympy: symbolic mathematics for the IPython console'
+              'python2-pandas: view and edit DataFrames and Series in the 
Variable Explorer')
+  install="${pkgname}.install"
+
+  cd "${pkgname}-${pkgver}"
+  python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+  # Install license file
+  install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+  # Install icon and desktop file
+  install -D -m644 "spyder/images/spyder.svg" 
"${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+  # Change main executable name
+  mv "${pkgdir}/usr/bin/spyder" "${pkgdir}/usr/bin/${pkgname}"
+  # Remove useless spyder_win_post_install script
+  rm -f "${pkgdir}/usr/bin/spyder_win_post_install.py"
+}
+
+package_spyder3() {
+  pkgdesc='Scientific PYthon Development EnviRonment providing MATLAB-like 
features for Python 3.x series.'
+  depends=('python-pyqt5' 'qt5-webkit' 'python-qtconsole' 'python-qtpy' 
'python-qtawesome'
+           'python-pyflakes' 'python-pyzmq' 'python-pygments' 'python-psutil' 
'python-pickleshare'
+           'jupyter' 'jupyter-nbconvert'
+           'python-rope' 'python-jedi' 'python-pylint' 'python-pycodestyle' 
'python-sphinx'
+           'icu' 'gtk-update-icon-cache')
+  optdepends=('python-numpy: N-dimensional arrays'
+              'python-scipy: signal/image processing'
+              'python-h5py: HDF5 support'
+              'python-matplotlib: interactive 2D/3D data plotting'
+              'python-sympy: symbolic mathematics for the IPython console'
+              'python-pandas: view and edit DataFrames and Series in the 
Variable Explorer')
+
+  cd "${pkgname}-${pkgver}"
+  python3 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+  # Install license file
+  install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+  # Install icon and desktop file
+  install -D -m644 "spyder/images/spyder.svg" 
"${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+  # Remove useless spyder_win_post_install script
+  rm -f "${pkgdir}/usr/bin/spyder_win_post_install.py"
+  # Add symlink /usr/bin/spyder to /usr/bin/spyder3 (see 
https://bugs.archlinux.org/task/51437)
+  ln -s "/usr/bin/spyder3" "${pkgdir}/usr/bin/spyder"
+}

Copied: spyder/repos/community-any/bug_51437_spyder2.patch (from rev 250014, 
spyder/trunk/bug_51437_spyder2.patch)
===================================================================
--- bug_51437_spyder2.patch                             (rev 0)
+++ bug_51437_spyder2.patch     2017-08-12 20:00:20 UTC (rev 250015)
@@ -0,0 +1,51 @@
+diff -Naur spyder-3.1.4.orig/scripts/spyder3.desktop 
spyder-3.1.4/scripts/spyder3.desktop
+--- spyder-3.1.4.orig/scripts/spyder3.desktop  2017-04-24 02:30:23.000000000 
+0200
++++ spyder-3.1.4/scripts/spyder3.desktop       2017-08-12 20:49:55.349203674 
+0200
+@@ -1,9 +1,8 @@
+ [Desktop Entry]
+ Version=1.0
+ Type=Application
+-Name=Spyder3
+-GenericName=Spyder3
+-Comment=Scientific PYthon Development EnviRonment - Python3
++Name=Spyder for Python 3.x
++Comment=Scientific PYthon Development EnviRonment - Python 3.x
+ TryExec=spyder3
+ Exec=spyder3 %F
+ Categories=Development;Science;IDE;Qt;
+diff -Naur spyder-3.1.4.orig/scripts/spyder.desktop 
spyder-3.1.4/scripts/spyder.desktop
+--- spyder-3.1.4.orig/scripts/spyder.desktop   2017-04-24 02:30:23.000000000 
+0200
++++ spyder-3.1.4/scripts/spyder.desktop        2017-08-12 20:49:54.005881501 
+0200
+@@ -1,13 +1,12 @@
+ [Desktop Entry]
+ Version=1.0
+ Type=Application
+-Name=Spyder
+-GenericName=Spyder
+-Comment=Scientific PYthon Development EnviRonment
+-TryExec=spyder
+-Exec=spyder %F
++Name=Spyder for Python 2.x
++Comment=Scientific PYthon Development EnviRonment - Python 2.x
++TryExec=spyder2
++Exec=spyder2 %F
+ Categories=Development;Science;IDE;Qt;
+-Icon=spyder
++Icon=spyder2
+ Terminal=false
+ StartupNotify=true
+ MimeType=text/x-python;
+diff -Naur spyder-3.1.4.orig/setup.py spyder-3.1.4/setup.py
+--- spyder-3.1.4.orig/setup.py 2017-04-24 02:30:23.000000000 +0200
++++ spyder-3.1.4/setup.py      2017-08-12 20:34:09.464160097 +0200
+@@ -82,8 +82,8 @@
+                           ('share/pixmaps', ['img_src/spyder3.png']),
+                           ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
+         else:
+-            data_files = [('share/applications', ['scripts/spyder.desktop']),
+-                          ('share/pixmaps', ['img_src/spyder.png'])]
++            data_files = [('share/applications', ['scripts/spyder2.desktop']),
++                          ('share/pixmaps', ['img_src/spyder2.png'])]
+     elif os.name == 'nt':
+         data_files = [('scripts', ['img_src/spyder.ico',
+                                    'img_src/spyder_reset.ico'])]

Copied: spyder/repos/community-any/bug_53489_python2-optional-nbconvert.patch 
(from rev 250014, spyder/trunk/bug_53489_python2-optional-nbconvert.patch)
===================================================================
--- bug_53489_python2-optional-nbconvert.patch                          (rev 0)
+++ bug_53489_python2-optional-nbconvert.patch  2017-08-12 20:00:20 UTC (rev 
250015)
@@ -0,0 +1,12 @@
+diff -Naur spyder-3.2.0.orig/spyder/plugins/editor.py 
spyder-3.2.0/spyder/plugins/editor.py
+--- spyder-3.2.0.orig/spyder/plugins/editor.py 2017-07-24 05:03:40.000000000 
+0200
++++ spyder-3.2.0/spyder/plugins/editor.py      2017-08-12 21:45:09.455757449 
+0200
+@@ -56,7 +56,7 @@
+ # Dependencies
+ NBCONVERT_REQVER = ">=4.0"
+ dependencies.add("nbconvert", _("Manipulate Jupyter notebooks on the Editor"),
+-                 required_version=NBCONVERT_REQVER)
++                 required_version=NBCONVERT_REQVER, optional=True)
+ 
+ 
+ def _load_all_breakpoints():

Deleted: bug_54508_missing_pyqt4_qtwebkit.patch
===================================================================
--- bug_54508_missing_pyqt4_qtwebkit.patch      2017-08-12 19:59:48 UTC (rev 
250014)
+++ bug_54508_missing_pyqt4_qtwebkit.patch      2017-08-12 20:00:20 UTC (rev 
250015)
@@ -1,24 +0,0 @@
-diff -Naur spyder-3.1.4.orig/scripts/spyder spyder-3.1.4/scripts/spyder
---- spyder-3.1.4.orig/scripts/spyder   2017-04-24 02:30:23.000000000 +0200
-+++ spyder-3.1.4/scripts/spyder        2017-07-09 18:47:22.072698407 +0200
-@@ -1,3 +1,8 @@
- #!/usr/bin/env python
-+
-+# Forced QT API to pyqt5 (see https://bugs.archlinux.org/task/54508)
-+import os
-+os.environ['QT_API'] = 'pyqt5'
-+
- from spyder.app import start
- start.main()
-diff -Naur spyder-3.1.4.orig/scripts/spyder3 spyder-3.1.4/scripts/spyder3
---- spyder-3.1.4.orig/scripts/spyder3  2017-04-24 02:30:23.000000000 +0200
-+++ spyder-3.1.4/scripts/spyder3       2017-07-09 18:47:27.659425267 +0200
-@@ -1,3 +1,8 @@
- #! /usr/bin/python3
-+
-+# Forced QT API to pyqt5 (see https://bugs.archlinux.org/task/54508)
-+import os
-+os.environ['QT_API'] = 'pyqt5'
-+
- from spyder.app import start
- start.main()

Copied: spyder/repos/community-any/bug_54508_missing_pyqt4_qtwebkit.patch (from 
rev 250014, spyder/trunk/bug_54508_missing_pyqt4_qtwebkit.patch)
===================================================================
--- bug_54508_missing_pyqt4_qtwebkit.patch                              (rev 0)
+++ bug_54508_missing_pyqt4_qtwebkit.patch      2017-08-12 20:00:20 UTC (rev 
250015)
@@ -0,0 +1,24 @@
+diff -Naur spyder-3.1.4.orig/scripts/spyder spyder-3.1.4/scripts/spyder
+--- spyder-3.1.4.orig/scripts/spyder   2017-04-24 02:30:23.000000000 +0200
++++ spyder-3.1.4/scripts/spyder        2017-07-09 18:47:22.072698407 +0200
+@@ -1,3 +1,8 @@
+ #!/usr/bin/env python
++
++# Forced QT API to pyqt5 (see https://bugs.archlinux.org/task/54508)
++import os
++os.environ['QT_API'] = 'pyqt5'
++
+ from spyder.app import start
+ start.main()
+diff -Naur spyder-3.1.4.orig/scripts/spyder3 spyder-3.1.4/scripts/spyder3
+--- spyder-3.1.4.orig/scripts/spyder3  2017-04-24 02:30:23.000000000 +0200
++++ spyder-3.1.4/scripts/spyder3       2017-07-09 18:47:27.659425267 +0200
+@@ -1,3 +1,8 @@
+ #! /usr/bin/python3
++
++# Forced QT API to pyqt5 (see https://bugs.archlinux.org/task/54508)
++import os
++os.environ['QT_API'] = 'pyqt5'
++
+ from spyder.app import start
+ start.main()

Deleted: python2-optional-nbconvert.patch
===================================================================
--- python2-optional-nbconvert.patch    2017-08-12 19:59:48 UTC (rev 250014)
+++ python2-optional-nbconvert.patch    2017-08-12 20:00:20 UTC (rev 250015)
@@ -1,12 +0,0 @@
-diff -Naur spyder-3.1.4.orig/spyder/config/ipython.py 
spyder-3.1.4/spyder/config/ipython.py
---- spyder-3.1.4.orig/spyder/config/ipython.py 2017-04-24 02:30:23.000000000 
+0200
-+++ spyder-3.1.4/spyder/config/ipython.py      2017-05-07 02:50:25.640734369 
+0200
-@@ -23,7 +23,7 @@
- dependencies.add("qtconsole", _("Integrate the IPython console"),
-                  required_version=QTCONSOLE_REQVER)
- dependencies.add("nbconvert", _("Manipulate Jupyter notebooks on the Editor"),
--                 required_version=NBCONVERT_REQVER)
-+                 required_version=NBCONVERT_REQVER, optional=True)
- 
- 
- # Auxiliary functions

Deleted: python2-pep8.patch
===================================================================
--- python2-pep8.patch  2017-08-12 19:59:48 UTC (rev 250014)
+++ python2-pep8.patch  2017-08-12 20:00:20 UTC (rev 250015)
@@ -1,45 +0,0 @@
-diff -Naur spyder-3.1.1.orig/spyder/plugins/editor.py 
spyder-3.1.1.pep8-python2/spyder/plugins/editor.py
---- spyder-3.1.1.orig/spyder/plugins/editor.py 2017-01-22 18:28:03.000000000 
+0100
-+++ spyder-3.1.1.pep8-python2/spyder/plugins/editor.py 2017-01-22 
23:40:42.426230374 +0100
-@@ -225,7 +225,7 @@
-         pep8_label = QLabel(_("<i>(Refer to the {} 
page)</i>").format(pep_url))
-         pep8_label.setOpenExternalLinks(True)
-         is_pyflakes = codeanalysis.is_pyflakes_installed()
--        is_pep8 = codeanalysis.get_checker_executable('pep8') is not None
-+        is_pep8 = codeanalysis.get_checker_executable('pycodestyle') is not 
None
-         pyflakes_box = newcb(_("Real-time code analysis"),
-                       'code_analysis/pyflakes', default=True,
-                       tip=_("<p>If enabled, Python source code will be 
analyzed "
-diff -Naur spyder-3.1.1.orig/spyder/utils/codeanalysis.py 
spyder-3.1.1.pep8-python2/spyder/utils/codeanalysis.py
---- spyder-3.1.1.orig/spyder/utils/codeanalysis.py     2017-01-22 
18:28:03.000000000 +0100
-+++ spyder-3.1.1.pep8-python2/spyder/utils/codeanalysis.py     2017-01-22 
23:44:40.107465175 +0100
-@@ -92,7 +92,7 @@
-                  required_version=PYFLAKES_REQVER)
- 
- PEP8_REQVER = '>=0.6'
--dependencies.add("pep8", _("Real-time code style analysis on the Editor"),
-+dependencies.add("pycodestyle", _("Real-time code style analysis on the 
Editor"),
-                  required_version=PEP8_REQVER)
- 
- 
-@@ -167,7 +167,7 @@
- def check_with_pep8(source_code, filename=None):
-     """Check source code with pep8"""
-     try:
--        args = get_checker_executable('pep8')
-+        args = get_checker_executable('pycodestyle2')
-         results = check(args, source_code, filename=filename, options=['-r'])
-     except Exception:
-         # Never return None to avoid lock in spyder/widgets/editor.py
-diff -Naur spyder-3.1.1.orig/spyder/widgets/editor.py 
spyder-3.1.1.pep8-python2/spyder/widgets/editor.py
---- spyder-3.1.1.orig/spyder/widgets/editor.py 2017-01-22 18:28:03.000000000 
+0100
-+++ spyder-3.1.1.pep8-python2/spyder/widgets/editor.py 2017-01-22 
23:45:29.697031996 +0100
-@@ -199,7 +199,7 @@
-         """Run code analysis"""
-         run_pyflakes = run_pyflakes and codeanalysis.is_pyflakes_installed()
-         run_pep8 = run_pep8 and\
--                   codeanalysis.get_checker_executable('pep8') is not None
-+                   codeanalysis.get_checker_executable('pycodestyle') is not 
None
-         self.pyflakes_results = []
-         self.pep8_results = []
-         if self.editor.is_python():

Deleted: python2.patch
===================================================================
--- python2.patch       2017-08-12 19:59:48 UTC (rev 250014)
+++ python2.patch       2017-08-12 20:00:20 UTC (rev 250015)
@@ -1,29 +0,0 @@
-diff -Naur spyder-3.1.1.orig/scripts/spyder spyder-3.1.1/scripts/spyder
---- spyder-3.1.1.orig/scripts/spyder   2017-01-22 18:28:03.000000000 +0100
-+++ spyder-3.1.1/scripts/spyder        2017-01-22 19:01:59.364263881 +0100
-@@ -1,3 +1,3 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- from spyder.app import start
- start.main()
-diff -Naur spyder-3.1.1.orig/spyder/app/restart.py 
spyder-3.1.1/spyder/app/restart.py
---- spyder-3.1.1.orig/spyder/app/restart.py    2017-01-22 18:28:03.000000000 
+0100
-+++ spyder-3.1.1/spyder/app/restart.py 2017-01-22 19:00:54.574451747 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- # -*- coding: utf-8 -*-
- #
- # Copyright © Spyder Project Contributors
-diff -Naur spyder-3.1.1.orig/spyder_pylint/widgets/pylintgui.py 
spyder-3.1.1/spyder_pylint/widgets/pylintgui.py
---- spyder-3.1.1.orig/spyder_pylint/widgets/pylintgui.py       2017-01-22 
18:28:03.000000000 +0100
-+++ spyder-3.1.1/spyder_pylint/widgets/pylintgui.py    2017-01-22 
19:05:13.522630971 +0100
-@@ -47,7 +47,7 @@
-     _ = gettext.gettext
- 
- 
--PYLINT = 'pylint'
-+PYLINT = 'pylint2'
- if PY3:
-     if programs.find_program('pylint3'):
-         PYLINT = 'pylint3'

Copied: spyder/repos/community-any/python2.patch (from rev 250014, 
spyder/trunk/python2.patch)
===================================================================
--- python2.patch                               (rev 0)
+++ python2.patch       2017-08-12 20:00:20 UTC (rev 250015)
@@ -0,0 +1,17 @@
+diff -Naur spyder-3.2.0.orig/scripts/spyder spyder-3.2.0/scripts/spyder
+--- spyder-3.2.0.orig/scripts/spyder   2017-07-24 05:03:40.000000000 +0200
++++ spyder-3.2.0/scripts/spyder        2017-08-12 21:22:11.230212853 +0200
+@@ -1,3 +1,3 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ from spyder.app import start
+ start.main()
+diff -Naur spyder-3.2.0.orig/spyder/app/restart.py 
spyder-3.2.0/spyder/app/restart.py
+--- spyder-3.2.0.orig/spyder/app/restart.py    2017-07-24 05:03:40.000000000 
+0200
++++ spyder-3.2.0/spyder/app/restart.py 2017-08-12 21:22:11.230212853 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+ #
+ # Copyright © Spyder Project Contributors

Deleted: python3-pep8.patch
===================================================================
--- python3-pep8.patch  2017-08-12 19:59:48 UTC (rev 250014)
+++ python3-pep8.patch  2017-08-12 20:00:20 UTC (rev 250015)
@@ -1,45 +0,0 @@
-diff -Naur spyder-3.1.1.orig/spyder/plugins/editor.py 
spyder-3.1.1.pep8-python3/spyder/plugins/editor.py
---- spyder-3.1.1.orig/spyder/plugins/editor.py 2017-01-22 18:28:03.000000000 
+0100
-+++ spyder-3.1.1.pep8-python3/spyder/plugins/editor.py 2017-01-22 
23:49:13.015095511 +0100
-@@ -225,7 +225,7 @@
-         pep8_label = QLabel(_("<i>(Refer to the {} 
page)</i>").format(pep_url))
-         pep8_label.setOpenExternalLinks(True)
-         is_pyflakes = codeanalysis.is_pyflakes_installed()
--        is_pep8 = codeanalysis.get_checker_executable('pep8') is not None
-+        is_pep8 = codeanalysis.get_checker_executable('pycodestyle') is not 
None
-         pyflakes_box = newcb(_("Real-time code analysis"),
-                       'code_analysis/pyflakes', default=True,
-                       tip=_("<p>If enabled, Python source code will be 
analyzed "
-diff -Naur spyder-3.1.1.orig/spyder/utils/codeanalysis.py 
spyder-3.1.1.pep8-python3/spyder/utils/codeanalysis.py
---- spyder-3.1.1.orig/spyder/utils/codeanalysis.py     2017-01-22 
18:28:03.000000000 +0100
-+++ spyder-3.1.1.pep8-python3/spyder/utils/codeanalysis.py     2017-01-22 
23:49:56.851384285 +0100
-@@ -92,7 +92,7 @@
-                  required_version=PYFLAKES_REQVER)
- 
- PEP8_REQVER = '>=0.6'
--dependencies.add("pep8", _("Real-time code style analysis on the Editor"),
-+dependencies.add("pycodestyle", _("Real-time code style analysis on the 
Editor"),
-                  required_version=PEP8_REQVER)
- 
- 
-@@ -167,7 +167,7 @@
- def check_with_pep8(source_code, filename=None):
-     """Check source code with pep8"""
-     try:
--        args = get_checker_executable('pep8')
-+        args = get_checker_executable('pycodestyle')
-         results = check(args, source_code, filename=filename, options=['-r'])
-     except Exception:
-         # Never return None to avoid lock in spyder/widgets/editor.py
-diff -Naur spyder-3.1.1.orig/spyder/widgets/editor.py 
spyder-3.1.1.pep8-python3/spyder/widgets/editor.py
---- spyder-3.1.1.orig/spyder/widgets/editor.py 2017-01-22 18:28:03.000000000 
+0100
-+++ spyder-3.1.1.pep8-python3/spyder/widgets/editor.py 2017-01-22 
23:50:13.531240654 +0100
-@@ -199,7 +199,7 @@
-         """Run code analysis"""
-         run_pyflakes = run_pyflakes and codeanalysis.is_pyflakes_installed()
-         run_pep8 = run_pep8 and\
--                   codeanalysis.get_checker_executable('pep8') is not None
-+                   codeanalysis.get_checker_executable('pycodestyle') is not 
None
-         self.pyflakes_results = []
-         self.pep8_results = []
-         if self.editor.is_python():

Copied: spyder/repos/community-any/spyder2.install (from rev 250014, 
spyder/trunk/spyder2.install)
===================================================================
--- spyder2.install                             (rev 0)
+++ spyder2.install     2017-08-12 20:00:20 UTC (rev 250015)
@@ -0,0 +1,8 @@
+post_install() {
+  echo "==> The /usr/bin/spyder executable is now a symlink for spyder3 (in 
the spyder3 package)."
+  echo "==> The executable file for spyder2 is now /usr/bin/spyder2"
+}
+
+post_upgrade() {
+  post_install
+}

Reply via email to