Date: Friday, February 2, 2018 @ 20:10:27
  Author: heftig
Revision: 315771

simplify

Modified:
  nvidia-lts/trunk/PKGBUILD
Deleted:
  nvidia-lts/trunk/nvidia-lts.install

--------------------+
 PKGBUILD           |   10 +++-------
 nvidia-lts.install |   15 ---------------
 2 files changed, 3 insertions(+), 22 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2018-02-02 20:03:14 UTC (rev 315770)
+++ PKGBUILD    2018-02-02 20:10:27 UTC (rev 315771)
@@ -11,12 +11,11 @@
 makedepends=("nvidia-utils=$pkgver" 'linux-lts>=4.14.16' 
'linux-lts-headers>=4.14.16')
 provides=('nvidia')
 license=('custom')
-install=nvidia-lts.install
 options=('!strip')
 
source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run";)
 
sha512sums=('02dbb790013f51b6e6945933d977366211f47cb62f7ff1b6b2f57bd40be7fc28d8e92f223155f21fcb9154b857133235e68f9e020d0d8079f5e9f676d15177d7')
 
-[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
+_pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
 
 prepare() {
     sh ${_pkg}.run --extract-only
@@ -39,12 +38,9 @@
       
"${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia-modeset.ko"
     install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia-drm.ko" \
       "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-drm.ko"
+    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia-uvm.ko" \
+      "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
 
-    if [[ "$CARCH" = "x86_64" ]]; then
-      install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia-uvm.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
-    fi
-
     gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/"*.ko
     install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
     echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"

Deleted: nvidia-lts.install
===================================================================
--- nvidia-lts.install  2018-02-02 20:03:14 UTC (rev 315770)
+++ nvidia-lts.install  2018-02-02 20:10:27 UTC (rev 315771)
@@ -1,15 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-4.14-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-4.14-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-4.14-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Reply via email to