Date: Friday, February 9, 2018 @ 11:16:20
  Author: arojas
Revision: 316509

archrelease: copy trunk to extra-x86_64

Added:
  phonon-gstreamer/repos/extra-x86_64/PKGBUILD
    (from rev 316508, phonon-gstreamer/trunk/PKGBUILD)
Deleted:
  phonon-gstreamer/repos/extra-x86_64/PKGBUILD

----------+
 PKGBUILD |  125 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 63 insertions(+), 62 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-02-09 11:15:52 UTC (rev 316508)
+++ PKGBUILD    2018-02-09 11:16:20 UTC (rev 316509)
@@ -1,62 +0,0 @@
-# $Id$
-# Maintainer: Andrea Scarpino <and...@archlinux.org>
-
-pkgbase=phonon-gstreamer
-pkgname=('phonon-qt4-gstreamer' 'phonon-qt5-gstreamer')
-pkgver=4.9.0
-pkgrel=3
-arch=('i686' 'x86_64')
-url='http://phonon.kde.org/'
-license=('LGPL')
-optdepends=('pulseaudio: PulseAudio support' 'gst-plugins-good: PulseAudio 
support and good codecs' 'gst-plugins-bad: additional codecs'
-       'gst-plugins-ugly: additional codecs' 'gst-libav: libav codec')
-makedepends=('gst-plugins-base' 'extra-cmake-modules' 'automoc4' 'phonon-qt4' 
'phonon-qt5' 'qt5-x11extras')
-source=("http://download.kde.org/stable/phonon/phonon-backend-gstreamer/${pkgver}/phonon-backend-gstreamer-${pkgver}.tar.xz";)
-md5sums=('b2b0ca327908948ce8cdba117e31bf80')
-
-prepare() {
-  mkdir build-qt4
-  mkdir build-qt5
-}
-
-build() {
-  cd build-qt4
-  cmake ../${pkgbase}-${pkgver} \
-    -DCMAKE_BUILD_TYPE=Release \
-    -DCMAKE_INSTALL_PREFIX=/usr \
-    -DCMAKE_SKIP_RPATH=ON \
-    -D__KDE_HAVE_GCC_VISIBILITY=NO \
-    -DCMAKE_INSTALL_LIBDIR=lib
-  make
-
-  cd ../build-qt5
-  cmake ../${pkgbase}-${pkgver} \
-    -DCMAKE_BUILD_TYPE=Release \
-    -DCMAKE_INSTALL_PREFIX=/usr \
-    -DCMAKE_SKIP_RPATH=ON \
-    -DCMAKE_INSTALL_LIBDIR=lib \
-    -D__KDE_HAVE_GCC_VISIBILITY=NO \
-    -DPHONON_BUILD_PHONON4QT5=ON
-  make
-}
-
-package_phonon-qt4-gstreamer() {
-  pkgdesc="Phonon GStreamer backend for Qt4"
-  depends=(gst-plugins-base phonon-qt4)
-  provides=(phonon-qt4-backend)
-
-  cd build-qt4
-  make DESTDIR="${pkgdir}" install
-
-# Conflict with -qt5
-  rm -r "$pkgdir"/usr/share/icons
-}
-
-package_phonon-qt5-gstreamer() {
-  pkgdesc="Phonon GStreamer backend for Qt5"
-  depends=(gst-plugins-base qt5-x11extras phonon-qt5)
-  provides=(phonon-qt5-backend)
-
-  cd build-qt5
-  make DESTDIR="${pkgdir}" install
-}

Copied: phonon-gstreamer/repos/extra-x86_64/PKGBUILD (from rev 316508, 
phonon-gstreamer/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-02-09 11:16:20 UTC (rev 316509)
@@ -0,0 +1,63 @@
+# $Id$
+# Maintainer: Antonio Rojas <aro...@archlinux.org>
+# Contributor: Andrea Scarpino <and...@archlinux.org>
+
+pkgbase=phonon-gstreamer
+pkgname=(phonon-qt4-gstreamer phonon-qt5-gstreamer)
+pkgver=4.9.0
+pkgrel=4
+arch=(x86_64)
+url='http://phonon.kde.org/'
+license=(LGPL)
+optdepends=('pulseaudio: PulseAudio support' 'gst-plugins-good: PulseAudio 
support and good codecs' 'gst-plugins-bad: additional codecs'
+       'gst-plugins-ugly: additional codecs' 'gst-libav: libav codec')
+makedepends=(gst-plugins-base extra-cmake-modules phonon-qt4 phonon-qt5 
qt5-x11extras)
+source=("http://download.kde.org/stable/phonon/phonon-backend-gstreamer/$pkgver/phonon-backend-gstreamer-$pkgver.tar.xz";)
+sha256sums=('cec3e5ece1261d344b68363ef0606ebf49772628ba94bb55b0c0d18773b885f1')
+
+prepare() {
+  mkdir build-qt4
+  mkdir build-qt5
+}
+
+build() {
+  cd build-qt4
+  cmake ../$pkgbase-$pkgver \
+    -DCMAKE_BUILD_TYPE=Release \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DCMAKE_SKIP_RPATH=ON \
+    -D__KDE_HAVE_GCC_VISIBILITY=NO \
+    -DCMAKE_INSTALL_LIBDIR=lib
+  make
+
+  cd ../build-qt5
+  cmake ../$pkgbase-$pkgver \
+    -DCMAKE_BUILD_TYPE=Release \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DCMAKE_SKIP_RPATH=ON \
+    -DCMAKE_INSTALL_LIBDIR=lib \
+    -D__KDE_HAVE_GCC_VISIBILITY=NO \
+    -DPHONON_BUILD_PHONON4QT5=ON
+  make
+}
+
+package_phonon-qt4-gstreamer() {
+  pkgdesc="Phonon GStreamer backend for Qt4"
+  depends=(gst-plugins-base phonon-qt4)
+  provides=(phonon-qt4-backend)
+
+  cd build-qt4
+  make DESTDIR="$pkgdir" install
+
+# Conflict with -qt5
+  rm -r "$pkgdir"/usr/share/icons
+}
+
+package_phonon-qt5-gstreamer() {
+  pkgdesc="Phonon GStreamer backend for Qt5"
+  depends=(gst-plugins-base qt5-x11extras phonon-qt5)
+  provides=(phonon-qt5-backend)
+
+  cd build-qt5
+  make DESTDIR="$pkgdir" install
+}

Reply via email to