Date: Tuesday, February 13, 2018 @ 11:35:30
  Author: jsteel
Revision: 293800

archrelease: copy trunk to community-x86_64

Added:
  leatherman/repos/community-x86_64/PKGBUILD
    (from rev 293799, leatherman/trunk/PKGBUILD)
Deleted:
  leatherman/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |   86 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 43 insertions(+), 43 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-02-13 11:35:22 UTC (rev 293799)
+++ PKGBUILD    2018-02-13 11:35:30 UTC (rev 293800)
@@ -1,43 +0,0 @@
-# Maintainer: Jonathan Steel <jsteel at archlinux.org>
-
-pkgname=leatherman
-pkgver=1.3.0
-pkgrel=2
-pkgdesc="Collection of C++ and CMake utility libraries"
-arch=('x86_64')
-url="https://github.com/puppetlabs/leatherman";
-license=('APACHE')
-makedepends=('boost' 'cmake' 'rapidjson')
-checkdepends=('ruby')
-source=($pkgname-$pkgver.tar.gz::https://github.com/puppetlabs/leatherman/archive/$pkgver.tar.gz)
-md5sums=('659d2b3bc3ff34ae01b31a24bff43d21')
-
-prepare() {
-  cd $pkgname-$pkgver
-
-  # Ruby 2.3 fix: replace rb_data_object_alloc symbol with rb_data_object_wrap
-  sed -i 's/rb_data_object_alloc/rb_data_object_wrap/g' \
-    $( grep -rl rb_data_object_alloc ruby )
-}
-
-build() {
-  cd $pkgname-$pkgver
-
-  cmake -DCMAKE_INSTALL_PREFIX=/usr
-
-  make
-}
-
-check() {
-  cd $pkgname-$pkgver
-
-  make test
-}
-
-package() {
-  cd $pkgname-$pkgver
-
-  make install DESTDIR="$pkgdir"
-
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}

Copied: leatherman/repos/community-x86_64/PKGBUILD (from rev 293799, 
leatherman/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-02-13 11:35:30 UTC (rev 293800)
@@ -0,0 +1,43 @@
+# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+
+pkgname=leatherman
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Collection of C++ and CMake utility libraries"
+arch=('x86_64')
+url="https://github.com/puppetlabs/leatherman";
+license=('APACHE')
+makedepends=('boost' 'cmake' 'rapidjson')
+checkdepends=('ruby')
+source=($pkgname-$pkgver.tar.gz::https://github.com/puppetlabs/leatherman/archive/$pkgver.tar.gz)
+md5sums=('7de85c496ca0024d60df873e7ef1a462')
+
+prepare() {
+  cd $pkgname-$pkgver
+
+  # Ruby 2.3 fix: replace rb_data_object_alloc symbol with rb_data_object_wrap
+  sed -i 's/rb_data_object_alloc/rb_data_object_wrap/g' \
+    $( grep -rl rb_data_object_alloc ruby )
+}
+
+build() {
+  cd $pkgname-$pkgver
+
+  cmake -DCMAKE_INSTALL_PREFIX=/usr
+
+  make
+}
+
+check() {
+  cd $pkgname-$pkgver
+
+  make test
+}
+
+package() {
+  cd $pkgname-$pkgver
+
+  make install DESTDIR="$pkgdir"
+
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}

Reply via email to