Date: Tuesday, February 13, 2018 @ 18:07:13
  Author: arojas
Revision: 293888

archrelease: copy trunk to community-staging-x86_64

Added:
  deepin-qt5integration/repos/community-staging-x86_64/
  deepin-qt5integration/repos/community-staging-x86_64/PKGBUILD
    (from rev 293887, deepin-qt5integration/trunk/PKGBUILD)

----------+
 PKGBUILD |   33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Copied: deepin-qt5integration/repos/community-staging-x86_64/PKGBUILD (from rev 
293887, deepin-qt5integration/trunk/PKGBUILD)
===================================================================
--- community-staging-x86_64/PKGBUILD                           (rev 0)
+++ community-staging-x86_64/PKGBUILD   2018-02-13 18:07:13 UTC (rev 293888)
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Felix Yan <felixonm...@archlinux.org>
+
+pkgname=deepin-qt5integration
+pkgver=0.2.8.3
+pkgrel=3
+pkgdesc='Qt platform theme integration plugins for DDE'
+arch=('x86_64')
+url="https://github.com/linuxdeepin/qt5integration";
+license=('GPL3')
+depends=('dtkwidget' 'libqtxdg' 'qt5-styleplugins' 'deepin-qt5dxcb-plugin')
+makedepends=('xcb-util-renderutil' 'deepin-file-manager')
+replaces=('qt5dxcb-plugin')
+conflicts=('qt5dxcb-plugin')
+groups=('deepin')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/linuxdeepin/qt5integration/archive/$pkgver.tar.gz";)
+sha512sums=('f258967e6b5a2e19cd5d0f70623a7bddf286de1bbe41b139e04e523af1a093c9c2d0ff6e9a032828f6078fa8ebb408a47e94498ee8f7b9dc25663b12210b2048')
+
+prepare() {
+  cd qt5integration-$pkgver
+  sed -i 's|qt5xdgiconloader/2.0.0|qt5xdgiconloader/3.1.0|' 
platformthemeplugin/main.cpp
+}
+
+build() {
+  cd qt5integration-$pkgver
+  qmake-qt5 QMAKE_CFLAGS_ISYSTEM= PREFIX=/usr
+  make
+}
+
+package() {
+  cd qt5integration-$pkgver
+  make INSTALL_ROOT="$pkgdir" install
+}

Reply via email to