Date: Wednesday, February 14, 2018 @ 14:42:48
  Author: jgc
Revision: 317010

upgpkg: poppler 0.62.0-1

Drop poppler-qt4

Modified:
  poppler/trunk/PKGBUILD

----------+
 PKGBUILD |   29 ++++++++---------------------
 1 file changed, 8 insertions(+), 21 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2018-02-14 14:30:15 UTC (rev 317009)
+++ PKGBUILD    2018-02-14 14:42:48 UTC (rev 317010)
@@ -3,12 +3,12 @@
 # Maintainer: Jan de Groot <j...@archlinux.org>
 
 pkgbase=poppler
-pkgname=('poppler' 'poppler-glib' 'poppler-qt4' 'poppler-qt5')
-pkgver=0.61.1
+pkgname=('poppler' 'poppler-glib' 'poppler-qt5')
+pkgver=0.62.0
 pkgrel=1
 arch=(x86_64)
 license=('GPL')
-makedepends=('libjpeg' 'gcc-libs' 'cairo' 'fontconfig' 'openjpeg2' 'gtk3' 
'qt4' 'pkgconfig' 'lcms2' 
+makedepends=('libjpeg' 'gcc-libs' 'cairo' 'fontconfig' 'openjpeg2' 'gtk3' 
'pkgconfig' 'lcms2' 
              'gobject-introspection' 'icu' 'qt5-base' 'git' 'nss' 'gtk-doc' 
'curl' 'poppler-data'
              'cmake' 'python2') # python2 just for make-glib-api-docs/gtkdoc.py
 options=('!emptydirs')
@@ -16,7 +16,7 @@
 source=(https://poppler.freedesktop.org/${pkgbase}-${pkgver}.tar.xz
         
test::git+https://anongit.freedesktop.org/git/poppler/test/#commit=0d2bfd4
         gtk-doc.patch)
-sha256sums=('1266096343f5163c1a585124e9a6d44474e1345de5cdfe55dc7b47357bcfcda9'
+sha256sums=('5b9a73dfd4d6f61d165ada1e4f0abd2d420494bf9d0b1c15d0db3f7b83a729c6'
             'SKIP'
             '4032a01456e2372e8f7c805f18634437285ce703fbcfe0fc9a3884ac39edc9ee')
 
@@ -49,15 +49,15 @@
   pkgdesc="PDF rendering library based on xpdf 3.0"
   depends=('libjpeg' 'gcc-libs' 'cairo' 'fontconfig' 'openjpeg2' 'lcms2' 'nss' 
'curl')
   optdepends=('poppler-data: encoding data to display PDF documents containing 
CJK characters')
-  conflicts=("poppler-qt3<${pkgver}")
+  conflicts=("poppler-qt3<${pkgver}" "poppler-qt4<${pkgver}")
 
   cd build
   make DESTDIR="${pkgdir}" install
 
   # cleanup for splitted build
-  rm -vrf "${pkgdir}"/usr/include/poppler/{glib,qt4,qt5}
-  rm -vf "${pkgdir}"//usr/lib/libpoppler-{glib,qt4,qt5}.*
-  rm -vf "${pkgdir}"/usr/lib/pkgconfig/poppler-{glib,qt4,qt5}.pc
+  rm -vrf "${pkgdir}"/usr/include/poppler/{glib,qt5}
+  rm -vf "${pkgdir}"//usr/lib/libpoppler-{glib,qt5}.*
+  rm -vf "${pkgdir}"/usr/lib/pkgconfig/poppler-{glib,qt5}.pc
   rm -vrf "${pkgdir}"/usr/{lib,share}/gir*
   rm -vrf "${pkgdir}"/usr/share/gtk-doc
 }
@@ -75,19 +75,6 @@
   rm -vf "${pkgdir}/usr/bin/poppler-glib-demo"
 }
 
-package_poppler-qt4() {
-  pkgdesc="Poppler Qt4 bindings"
-  provides=("poppler-qt=${pkgver}")
-  replaces=('poppler-qt')
-  conflicts=('poppler-qt')
-  depends=("poppler=${pkgver}" 'qt4')
-
-  cd build
-  make -C qt4 DESTDIR="${pkgdir}" install
-  install -m755 -d "${pkgdir}/usr/lib/pkgconfig"
-  install -m644 poppler-qt4.pc "${pkgdir}/usr/lib/pkgconfig/"
-}
-
 package_poppler-qt5() {
   pkgdesc="Poppler Qt5 bindings"
   depends=("poppler=${pkgver}" 'qt5-base')

Reply via email to