Date: Friday, February 23, 2018 @ 14:34:17
  Author: anthraxx
Revision: 317425

archrelease: copy trunk to extra-x86_64

Added:
  postgresql-old-upgrade/repos/extra-x86_64/PKGBUILD
    (from rev 317424, postgresql-old-upgrade/trunk/PKGBUILD)
Deleted:
  postgresql-old-upgrade/repos/extra-x86_64/PKGBUILD

----------+
 PKGBUILD |  104 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 52 insertions(+), 52 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-02-23 14:34:09 UTC (rev 317424)
+++ PKGBUILD    2018-02-23 14:34:17 UTC (rev 317425)
@@ -1,52 +0,0 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Maintainer: Dan McGee <d...@archlinux.org>
-
-pkgname=postgresql-old-upgrade
-pkgver=9.6.6
-_majorver=${pkgver%.*}
-pkgrel=1
-pkgdesc='PostgreSQL build for migrating between major versions with pg_upgrade'
-url='https://www.postgresql.org/'
-arch=('x86_64')
-license=('custom:PostgreSQL')
-depends=("postgresql-libs>=${_majorver}" 'libxml2' 'openssl>=1.0.0' 'pam' 
'zlib')
-makedepends=('krb5' 'python2' 'perl' 'tcl>=8.6.0')
-source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2)
-sha256sums=('399cdffcb872f785ba67e25d275463d74521566318cfef8fe219050d063c8154')
-sha512sums=('ac2f0fe6ef7c4e14f85cd7592d1306d9657b7f35efa6f43a089d7785ab970b8c25aa1e66d83df056c23513d6dbac0a9f54717b3d85758560d02e7f8141914ebc')
-
-build() {
-  cd postgresql-${pkgver}
-  ./configure \
-    --prefix=/opt/pgsql-${_majorver} \
-    --with-gssapi \
-    --with-libxml \
-    --with-openssl \
-    --with-perl \
-    --with-python PYTHON=/usr/bin/python2 \
-    --with-tcl \
-    --with-pam \
-    --without-readline \
-    --with-system-tzdata=/usr/share/zoneinfo \
-    --with-uuid=e2fs \
-    --disable-nls \
-    --enable-thread-safety
-  make -C src all
-  make -C contrib all
-}
-
-package() {
-  cd postgresql-${pkgver}
-
-  # install
-  make -C src DESTDIR="${pkgdir}" install
-  make -C contrib DESTDIR="${pkgdir}" install
-
-  # install license
-  install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
-
-  # clean up unneeded installed items
-  rm -rf "${pkgdir}/opt/pgsql-${_majorver}/include"
-}
-
-# vim: ts=2 sw=2 et:

Copied: postgresql-old-upgrade/repos/extra-x86_64/PKGBUILD (from rev 317424, 
postgresql-old-upgrade/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-02-23 14:34:17 UTC (rev 317425)
@@ -0,0 +1,52 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Maintainer: Dan McGee <d...@archlinux.org>
+
+pkgname=postgresql-old-upgrade
+pkgver=9.6.7
+_majorver=${pkgver%.*}
+pkgrel=1
+pkgdesc='PostgreSQL build for migrating between major versions with pg_upgrade'
+url='https://www.postgresql.org/'
+arch=('x86_64')
+license=('custom:PostgreSQL')
+depends=("postgresql-libs>=${_majorver}" 'libxml2' 'openssl>=1.0.0' 'pam' 
'zlib')
+makedepends=('krb5' 'python2' 'perl' 'tcl>=8.6.0')
+source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2)
+sha256sums=('2ebe3df3c1d1eab78023bdc3ffa55a154aa84300416b075ef996598d78a624c6')
+sha512sums=('6a66cdd5b74ea6dc95628b89bb7663555370be56b3e938f635950628ad5d77443ac8f40c747be1fc1cfc19ca8b0a27f41e52fe4db83a43c7a7bab9bb076c7844')
+
+build() {
+  cd postgresql-${pkgver}
+  ./configure \
+    --prefix=/opt/pgsql-${_majorver} \
+    --with-gssapi \
+    --with-libxml \
+    --with-openssl \
+    --with-perl \
+    --with-python PYTHON=/usr/bin/python2 \
+    --with-tcl \
+    --with-pam \
+    --without-readline \
+    --with-system-tzdata=/usr/share/zoneinfo \
+    --with-uuid=e2fs \
+    --disable-nls \
+    --enable-thread-safety
+  make -C src all
+  make -C contrib all
+}
+
+package() {
+  cd postgresql-${pkgver}
+
+  # install
+  make -C src DESTDIR="${pkgdir}" install
+  make -C contrib DESTDIR="${pkgdir}" install
+
+  # install license
+  install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+  # clean up unneeded installed items
+  rm -rf "${pkgdir}/opt/pgsql-${_majorver}/include"
+}
+
+# vim: ts=2 sw=2 et:

Reply via email to