Date: Tuesday, March 6, 2018 @ 12:18:11
  Author: dvzrv
Revision: 303067

archrelease: copy trunk to community-x86_64

Added:
  audacity/repos/community-x86_64/PKGBUILD
    (from rev 303066, audacity/trunk/PKGBUILD)
Deleted:
  audacity/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |   95 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 48 insertions(+), 47 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-03-06 12:18:00 UTC (rev 303066)
+++ PKGBUILD    2018-03-06 12:18:11 UTC (rev 303067)
@@ -1,47 +0,0 @@
-# $Id$
-# Maintainer: David Runge <d...@sleepmap.de>
-# Contributor: Eric Bélanger <e...@archlinux.org>
-
-pkgname=audacity
-pkgver=2.2.1
-pkgrel=2
-pkgdesc="A program that lets you manipulate digital audio waveforms"
-arch=('x86_64')
-url="https://audacityteam.org";
-license=('GPL2' 'CCPL')
-depends=('libmad' 'libid3tag' 'wxgtk3' 'lame' 'soundtouch'
-         'ffmpeg' 'vamp-plugin-sdk' 'portsmf' 'twolame' 'suil' 'lilv') # sbsms 
- needs unreleased version
-makedepends=('cmake')
-source=("https://github.com/${pkgname}/${pkgname}/archive/Audacity-${pkgver}.tar.gz";)
-sha512sums=('5f3e17aa5f39210f1440f49e19835bc6f2b6ab1bb58cee989dd2aa46cbcaf82eaa01037a8ee9e3a419741a34ae00c0325da33f017d83be531654032797ac7edd')
-
-prepare() {
-  cd "${pkgname}-Audacity-${pkgver}"
-  autoreconf -vi
-}
-
-build() {
-  cd "${pkgname}-Audacity-${pkgver}"
-  WX_CONFIG=wx-config-gtk3 ./configure --prefix="/usr" \
-    --with-libsndfile="system" \
-    --with-ffmpeg="system" \
-    --with-expat="system" \
-    --with-lame="system" \
-    --with-libsoxr="system" \
-    --with-libclac \
-    --with-libid3tag \
-    --with-libsamplerate \
-    --with-sbsms \
-    --with-soundtouch \
-    --with-libtwolame \
-    --with-libvorbis \
-    --with-lv2 \
-    --with-portaudio \
-    --with-portmidi
-  make
-}
-
-package() {
-  cd "${pkgname}-Audacity-${pkgver}"
-  make DESTDIR="${pkgdir}" install
-}

Copied: audacity/repos/community-x86_64/PKGBUILD (from rev 303066, 
audacity/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-03-06 12:18:11 UTC (rev 303067)
@@ -0,0 +1,48 @@
+# $Id$
+# Maintainer: David Runge <d...@sleepmap.de>
+# Contributor: Eric Bélanger <e...@archlinux.org>
+
+pkgname=audacity
+pkgver=2.2.2
+pkgrel=1
+pkgdesc="A program that lets you manipulate digital audio waveforms"
+arch=('x86_64')
+url="https://audacityteam.org";
+license=('GPL2' 'CCPL')
+depends=('libmad' 'libid3tag' 'wxgtk3' 'lame' 'soundtouch'
+         'ffmpeg' 'vamp-plugin-sdk' 'portsmf' 'twolame' 'suil' 'lilv') # sbsms 
- needs unreleased version
+makedepends=('cmake')
+source=("https://github.com/${pkgname}/${pkgname}/archive/Audacity-${pkgver}.tar.gz";)
+sha512sums=('311a5f3413e7faf40dc5639b2b9f8b0d03d1a410c50d894ca7abf3fe5733a29b710ccf7e3215d97dd9142e93c0ab5e13955dfd13146b03f927f74465459a6457')
+
+prepare() {
+  mv -v "${pkgname}-Audacity-${pkgver}" "${pkgname}-${pkgver}"
+  cd "${pkgname}-${pkgver}"
+  autoreconf -vi
+}
+
+build() {
+  cd "${pkgname}-${pkgver}"
+  WX_CONFIG=wx-config-gtk3 ./configure --prefix="/usr" \
+    --with-libsndfile="system" \
+    --with-ffmpeg="system" \
+    --with-expat="system" \
+    --with-lame="system" \
+    --with-libsoxr="system" \
+    --with-libclac \
+    --with-libid3tag \
+    --with-libsamplerate \
+    --with-sbsms \
+    --with-soundtouch \
+    --with-libtwolame \
+    --with-libvorbis \
+    --with-lv2 \
+    --with-portaudio \
+    --with-portmidi
+  make
+}
+
+package() {
+  cd "${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+}

Reply via email to