Date: Wednesday, March 7, 2018 @ 09:24:21
  Author: dvzrv
Revision: 303544

upgpkg: python-nose2 0.7.4-1

Upgrading to 0.7.4. Including necessary depends.

Modified:
  python-nose2/trunk/PKGBUILD

----------+
 PKGBUILD |   10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2018-03-07 09:23:43 UTC (rev 303543)
+++ PKGBUILD    2018-03-07 09:24:21 UTC (rev 303544)
@@ -4,8 +4,8 @@
 _name=nose2
 pkgbase=python-nose2
 pkgname=('python-nose2' 'python2-nose2')
-pkgver=0.6.5
-pkgrel=3
+pkgver=0.7.4
+pkgrel=1
 pkgdesc="The next generation of nicer testing for python"
 arch=('any')
 url="https://github.com/nose-devs/nose2";
@@ -12,7 +12,7 @@
 license=('BSD')
 makedepends=('python-setuptools' 'python2-setuptools')
 
source=("${pkgname[0]}-${pkgver}.tar.gz::https://github.com/nose-devs/${_name}/archive/${pkgver}.tar.gz";)
-sha512sums=('05a22d6a4950f58dd4fcef9564c63ac2d23aa946a49ebc45fd78cd6ae01f2a46d669caced4ac8615b74a7baa1063f7d776b15b42758434cc1d509b8658c11b03')
+sha512sums=('693ae9c9fff5b3add269579a6c29863b616a5d2f33044d655407c9e50cf2df4e8eed3be2c0f47cf71f222fabe3d52da7bd40492880c64107557b30a928606e4f')
 
 prepare() {
   mv -v "${_name}-${pkgver}" "${pkgname[0]}-${pkgver}"
@@ -27,7 +27,7 @@
 }
 
 package_python-nose2() {
-  depends=('python-six')
+  depends=('python-coverage' 'python-six')
   cd "${pkgname[0]}-${pkgver}"
   python setup.py install --skip-build \
     --optimize=1 \
@@ -42,7 +42,7 @@
 }
 
 package_python2-nose2() {
-  depends=('python2-six')
+  depends=('python2-coverage' 'python2-mock' 'python2-six')
   cd "${pkgname[1]}-${pkgver}"
   python2 setup.py install --skip-build \
     --optimize=1 \

Reply via email to