Date: Tuesday, March 13, 2018 @ 15:18:19
  Author: arojas
Revision: 307301

archrelease: copy trunk to community-x86_64

Added:
  cysignals/repos/community-x86_64/PKGBUILD
    (from rev 307300, cysignals/trunk/PKGBUILD)
Deleted:
  cysignals/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |   92 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 46 insertions(+), 46 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-03-13 15:17:56 UTC (rev 307300)
+++ PKGBUILD    2018-03-13 15:18:19 UTC (rev 307301)
@@ -1,46 +0,0 @@
-# $Id$
-# Maintainer: Antonio Rojas <aro...@archlinux.org>
-
-pkgbase=cysignals
-pkgname=(python-cysignals python2-cysignals)
-pkgver=1.6.8
-pkgrel=1
-pkgdesc="Interrupt and signal handling for Cython"
-arch=(x86_64)
-url="https://www.sagemath.org";
-license=(LGPL)
-makedepends=(cython2 cython pari)
-source=("https://github.com/sagemath/cysignals/releases/download/$pkgver/$pkgbase-$pkgver.tar.gz";)
-sha256sums=('4d0c7b035edc1d7ac5b4e4264021b5cf06b6f501b328d9892af102caabe50604')
-
-prepare() {
-  cp -r $pkgbase-$pkgver{,-py2}
-}
-
-build() {
-  cd $pkgbase-$pkgver
-  python setup.py build
-
-  cd "$srcdir"/$pkgbase-$pkgver-py2
-  python2 setup.py build
-}
-
-package_python-cysignals() {
-  depends=(python pari)
-
-  cd $pkgbase-$pkgver
-  python setup.py install --root="$pkgdir"
-
-# Keep scripts in python2 package
-  rm -r "$pkgdir"/usr/bin
-}
-
-package_python2-cysignals() {
-  depends=(python2 pari)
-  conflicts=(cysignals)
-  provides=(cysignals)
-  replaces=(cysignals)
-
-  cd $pkgbase-$pkgver-py2   
-  python2 setup.py install --root="$pkgdir"
-}

Copied: cysignals/repos/community-x86_64/PKGBUILD (from rev 307300, 
cysignals/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-03-13 15:18:19 UTC (rev 307301)
@@ -0,0 +1,46 @@
+# $Id$
+# Maintainer: Antonio Rojas <aro...@archlinux.org>
+
+pkgbase=cysignals
+pkgname=(python-cysignals python2-cysignals)
+pkgver=1.6.9
+pkgrel=1
+pkgdesc="Interrupt and signal handling for Cython"
+arch=(x86_64)
+url="https://www.sagemath.org";
+license=(LGPL)
+makedepends=(cython2 cython pari)
+source=("https://github.com/sagemath/cysignals/releases/download/$pkgver/$pkgbase-$pkgver.tar.gz";)
+sha256sums=('08a4a2b6e5ba627c077eb335a55909f7f7e97be61b95b12881c1e31eedb67100')
+
+prepare() {
+  cp -r $pkgbase-$pkgver{,-py2}
+}
+
+build() {
+  cd $pkgbase-$pkgver
+  python setup.py build
+
+  cd "$srcdir"/$pkgbase-$pkgver-py2
+  python2 setup.py build
+}
+
+package_python-cysignals() {
+  depends=(python pari)
+
+  cd $pkgbase-$pkgver
+  python setup.py install --root="$pkgdir"
+
+# Keep scripts in python2 package
+  rm -r "$pkgdir"/usr/bin
+}
+
+package_python2-cysignals() {
+  depends=(python2 pari)
+  conflicts=(cysignals)
+  provides=(cysignals)
+  replaces=(cysignals)
+
+  cd $pkgbase-$pkgver-py2   
+  python2 setup.py install --root="$pkgdir"
+}

Reply via email to