Date: Tuesday, March 13, 2018 @ 17:54:30
  Author: archange
Revision: 307413

upgpkg: nodejs-lts-carbon 8.10.0-1

Switch to OpenSSL 1.1 since upstream added support.
Revert to SHA256 because this is what upstream provides as GPG signed.

Modified:
  nodejs-lts-carbon/trunk/PKGBUILD

----------+
 PKGBUILD |    9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2018-03-13 17:47:17 UTC (rev 307412)
+++ PKGBUILD    2018-03-13 17:54:30 UTC (rev 307413)
@@ -1,13 +1,13 @@
 # Maintainer: Bruno Pagani (a.k.a. ArchangeGabriel) <archa...@archlinux.org>
 
 pkgname=nodejs-lts-carbon
-pkgver=8.9.4
-pkgrel=2
+pkgver=8.10.0
+pkgrel=1
 pkgdesc='Evented I/O for V8 javascript (LTS release: Carbon)'
 arch=('x86_64')
 url="https://nodejs.org/";
 license=('MIT')
-depends=('openssl-1.0' 'zlib' 'icu' 'libuv' 'http-parser' 'c-ares')
+depends=('openssl' 'zlib' 'icu' 'libuv' 'http-parser' 'c-ares')
 makedepends=('python2' 'procps-ng')
 optdepends=('npm: nodejs package manager')
 provides=("nodejs=$pkgver")
@@ -14,7 +14,7 @@
 conflicts=('nodejs')
 source=("${url}/dist/v${pkgver}/node-v${pkgver}.tar.xz")
 # https://nodejs.org/download/release/latest-carbon/SHASUMS256.txt.asc
-sha512sums=('9656b57145c2b3048ff9ad70f91dbff33a7349dca564efe3b2ff585e2ffad004ea8de920a7a049ff4c5487683986d78b5a578306c2c99f3b1a3de96d9ad1dece')
+sha256sums=('b72d4e71618d6bcbd039b487b51fa7543631a4ac3331d7caf69bdf55b5b2901a')
 #validpgpkeys=('C4F0DFFF4E8C1A8236409D08E73BC641CC11F4C8'  # Myles Borins 
<mylesbor...@google.com>
 #              '77984A986EBC2AA786BC0F66B01FBB92821C587A') # Gibson Fahnestock 
<gibf...@gmail.com>
 
@@ -35,7 +35,6 @@
 build() {
   cd node-v${pkgver}
 
-  export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
   export PYTHON=python2
   ./configure \
     --prefix=/usr \

Reply via email to